"No more Internet handles can be allocated" error from "Windows Explorer" FTP client. RRS feed

  • Întrebare

  • While using "Windows Explorer" as an FTP client I have put the system into a state where any attempts to access an FTP folder from "Windows Explorer" produces the following dialog:

    Dialog Title: "FTP Folder Error"
    Dialog Icon: Information Icon
    Dialog Text: "Windows cannot access this folder.  Make sure you typed the file name correctly and that you have permission to access the folder.  Details: No more Internet handles can be allocated"
    Dialog Buttons: OK

    I had used the "Add a network location" feature of "Windows Explorer" to add an FTP site.  The FTP folder appears under "Computer" in the left panel of "Windows Explorer."  It is not mapped to a drive letter.  I then initiated a large FTP transfer operation by using drag-and-drop from the FTP folder to a local folder.  A portion of the transfer completed as expected but after some time it produced the "No more Internet handles can be allocated" error.  When OK was clicked the transfer was terminated.  In this case I am using large to refer to many thousands of files and directories to be transferred as opposed to a small count of files having many bytes.

    After the initial error dialog is cleared with the OK button and the transfer is terminated I can then reliably reproduce the dialog.  Any attempt to open an FTP network location from "Windows Explorer" will produce a new dialog with the error.

    I am unfamiliar with the implementation of FTP network locations in "Windows Explorer" however my initial guess is that the transfer of many files and folders consumes a finite resource of Internet handles.  This is not an inherent limitation of the FTP protocol but rather appears to be a defect in the implementation of the FTP client in "Windows Explorer."  If this is the situation then it seems the appropriate action is to file a bug report with Microsoft.  Please let me know if this is a reasonable assessment of the error or if something else might be causing the problem.  I have not rebooted the test system yet however I presume that a reboot will clear the allocated handles and thus resolve the issue until they are consumed again.

    Test Case System: Microsoft Windows 7 Professional 64-bit with all updates applied as of September 22, 2010.

    miercuri, 22 septembrie 2010 15:29

Toate mesajele

  • Hi,


    Can you open the FTP via the Run box?

    Based on my research, error message "No more Internet handles can be allocated" indicates that the Internet server does not have enough available resources to support the request for service at this time. You may try again later. Sometimes this kind of error could be caused by third party application running on your computer. Please perform a Clean Boot and Safe Mode with Networking for a try.

    Best Regards


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    vineri, 24 septembrie 2010 03:58
  • Thanks for the reply Dale.  Unfortunately I have since rebooted the test case system so I am unable to determine if the Command Prompt FTP interface may have worked even when the Windows Explorer FTP interface was put into the error state.  If I get the system into the error state again I will test the Command Prompt FTP interface and let you know the results.

    I performed a normal reboot rather than a Clean Boot and Safe Mode with Networking.  The normal reboot cleared the error state I am now able to reconnect to FTP servers.

    Searching for "No more Internet handles can be allocated" returns a few hits.  The Microsoft TechNet article at [] reports that an event message containing this string can be produced by Microsoft Internet Security and Acceleration Server.  The server I was connecting to when I received the error was the GoDaddy Grid Linux hosting server.  When the Windows 7 client system was in the error state I also attempted to initiate a connection to the GoDaddy Online File Folder server and this produced the same error dialog.  This led me to believe that the error was on the client side and potentially a defect in Windows 7 rather than on both FTP servers (although GoDaddy may be using a single FTP server for both products; I am not familiar with their deployment architecture).

    Please let me know if there are any logs or other protocol level details I could explore to debug more fully.  Thanks for the assistance.

    luni, 27 septembrie 2010 14:56
  • This is a bug in Internet Explorer 9 and it is still occurring. I was able to put a file using ftp from the command prompt, so it does not appear to be blocking all FTP traffic. The problem is cleared by a normal reboot and will come back again after more than a thousand files are copied to the FTP site. By the way, is is it even possible to report a bug to Microsoft?
    joi, 7 februarie 2013 06:39
  • This is not a bug in the ftp server. I run into the same issue when trying to copy large amounts of files from an ftp server of mine. I was using Windows 10 explorer.exe as an ftp client. At some point during the copy process, 'no more internet handles could be allocated'. The folder I was coping from server had 22,294 Files, 3,323 Folders.

    I don't see any problem in windows having a so-called 'handle limit'. The real problem is that it does not recover from this situation, it does not release used handles. After this problem had happened, I could not access any other ftp site, the same message of exhausted internet handles was displayed. Even waiting until the next day, the 'internet handles' were still not available. Only rebooting the client machine released the handles and made it possible to me to access ftp sites again. The server was not rebooted, only the client, then things went back to normal. The problem is, since windows does not release these handles, one can run into this problem even if copying only modest amounts of files. They only need to do it enough times, and will eventually hit the limit. And at this point only rebooting can fix their problem.

    I think it is a serious bug in explorer.exe that needs to be fixed.

    joi, 13 iulie 2017 14:36
  • I had the same problem. A quick fix is to open Task Manager, right click on Windows Explorer and select "Restart". From here you can use the FTP in Explorer again.
    sâmbătă, 19 octombrie 2019 05:43