locked
Mapped drive will not disconnect RRS feed

  • Întrebare

  • I have a computer running Windows 7 Enterprise with a network drive mapped to another commuter running Windows XP Professional. The C drive in the computer with XP went bad and the computer was replaced. However I cannot disconnect the mapped drive.

    If I try to disconnect it using the context menu option in Windows Explorer it brings up a dialog box that says, "This network connection does not exist," and does not disconnect it. I have also tried to disconnect it from the command line:

    C:\>net use Z: /delete
    The network connection could not be found.
    More help is available by typing NET HELPMSG 2250.
    
    C:\>net helpmsg 2250
    The network connection could not be found.
    
    C:\>

    This problem is very annoying. Please help.

    marți, 11 octombrie 2011 00:42

Răspunsuri

  • In cmd windows, you can directly type command 'net use' to see the net connection.

    If the Z: doesn't existed in the list, 'the network connection could not be found' is normal.

    And you can directly define a new network location to Z:.

    • Marcat ca răspuns de Juke Chou miercuri, 26 octombrie 2011 03:39
    marți, 11 octombrie 2011 07:45
  • once you replace you can delete the mapped drive now..
    Regards, h9ck3r.
    • Marcat ca răspuns de Juke Chou miercuri, 26 octombrie 2011 03:39
    marți, 11 octombrie 2011 17:09

Toate mesajele

  • In cmd windows, you can directly type command 'net use' to see the net connection.

    If the Z: doesn't existed in the list, 'the network connection could not be found' is normal.

    And you can directly define a new network location to Z:.

    • Marcat ca răspuns de Juke Chou miercuri, 26 octombrie 2011 03:39
    marți, 11 octombrie 2011 07:45
  • It still showed up in the list but would not let me disconnect it. However, it replaced it just fine. Thank you.

    marți, 11 octombrie 2011 14:14
  • once you replace you can delete the mapped drive now..
    Regards, h9ck3r.
    • Marcat ca răspuns de Juke Chou miercuri, 26 octombrie 2011 03:39
    marți, 11 octombrie 2011 17:09
  • I was experiencing a similar problem on my computer. The root of the issue is that the drives where initially mapped when explorer.exe was started. As you said, after "disconnecting" them they still appeared in My Computer but not "net use". Restarting explorer.exe at this point removed the drives from My Computer.
    • Propus ca răspuns de Skills vineri, 6 iulie 2012 21:44
    vineri, 13 aprilie 2012 13:23
  • That's the ticket! KISS! (Keep It Simple Stupid) I remember this from my Novell instructor. I am definitely going to put this in my HOW TO's Thank you Robert Greer!
    • Editat de Skills vineri, 6 iulie 2012 21:46
    • Propus ca răspuns de Change2009 sâmbătă, 17 iunie 2017 03:51
    vineri, 6 iulie 2012 21:44
  • This worked for me as well. 

    Thanks Robert!

    luni, 23 iulie 2012 20:07
  • I've tried both solutions, I've tried remapping the drive (net use Z: \\myServer\myShare\), restarting explorer and the computer. It still shows the disconnected drive and I can't delete it. Anybody else have this issue? Thanks.

    joi, 14 martie 2013 20:05
  • I have a similar issue on Server 2012, but when net use is run it shows "There are no entries in the list." but shows in Windows Explorer. Restarting Server and explorer.exe does not change anything?!
    marți, 9 aprilie 2013 06:50
  • I have a client running Windows 7 connected to SBS 2011 Essentials. Mapped drives to previous server persist as icons in Windows Explorer and can't be deleted even though I used net use to delete the drive letter mappings. I have been able to map new letters to the shared folders on the new server but can't get rid of the red X icons no matter what I try, including the suggestion to net use the same drive letter and then try and disconnect.

    Any suggestions would be appreciated!

    Thanks. 

    Michael

    vineri, 26 aprilie 2013 17:01
  • I tried all described above, but nothing worked. But somewhere I found that "Net Use /Persistent:yes" would set all current drives to persistent. I tried "Net Use /Persistent:no", booted and that one driveletter was gone at last. May be that will do the trick for you????

    Leo Koolsbergen

     
    joi, 2 mai 2013 06:52
  • Microsoft: There are multiple bugs here, at least to the rest of the world.  Please correct them anyway. 

    -> If 'net use' reports no drives, neither should Explorer. 

    -> A refresh in Explorer should remove the disconnected drives, if 'net use x: /delete' alone doesn't do it -- but it should.

    -> The Explorer context menu 'Disconnect' should remove them also.

    luni, 15 iulie 2013 17:20
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    • Propus ca răspuns de TonyVov sâmbătă, 27 iulie 2013 01:52
    sâmbătă, 27 iulie 2013 01:51
  • I have tried this but no luck - I still see Disconnected Network Drive (V:) in explorer. Also tried a restart and settings /persistent:No and Yes.

    Is there any place I can escalate this to Microsoft and not be charged Pro Support fee for?

    duminică, 28 iulie 2013 22:32
  • the batchfile worked great. 

    thanks


    Marcia Henry

    vineri, 6 septembrie 2013 02:14
  • Was having a similiar issue and this little batch file worked like a charm!

    Thanks

    • Propus ca răspuns de tommmyyyyyyyy luni, 23 noiembrie 2015 15:53
    vineri, 4 octombrie 2013 15:25
  • I have the same issue on Win 7. This drive is our home drive from AD.

    The one factor I see is that all other drive mappings show as "Microsoft Windows Network" whereas this one mapping shows as NFS network. Perhaps this has something to do with it.

    I can map the drive as letter Z and it works. It is mapped as drive P and will not allow me to access. System error 85.

    Status       Local     Remote                    Network

    -------------------------------------------------------------------------------
    OK           J:        \\t70nas301\home\jpanik   Microsoft Windows Network
    OK           N:        \\T01FAP01\ISDATA         Microsoft Windows Network
                    P:        \\t70nas301\home\JPANIK   NFS Network
    OK           Q:        \\T70NAS301\PUBLIC\PUBLIC Microsoft Windows Network
    OK           R:        \\T70NAS401\SHARED\SHARED Microsoft Windows Network
    OK           S:        \\T70NAS301\SHARED        Microsoft Windows Network
    OK           Z:        \\t70nas301\home\jpanik   Microsoft Windows Network
    The command completed successfully.

    joi, 31 octombrie 2013 19:03
  • ANSWER:
    In HKEY_CURRENT_USER\Network the key for the drive does nto exist.
    Exported one of the other keys for a drive mapping and edited the content to match that of my locked drive.

    [HKEY_CURRENT_USER\Network\P]
    "RemotePath"="\\\\t70nas301\\home\\jpanik"
    "UserName"=dword:00000000
    "ProviderName"="Microsoft Windows Network"
    "ProviderType"=dword:00020000
    "ConnectionType"=dword:00000001
    "DeferFlags"=dword:00000004

    add this to a REG file and merge the data.
    Once this is done, click the drive mapping and the error is that the drive is not available, you can now disconnect the mapping.

    • Propus ca răspuns de Jimm Panik joi, 31 octombrie 2013 19:10
    joi, 31 octombrie 2013 19:10
  • Just log-off or restart the system it will go off.
    miercuri, 6 noiembrie 2013 13:17
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.


    DOS Vader

    • Propus ca răspuns de Whizzy42 marți, 28 octombrie 2014 17:29
    vineri, 6 decembrie 2013 21:14
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.


    DOS Vader

    Worked for me as the mapped drive was created using Task Scheduler with user System. Was unable to get rid of the share unless I umount it with a script just as I mounted it (nfs share). +1
    luni, 16 decembrie 2013 06:46
  • it works! thanks a lot
    luni, 3 februarie 2014 11:55
  • The easiest way to fix this problem is to edit the regedit , it so simple.

    open regedit

    Go to HKEY_CURRENT_USER/Network

    Now remove the letter you want in this case X, and restart the computer. issue is fixed.


    duminică, 16 februarie 2014 11:20
  • There appear to be a multitude of people with the same issue and a multitude of solutions offered by others.  I tried just about all of them but to no avail, including all the registry changes, net use commands, rebooting, restarting Explorer etc etc.  In the end, the only solution that allowed me to actually disconnect my network drive and remove it from displaying in explorer was the following:  remove the offending PC from the network Domain (ie. join a workgroup), login as a local administrator, then you can disconnect the offending drives.  Then re-register the PC to your Domain as per normal and you will find that the offending drives are gone and you can re-establish your required network mappings.
    miercuri, 5 martie 2014 06:21
  • Thanks DOS Vader - yours was the only method that worked for me. Possibly because in my case the drive letter was mapped to a NAS share?

    Tangata_Manu

    vineri, 28 martie 2014 18:28
  • Thanks!  Worked.
    luni, 14 aprilie 2014 15:04
  • @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    Working fine for me, keep mind to run it like administrator

    Alejo

    marți, 3 iunie 2014 12:54
  • Brilliant, this helped me resolve the issue.
    marți, 17 iunie 2014 13:45
  • This is a serious bug in Windows Explorer, and I'm very much surprised that Microsoft failed to address it for so long:
    All workarounds posted here or else where basically work by killing Explorer, or worse still by rebooting Windows. This is ridiculous :-(

    This bug has been in all versions of Windows since at least Windows XP. For example, here's a 2006 post that reports exactly the symptoms I'm having today with Windows 8: http://www.pcreview.co.uk/forums/getting-rid-disconnected-network-drives-explorer-t2414089.html

    As in that 2006 example, I'm regularly affected by the consequence, where Windows Explorer reports the OLD share name (the one that refused to go away after the drive became disconnected) even after the same drive letter is mapped on a DIFFERENT share. This is really a serious issue, as this can potentially lead to data loss, by misleading the user to copy or erase data on the wrong shares!!!

    Mr Microsoft, how can we officially enter this bug in your bug tracking databases, and make sure that Windows Explorer gets fixed at last?
    (That means fixing the three symptoms of the problem reported by chiptech above, plus the fourth I report here.)
    (And please no more suggestions for workarounds. It's a fix preventing the issue from reoccuring that we need, not yet another time consuming method for repairing Explorer after it starts displaying false information.)

    Jean-François

    luni, 7 iulie 2014 10:30
  • I was going to give this one a try but there are no entries under HKEY_CURRENT_USER\Network (I even added another mapping to see if one would show up - nope).
    marți, 19 august 2014 15:13
  • Leaving and re-joining the domain was my "last resort" - it didn't work either.

    marți, 19 august 2014 15:15
  • This was the one for us : running a scheduled task. Importantly I believe that this was because the network drive was created by the system account and ultimately regardless of enhanced permissions it would not delete as any other user.

    By simply running the scheduled task as that same system user I was able to remove the mapped drive through a scheduled task.

    Thanks

    vineri, 29 august 2014 17:54
  • s this just a bug in explorer, I wonder. This is why:
    A user (win8.1) did not have, through an oversight, the rights to a certain share. So I made a mapping using different user-credentials, which at least provided the user with reading-rights. When the oversight had been corrected (the user now had read/write access to the share) I wanted to re-do the mapping. So i tried to delete it, but ran into the situation more-or-less as described here: in explorer, drive has red cross; in the registry, drive is not to be found; under 'net use', drive is not listed; in a cmd-window, drive does not exist. (By the way: if this is just an explorer issue, then how come the drive doesn't exist in a cmd-window?) Then I tried to just re-map the driveletter, this time using the user's own credentials, without first disconnecting. This SEEMED to work, but in fact, access was still read-only! Then - here it gets hairy - I tried mapping to that share using a different driveletter: the mapping was read-only! Suspecting that somehow first completely deleting the driveletter was essential, I tried most of the above tricks - to no avail.
    What finally worked was, especially under my 20/20 hindsight vision, very simple: first re-mapping the offending driveletter to a different share, then to the right share again. Not only did the drive have write-access, but now I could delete the mapping in the normal way by just disconnecting in win explorer.
    vineri, 17 octombrie 2014 17:02
  • DOS Vader's  scheduled Task option  

    This was the only solution that worked for me...

    marți, 28 octombrie 2014 17:28
  • I used: "net use Z: /delete" and it did remove the drive. I even check HCU/Network and it was gone.

    History: Drive returned on its' own. Ran "net use" and it did not report anything. Ran "net use Z: /delete" and it said deleted. Ran "net use" and it did not report anything. Check HCU > Network and drive is gone. Restarted MyComputer and the drive is still there.

    I did a search of the entire registry for the drive's network name and it isn't there. Sure wish MS would take a few minutes off of Win10 and fix this problem with Win8.

    joi, 13 noiembrie 2014 11:18
  • Thanks Tony

    I went to task manager>processes. Find Explorer.exe and end task. Next click applications tab, click NEW TASK type in Explorer.exe and click OK. you're done Drive was gone

    • Editat de justnuts69 marți, 2 decembrie 2014 15:38
    marți, 2 decembrie 2014 15:25
  • The batchfile described above didn't work on itself, but i implented one important command to it

    This will delete those "ghost"-netdrives. Create .cmd -file and paste text belowe to it, and run as an admin.

    Net Use /Persistent:no
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    marți, 9 decembrie 2014 08:05
  • Proposed as answer by TonyVov Saturday, July 27, 2013 1:52 AM


    net use * /delete /y

    taskkill /f /IM explorer.exe
    explorer.exe

    You nailed it.  That was driving me crazy.  I tried everything else in this thread.  ONLY this worked and I needed to do all of the steps.

    THANKS TONS!!!

    vineri, 2 ianuarie 2015 14:09
  • I support Henge's believe that the mapped drive was created by the SYSTEM account and can thus only be removed using the SYSTEM account.

    Instead of DOS Vader's scheduled Task, I however used SysInternals PSExec to Run a command as SYSTEM.

    psexec -s -i cmd
    net use Z: /delete /y
    • Propus ca răspuns de Kapil Patry joi, 10 septembrie 2015 04:27
    joi, 5 martie 2015 16:19
  • Thanks Robert. Restarting explorer fixed the issue. 
    marți, 10 martie 2015 14:22
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.


    DOS Vader

    This is the first time I've ever responded to someone on technet, but it's because you are a genius. This perfectly fixed my problem. I'd created these drives as the system user so that Crashplan would see them and back them up. I don't need that anymore and my NAS has a new address, so I had undeletable drives. You fixed that! Bravo.
    vineri, 4 septembrie 2015 14:51
  • @ Ten Cents, This worked for me perfectly on a Windows Server 2012 R2. Earlier, I had tried all the solutions that were posted here in this forum and out there on the web but running psexec as a System process and deleting the mapped drive was a no problem at all. Thanks!!
    joi, 10 septembrie 2015 04:29
  • To remove the incorrectly labeled mapped drive, follow these steps:
    1. Click Start, point to Run, type regedit, and then click OK.
    2. In Registry Editor, locate the following registry subkey:
      HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2
    3. Right-click the mapped drive that you want to remove. For example, right-click ##<var class="sbody-var" style="box-sizing:border-box;">Server_Name</var>#<var class="sbody-var" style="box-sizing:border-box;">Share_Name</var>, and then click Delete
    4.  Restart PC :-) 
    • Propus ca răspuns de CAD_IT_Guy vineri, 14 iulie 2017 11:41
    joi, 17 septembrie 2015 07:01
  • This registry edit was the only thing that worked for me. Thank you!!
    sâmbătă, 31 octombrie 2015 19:27
  • @ Ten Cents 

    thanks, run as SYSTEM is key to the issue for me.

    miercuri, 2 decembrie 2015 11:51
  • I had 2 drives showing as disconnected with red crosses. I was unable to unmap in most of the ways suggested above. I was getting system error 85 or not found.

    The worrying thing was that when opened they still linked to a server share (the wrong one) and the user had R/W access to the root of the server's data drive, even though they were not an admin! I couldn't find any cached credentials. I assumed some kind of rogue software had done this.

    Using the task scheduler with SYSTEM rights, I managed to get rid of one of them.

    The 2nd one could only be got rid of through deleting the MountPoints2 registry key as described here.

    Thanks a lot.


    • Editat de trichromic vineri, 29 ianuarie 2016 14:14
    vineri, 29 ianuarie 2016 14:13
  • I had this problem, all of the above did not work, turned out to be an application called CloudBerry Drive, it is used for Azure, Amazon etc. You need to unmount it from the app that created it, it is not managed by Windows 7,8, 8.1, 10 and so forth. IF not this, then something above should work. BTW, CloudBerry is a solid app, it was my mistake trying to manage it within Windows OS. There are many Network Drive app for local LAN's, Data Centre and Internet solutions, the question for yourself is; did I create it with Windows??, if YES and none of the above works, you probably have corruption, sorry to tell you that but some suggestions below. If NO, then go back to the app.

    The other thing to consider is that the network location cannot be reached, windows appears to hang when you click it or very slow to start File Explorer due to your Quick Access setting having Recent places monitored, look at; firewall, share deleted, NIC problem, IP Address changed via DHCP (changed or cannot be reached), default IP Addr instead of correct IP address (starts 169.254...), permissions have changed on the share/network drive location, PC not joined to the correct domain or none at all, a workgroup for the share has been created and you are not part of it.

    The Network Drive table is stored in; HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices use regedit if you are confident. In the Command Prompt (CMD) the net use command returns error 2 or 86 when you try to delete it if it is managed by another application outside of windows. If you created it with an app but have since uninstalled it then regedit is probably your only option: caution regedit can kill a machine, if you are not confident, take a backup before you start, if you fail and kill the machine then refresh windows is your only option if you didn't backup first.


    marți, 31 mai 2016 14:34
  • Thanks, 

    This worked without rebooting. 

    luni, 11 iulie 2016 21:21
  • brilliant.  years ago I had set the z: to exist across boots and without logins for a service to use.  You jogged my memory and your commands solved me.  thanks!

    Jim S.

    vineri, 29 iulie 2016 19:03
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    Finally this fixed the problem.  First I mapped the same drive with some other network folder.  I then created the batch file net_Use_delete.bat with the following commands:

    C:\Temp>notepad net_Use_delete.bat

       net use G: /delete /y
       taskkill /f /IM explorer.exe
       explorer.exe

    C:\Temp>net_Use_delete.bat

    C:\Temp>net use G: /delete /y
    G: was deleted successfully.


    C:\Temp>taskkill /f /IM explorer.exe
    SUCCESS: The process "explorer.exe" with PID 3148 has been terminated.

    C:\Temp>explorer.exe

    Finally the File explorer has deleted the G: drive information without rebooting the PC.

    vineri, 5 august 2016 01:00
  • Hahar, hahaha!

    Microsoft Logic Bomb:

    "YOU CANNOT DELETE THIS NETWORK DRIVE BECAUSE THE NETWORK LOCATION NO LONGER EXISTS!"

    Ta-dar!!

    Perfect... absoutely....... perfect Microsoft. Thank you soooooo.... much. Your developers prove, on almost every level, why some people should NOT indeed ever think about becoming developers.

    And unfortunately... they all appear to work for Microsoft. Maybe (after 30+ years of everyone else's misery) your H.R should really think about tightening their minimum IQ requirements.
    sâmbătă, 27 august 2016 19:08
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    Work. Thanks
    marți, 27 septembrie 2016 15:53
  • Thanks. It helped me to remove the drive from explorer.
    marți, 4 octombrie 2016 10:46
  • Thanks Robert...It works.....hatsoff
    luni, 14 noiembrie 2016 12:18
  • This Woks for me...Thanks
    vineri, 30 decembrie 2016 21:26
  • I've tested all other solutions. And this one is only that worked for me.

    1. Download PSTools: https://technet.microsoft.com/en-us/sysinternals/pxexec
    2. Start Command Line
    3. Run command: psexec -s -i cmd
    4. Run command with your drive info: net use Z: /delete /y

    Thanks for posting this!



    luni, 16 ianuarie 2017 22:08
  • I support Henge's believe that the mapped drive was created by the SYSTEM account and can thus only be removed using the SYSTEM account.

    Instead of DOS Vader's scheduled Task, I however used SysInternals PSExec to Run a command as SYSTEM.

    psexec -s -i cmd
    net use Z: /delete /y

    Thanks Ten Cents, you are my savior. This issue drive me nuts for months. Only your solution works

    Update: my deleted drive remap automatically after reboot. So check this registry key and delete suspicious keys

    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2

    • Editat de DangH luni, 23 ianuarie 2017 06:00
    • Propus ca răspuns de thefalcone marți, 11 iulie 2017 20:28
    duminică, 22 ianuarie 2017 08:10
  • It seems by trial and error that the system has to be rebooted, logoff/on or Explorer killed in order to get the icon and drive from showing up on the computer list. This seems a bit illogical.

    A small kill explorer batchfile will fix the issue without logoff/on or reboot like:

    @echo off
    net use * /delete /y
    taskkill /f /IM explorer.exe
    explorer.exe

    Note: substitute your own net use [x]: /delete command for specific mapped drive letters

    OMFG!  Worked!

    Another tool for my toolbox USB drive!

    luni, 30 ianuarie 2017 15:57
  • Old post I know but thank you for the simple reminder of the fix.
    sâmbătă, 4 martie 2017 14:57
  • This worked on Windows 10 machine and Task Manager makes it very easy to restart Windows Explorer now.
    marți, 21 martie 2017 10:54
  • it works, thanks Tony.
    miercuri, 12 aprilie 2017 07:07
  • Tested as of 05/29/2017 on Windows 10 Professional and is working.
    luni, 29 mai 2017 06:44
  • Couldn't figure out how to post so putting this here in case it helps others. I went through and tried all solutions which didn't work for me.

    When i went to HKEY_USERS > Network theer was nothing there so i just mapped another drive to \\127.0.0.1\c$ and then the registry populated. I then copied all values to what drive the system thinks is there. I rebooted and the problem drive is gone!!

    marți, 30 mai 2017 18:16
  • Read and tried lots of these suggestions .... only this one worked for me.

    Thanks!

    vineri, 14 iulie 2017 11:42
  • This worked for me, Thanks alot.
    joi, 24 august 2017 16:36
  • thanks
    marți, 5 decembrie 2017 13:59
  • Can confirm, solved the problem for me too!
    luni, 11 decembrie 2017 11:27
  • No, this does not work in all cases.  I can have a drive still showing in Explorer, with a red X by the drive icon, and the net use command shows no network connection to the drive.  In trying to map the drive again, I get a "The network folder specified is currently mapped using a different user name and password.  To connect, yada yada yada..."

    And the Microsoft flunkie marked this as answered... typical.  I still have not found a solution yet except for rebooting the computer with which I'm trying from to the network share, or logging off and logging back on to it.

    Very annoying on several fronts...



    • Editat de Sunriver61 sâmbătă, 20 ianuarie 2018 01:18 addi
    sâmbătă, 20 ianuarie 2018 01:17
  • wrong.
    sâmbătă, 20 ianuarie 2018 01:19
  • GREAT!!!

    This has been a thorn in my side for too long to say.

    Thanks for resolving, Mr. Greer!

    joi, 24 mai 2018 14:06
  • I use the following dos batch file and delay start it in task scheduler.

    @echo off

    rem Open a hidden explorer window to re-establish the connection.
    FOR /F "tokens=1-2 delims= " %%i in ('net use ^| findstr ":" ^| findstr /i /v "^OK" ^| findstr "^[A-Z]"') do (
      echo "%%i - %%j"
      start "%%j:" /min explorer %%j  
    )

    timeout 10

    rem Close all the explorer windows with the string slholt-NAS- in them, if other servers
    rem are used for the shares then they would need to be addes.
    for /f "tokens=2 delims=," %%p in ('tasklist /fi "imagename eq explorer.exe" /v /fo:csv /nh
      ^| findstr /i /r /c:"slholt-NAS-"
      ') do taskkill /pid %%p

    exit

    marți, 19 iunie 2018 03:43
  • I tried everything above this, and some other ideas from other websites.  However, this worked exactly as described.  I needed to download the PSTools from Microsoft.

    Thank you Ten Cents

    joi, 19 iulie 2018 15:36
  • I only had to restart Windows Explorer in Task Manager and the drives disappeared. 
    vineri, 14 septembrie 2018 17:07
  • I have found that these "phantom" drive mappings can be removed by using a scheduled task:

    for example open an elevated CMD prompt and type the following:

    If you wish it to run at 13:00 (1:00 PM) and the drive letter to remove is "Z:"

    AT 13:00 NET USE Z: /DELETE /Y

    Open explorer and you will see the drive letter is now removed.


    DOS Vader

    I know this is an old post, but this issue was driving me crazy until I found the ONLY thing that works is DOS Vader's answer.  It is important to note that when creating the Scheduled Task, you need to make sure it is running as SYSTEM.  By default, it runs as whatever account is logged when creating the task.
    miercuri, 28 noiembrie 2018 16:14
  • Exporting the registry and merging it as a different drive letter worked for me. Worked like charm!
    joi, 20 decembrie 2018 08:56
  • I support Henge's believe that the mapped drive was created by the SYSTEM account and can thus only be removed using the SYSTEM account.

    Instead of DOS Vader's scheduled Task, I however used SysInternals PSExec to Run a command as SYSTEM.

    psexec -s -i cmd
    net use Z: /delete /y
    This is exactly what fixed it for me. Many thanks
    miercuri, 16 ianuarie 2019 09:53
  • Confirmed working using this procedure:

    As Jimm Panik said:

    ANSWER:
    In HKEY_CURRENT_USER\Network the key for the drive doesn't exist.
    Exported one of the other keys for a drive mapping and edited the content to match that of the locked drive.

    [HKEY_CURRENT_USER\Network\P]
    "RemotePath"="\\\\t70nas301\\home\\jpanik"
    "UserName"=dword:00000000
    "ProviderName"="Microsoft Windows Network"
    "ProviderType"=dword:00020000
    "ConnectionType"=dword:00000001
    "DeferFlags"=dword:00000004

    Note: In the above code, replace P with the drive letter that you want

    In addition:

    taskkill /F /IM explorer.exe
    net use /persistent:NO
    net use [drive letter] /DELETE
    mountvol [drive letter] /D
    explorer.exe

    And the mapped disappear. Works like a charm
    • Editat de realpc2008 miercuri, 20 martie 2019 11:34
    miercuri, 20 martie 2019 11:30
  • Confirmed working using this procedure:

    As Jimm Panik said:

    ANSWER:
    In HKEY_CURRENT_USER\Network the key for the drive doesn't exist.
    Exported one of the other keys for a drive mapping and edited the content to match that of the locked drive.

    [HKEY_CURRENT_USER\Network\P]
    "RemotePath"="\\\\t70nas301\\home\\jpanik"
    "UserName"=dword:00000000
    "ProviderName"="Microsoft Windows Network"
    "ProviderType"=dword:00020000
    "ConnectionType"=dword:00000001
    "DeferFlags"=dword:00000004

    Note: In the above code, replace P with the drive letter that you want

    In addition:

    taskkill /F /IM explorer.exe
    net use /persistent:NO
    net use [drive letter] /DELETE
    mountvol [drive letter] /D
    explorer.exe

    And the mapped disappear. Works like a charm

    miercuri, 20 martie 2019 11:33
  • Even though this was posted on July 6, 2012, it works even now-2019!!!

    Some things never change...


    joi, 28 martie 2019 22:38
  • Microsoft "remove bugs" from their scatophagic products?  Heh, they'll just pile on a few more!
    vineri, 15 noiembrie 2019 07:18
  • Hello  Tony Vov,

    I have been having the same problem for many months with the disconnected network drive appearing in explorer but not when using CMD. "Net Use"...This has been bugging me and have tried many posted solutions..

    Just like to say thx for sharing as my now disconnected drive had gone using your batch file..

    Problem solved..

    Many Thanks

    duminică, 12 ianuarie 2020 11:29
  • Couldn't figure out how to post so putting this here in case it helps others. I went through and tried all solutions which didn't work for me.

    When i went to HKEY_USERS > Network theer was nothing there so i just mapped another drive to \\127.0.0.1\c$ and then the registry populated. I then copied all values to what drive the system thinks is there. I rebooted and the problem drive is gone!!

    I did exactly that - inside explorer, I mapped another drive letter (Z) to my \\network_drive\network_share. The HKEY_USERS > Network folder then populated with that Z drive. But instead of creating a new drive letter (W, which is the faulty one that wont disconnect) and then copying all of Z's data to it, I instead just right clicked Z -> renamed Z to W, crossed my fingers and hoped for the best. On first reboot, it logged into a black screen. I waited probably 30 seconds, then rebooted again, now it all works! There is a normal W drive mounted in explorer (no longer with the "x" (disconnected) next to it) and no Z drive. It worked!

    I have to add, I earlier removed that drive path from HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2. Not sure if that step was necessary, but overall everything now works.

    miercuri, 11 martie 2020 02:26
  • Thanks justnuts69. only your suggestion worked for me.
    duminică, 26 iulie 2020 04:24
  • This worked for me on Windows Server 2008 R2.

    Thanks Sakari.

    luni, 17 august 2020 02:47