none
Large Files are locking up Windows 7 32 bit and 64 bit RRS feed

  • Întrebare

  • I am a tech and have done over 30 clean installs and cant figure out what the heck is going on with large as in 1gig or more file transfers hanging up. All clean installs with tests done immediately after activation and updates. This is a MS problem. I have tried all the various fixes and find that the C drive seems to handle network files best. In multidrive situations turning off the Remote Differential Compression also seems to help. Please get a hot fix as this is on multiple machines and very easy to duplicate. I would say it would be a rare install not to lock from a C drive to a D drive when file sizes are more then 2 gigs. You guys are running out of time. I am a consultant and I'm ready to get sick over a great operating system that's worthless for large video files.
    joi, 4 februarie 2010 10:22

Răspunsuri

  • Did you try this one

     
    Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly.  Set the following registry key to ‘1′:

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    and set the following registry key to ‘3′:

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    After making these changes and restarting, I haven’t seen this issue arise again

     
    • Marcat ca răspuns de JBerkove duminică, 7 februarie 2010 06:19
    vineri, 5 februarie 2010 22:40

Toate mesajele

  • Did you try this one

     
    Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly.  Set the following registry key to ‘1′:

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    and set the following registry key to ‘3′:

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    After making these changes and restarting, I haven’t seen this issue arise again

     
    • Marcat ca răspuns de JBerkove duminică, 7 februarie 2010 06:19
    vineri, 5 februarie 2010 22:40
  • Just to clarify, the LargeSystemCache key has no effect on Windows 7. It was only used on 32-bit, pre-Vista versions of Windows. So if the above steps make any difference, it must be because of the other setting.
    joi, 18 februarie 2010 19:48
  • All I can say is it fixed my problems on 2  Windows 7 64 bit computers
    and many others on
    joi, 18 februarie 2010 22:07
  • Just to clarify, the LargeSystemCache key has no effect on Windows 7. It was only used on 32-bit, pre-Vista versions of Windows. So if the above steps make any difference, it must be because of the other setting.
    Two questions.  !.  If LargeSystemCache is not used on Windows 7 and on 64-bit computers, why is the value in the registry?  And 2, more importantly, do you know of any other solution then to the 2017 issue?  I have Win7 64-bit with 12GB RAM, dual quad-core Xeons.  I should not be seeing memory limits copying a few files to my Win 7 home server.

    Thanks,

    Dale

    duminică, 7 martie 2010 03:16
  • The LargeSystemCache value was left in the registry (even though it is no longer used) for compatibility reasons.

    File server is not my area, so I don't know what the other registry key mentioned above (LanmanServer\Parameters\Size) does. I see it mentioned in a few places on technet.microsoft.com so it might be worth trying but I'm not in a position to make any statements regarding its applicability to this particular problem.
    duminică, 7 martie 2010 07:43
  • I agree i dont think we need to set the LargeSystemCache value .

    I fixed the problem by only setting the lanmanserver size to 3 in

    HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    and restarting the server service on the windows 7 box.


    • Editat de AL_C71 marți, 30 iulie 2013 10:42 typo
    marți, 30 iulie 2013 10:41
  • Set the following registry key to ‘1′:
    
    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    This works on my Windows 7 64-Bit with 12GB of memory and the other key was already set to 3.

    KR Baugh, you are 100% correct. Those that say it does not make a difference in Windows 7 are wrong.

    All you have to do is look at Resource Monitor to see the difference.

    My system was hanging for 30 sec. at a time because all but a few MBs of  "Free" memory was being used by Cache in the "Standby" area.


    Dan Randolph - My Code Samples List

    luni, 11 august 2014 20:18
  • Set the following registry key to ‘1′:
    
    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    This works on my Windows 7 64-Bit with 12GB of memory and the other key was already set to 3.

    KR Baugh, you are 100% correct. Those that say it does not make a difference in Windows 7 are wrong.

    All you have to do is look at Resource Monitor to see the difference.

    My system was hanging for 30 sec. at a time because all but a few MBs of  "Free" memory was being used by Cache in the "Standby" area.


    Dan Randolph - My Code Samples List

    Quite frankly, you have no idea what you are talking about.

    This setting has no impact on SuperFetch at all.

    marți, 12 mai 2015 15:14
  • Who said it had an impact on SuperFetch?

    I did also have to end up writing a utility I run around once a day to force the File System cache to be cleared. Mainly I have problems when I have two SSMS instances open and more than one Visual Studio 2012 instance open at the same time.


    Dan Randolph - My Code Samples List

    miercuri, 13 mai 2015 18:33
  • Agreed Dan. Quite frankly, I believe Squall has no idea what you or himself are talking about.. :)

    After changing the LargeSytemCache parameter to 1 (Win 7), Superfetch actually cached more program data and became much more useful on my slow drive. So the cache value itself does ultimately influence Superfetch, although that's not what you were talking about.

    Many say that LargeSystemCache = 1 is an incorrect tweak because it leaves less memory for running programs, however in practice I found that cache memory will be used for those programs as needed anyway, so there's no loss whatsoever.

    As Windows is likely the most disk-intensive OS that ever existed (I'm an ex-Amiga programmer) since it isn't contained on an efficient ROM chip, setting LargeSystemCache to 1 provides many benefits for those without an SSD.

    Many people also complain about Prefetch/Superfetch being slow in doing its job - and so do I - which currently takes 6 minutes (Win 7) before it kicks in after loading to desktop. It's not configurable to a degree which it could be, unless someone can tell me where the 6 minute parameter lives.

    Most people don't have a dual-boot setup (2 Win versions on one disk). So why don't they shut off Prefetch/Superfetch altogether, load up the software they regularly use, quit them (or leave them running) and then hibernate the machine. They'll then boot straight into an OS where everything's already cached with a lot less disk-grinding. That made a huge difference on one of my old (2002) laptops. That old Dell was incredibly slow at booting (XP) until I began hibernating the thing. With only 640K of memory, it was up in 7 seconds compared to the agony of booting fresh.

    On a dual-boot setup, unfortunately the hibernated OS will always be the boot OS without a choice, unless someone can point me to a workaround.

    sâmbătă, 16 iulie 2016 00:46
  • Intel says youre cache setting is wrong..Intel says it gets set to 1 not 3.Also,memory performance setting is thru:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SessionManager\MemoryManagement.Open DisablePagingExecutive.set to 1  this makes the OS use more ram than page file.

    vineri, 9 februarie 2018 04:33