none
Sharepoint 2013 и не работающие "рабочие процессы". RRS feed

  • Вопрос

  • Доброго времени суток. На портале Sharepoint 2013 перестали работать "рабочие процессы". Не имея до сего дня опыта работы и настройки Sharepoint. Запросив копию ВМ приступил к разбору. Первичную проблему удалось отыскать довольно быстро. На ферме Workflow закончились самоподписанные сертификаты. При попытке обновить сертификаты выяснилось что пароль от учетной записи под которой работает Workflow неизвестен. (Сбрасывать пароль не стал т.к. доменная уз могла использоваться в другом портале SP). Также был неизвестен пароль используемый при генерации сертификатов. 

    После недолгих раздумий (т.к. это была копия ВМ)  принял решение перенастроить заново ферму  Workflow. Что получилось со второй попытки правда. В Sharepoint появилась служба Workflow и она была запущена. Но при попытке опубликовать рабочий процесс 2013 возникала следующая ошибка: При компиляции рабочего процесса обнаружены ошибки. Файлы рабочего процесса были сохранены но они не могут быть запущены.

    Microsoft.SharePoint.SPException: Прокси общей службы управления приложениями не установлен. 

    Попоробовал пересоздать "приложение-службу для Управления приложениями" но в ответ получил ошибку: "К сожалению что-то пошло не так служба топологии недоступна в ферме". Очень прошу подсказать. Почему SP не создает службу? Почему он пишет про ферму если сервер standalone? Заранее спасибо.

    14 августа 2022 г. 5:40

Ответы

Все ответы