none
PPTP VPN suddenly throwing Error 651 RRS feed

  • Вопрос

  • I am not sure exactly when this started happening but as of 6/5 it was still working. 

    When I try to connect to my company's VPN (via PPTP) I get an Error 651.  There is a dialog window that opens that says "all devices connected" ... not sure what is going on.

    I disabled all firewalls and even uninstalled Kaspersky.  Still, same error.

    I re-created the VPN network connection, still same error.

    I uninstalled any of my recently installed programs (iTunes upgrade, etc.).  Same issue.

    I performed a System Restore to 6/5 and I am still getting the same issue.

    I have this happening on my home desktop as well as my work laptop from two different locations (will try more when I get a chance) through both wired and wireless connections.  As far as I know (and have been told) nothing has changed on my corporate LAN.

    The only things I see online for this error are related to PPPoE and firewalls ... not sure if PPPoE has anything to do with it at this point.

    Any other thoughts on what I can try?

    Info:
    Windows 7 RC, all latest critical and even some optional updates installed
    Laptop: Dell D830, 64bit, 4 GB RAM, 80 GB HDD
    Desktop: Pentium 4, 2 GB RAM, 120 GB  HDD

    Thanks,
    Jason
    9 июня 2009 г. 16:53

Ответы

  • I can confirm that the same thing happens with the Connectify program. Uninstalling it solved the problem for me. I will try to install it again to see if I can tweak some settings to make it work side by side with my VPN connection.

    Per

    • Предложено в качестве ответа Vadim Sorokin 9 сентября 2011 г. 13:17
    • Помечено в качестве ответа JAgostoni 25 октября 2011 г. 17:43
    22 июня 2011 г. 13:02
  • I have the same problem after VirtualBox installation.
    Uninstall VirtualBox solve the problem for me.

    Do you have VirtualBox or other Virtualization software ?
    • Предложено в качестве ответа alain178 18 июня 2009 г. 17:45
    • Помечено в качестве ответа JAgostoni 19 июня 2009 г. 13:09
    18 июня 2009 г. 17:42
  • Grrrrrrrrrrr it was fuffing CONNECTIFY!!!! After literally feeling like slicing my wrists over this frustration, and seeing millions of posts referring to Virtual PC (Not installed on my PC) I found this thread and uninstalled Conecftify. Everything works great now! I didnt even KNOW I had that shitty little program installed ><

     

     

    Thanks guys! You have NO idea how relieved I am now :)

    • Предложено в качестве ответа BinayaRaj Shrestha 25 октября 2011 г. 17:31
    • Помечено в качестве ответа JAgostoni 25 октября 2011 г. 17:43
    22 июля 2011 г. 15:40

Все ответы

  • You may already be aware of this since it working before but it doesn't hurt to ask... Is it set up for PPTP or IKEv2? I don't know if it's the same for 64-bit versions of Win7 but both beta 1 and RC build 7100 32-bit releases will default new VPN connections to IKEv2. To fix this, go to Control Panel -> Network and Internet -> Network Connections, find your connection profile, right click, select Properties -> Security and change Type of VPN to PPTP.

    -Gary
    • Изменено garypdx 9 июня 2009 г. 23:50
    9 июня 2009 г. 23:21
  • Thanks for the reply, Gary.  I did try this with no change.  I even tried another VPN service (though not exactly a reliable test) with the same results.
    10 июня 2009 г. 12:57
  • Ugh I hate pptp.
    My typical answers before trying anything else:
    - Did you reset your router?
    - What virus scanner/internet security suite is installed? More and more vendors add own network filters that block GRE traffic. If you check networking for your lan adapter are there other protocols installed as TCP/IPv6, TCP/IPv4, 2 Link-Layer Protocols?
    11 июня 2009 г. 18:36
  • Hahah ... yeah ... I am getting there too ...

    Yeah ... not ony have I reset my router, I have tried this in four different locations!

    For the security suite here is the order I have tried:

    1. Kaspersky Beta for Win 7 + It's firewall (Anit-Hacker)
    2. Kaspersky with Windows Firewall onlye
    3. Kaspersky NO firewall
    4. Kaspersky disabled
    5. Kaspersky uninstalled
    6. With and without Windows firewall enabled
    7. Now running Windows Firewall + Avira just to stay safe in the meantime

    I have also tried with both LAN and WLAN adapters.  Checked the protocols:

    WLAN:
    Client for MS
    QoS Packet Scheduler
    File and Printer Sharing
    Virtual Machine Network Services
    IP 4
    IP 6
    Link Layer ... Responder
    Link Layer ... Mapper I/O Driver

    LAN:
    Same except I have unchecked IP6

    I am happy to run any packet capture/traces anyone would like!

    Thanks!
    11 июня 2009 г. 19:24
  • jeah I'm just poking around too without the logs of the server.
    You could try to disable Receive Side Scaling in the advanced settings for your network adapter (actually that was a tip that once worked on the server side, but who knows).
    • Предложено в качестве ответа hdufort 29 августа 2019 г. 22:44
    11 июня 2009 г. 19:44
  • You could try to disable Receive Side Scaling in the advanced settings for your network adapter
    No such option in the UI ... any idea on a netsh command for that one?  I can research it if you don't know it offhand.
    11 июня 2009 г. 19:54
  • set global rss=disabled

    11 июня 2009 г. 20:00
  • I did try the set global rss=disabled with no luck ... anyone know of any alternative PPTP clients that I can try?
    15 июня 2009 г. 13:33
  • I don't suppose you can find a Windows update that was installed around the time the issue started? If so, you can try uninstalling that update.
    15 июня 2009 г. 16:33
  • I have the same problem after VirtualBox installation.
    Uninstall VirtualBox solve the problem for me.

    Do you have VirtualBox or other Virtualization software ?
    • Предложено в качестве ответа alain178 18 июня 2009 г. 17:45
    • Помечено в качестве ответа JAgostoni 19 июня 2009 г. 13:09
    18 июня 2009 г. 17:42
  • I'm in the same boat.  I have two Dell laptops sitting on the same desk, connecting to the same wireless router, using the same MS VPN client to connect to the same VPN server using the same settings.  Both are running Windows 7 RC.  One of them works with no problem, the other is giving me the "All devices connected - Error 651 Your modem (or other device) is reporting an error" message.

    Firewall rules permit GRE and PPTP traffic and I've tried with the firewall disabled.  I uninstalled and reinstalled the wireless drivers.

    Obviously if two laptops behave differently when all external factors are the same, the problem most likely lies in the one laptop.

    If anyone has any suggestions, or need more info to help, please let me know. 

    --  Mark
    19 июня 2009 г. 8:57
  • I do have Virtual PC installed ... though it was working the entire time it had been installed ... I'll try removing it and see what happens.
    19 июня 2009 г. 11:24
  • Removing Virtual PC 2007 SP1 totally fixed this.  I will try and re-install (given that it worked before) and report back.
    19 июня 2009 г. 13:10
  • Removing Virtual PC 2007 SP1 totally fixed this.  I will try and re-install (given that it worked before) and report back.

    On my machine VPC uninstallation didn't give expected results. The error still remains..
  • On my machine VPC uninstallation didn't give expected results. The error still remains..
    Hmmm ... obvious questions:
    - Did you reboot after uninstalling?
    - Did you verify that everything did uninstall? (Check Programs and Features, check your network setting to see if the virtual machine network add-on is gone)
    - Did you try anything else others have suggested in this thread?
    - Do you have any other virtualization software installed (VM Ware, VirtualBox, etc.)?

    Sorry for the obvious questions but I am not sure what else to suggest myself.

    8 июля 2009 г. 11:27
  • Yes. Everything checked. At the first step I uninstalled "Microsoft Virtual PC 2007" then discovered that actually that one is installed as Windows Update (don't remeber #). Then Virtual Windows XP removed as well. Everything removed, rebooted, no other virtualization software installed. Error still remains :)
    8 июля 2009 г. 15:21
  • Just out of curiosity. I discovered this error at about the same time that I discovered the dll gpsvc.dll missing. Do you have that dll present in %windows%\system32? I understand it's part of group policy and cryptography, so it may be related.
    8 июля 2009 г. 19:27
  • Just out of curiosity. I discovered this error at about the same time that I discovered the dll gpsvc.dll missing. Do you have that dll present in %windows%\system32? I understand it's part of group policy and cryptography, so it may be related.

    Yes. I do have. Group Policy Client v6.1.7100.0
    9 июля 2009 г. 14:32
  • Thank u guys. I would never thought VPC can cause such problems, especially because there was no symptoms for a long period of time after i've installed it (more then month), VPN worked fine.
    Also not only VPN crashed, my GPRS dial up didn't work, until i've uninstalled VPC, and my local area connection didn't work properly either.
    P.S: sorry for poor english.
    13 июля 2009 г. 16:28
  • Thank you so much alain!!
    I uninstalled the filter driver of VirtualBox in the properties page of my NIC and all connections that uses WAN Miniport (L2TP, PPTP, PPPoE...) came back magically.
    You don't even need to uninstall the whole app; removing the driver is enough.

    But this problem is quite weird though. VirtualBox and L2TP VPN were both working quite well no matter if I dial first or turn the virtual pc on first. Then last night all connections based on WAN Miniport stopped working, showing the 651 error. I didn't install any driver, software or system update, so this problem seems completely random. The only unusual thing I was doing yesterday is that I ran VirtualBox as admin so I can access a physical partition, and then the VBoxSvc process didn't exit when I closed the application. Could this cause the network filter driver to malfunction?

    I also notice that it takes much longer time to establish a wireless connection. It shows I am connected to the AP, but no packets is coming through as if the system is waiting for something and it timed out.
    27 июля 2009 г. 6:29
  • Thank you so much alain!!
    I uninstalled the filter driver of VirtualBox in the properties page of my NIC and all connections that uses WAN Miniport (L2TP, PPTP, PPPoE...) came back magically.
    You don't even need to uninstall the whole app; removing the driver is enough.

    But this problem is quite weird though. VirtualBox and L2TP VPN were both working quite well no matter if I dial first or turn the virtual pc on first. Then last night all connections based on WAN Miniport stopped working, showing the 651 error. I didn't install any driver, software or system update, so this problem seems completely random. The only unusual thing I was doing yesterday is that I ran VirtualBox as admin so I can access a physical partition, and then the VBoxSvc process didn't exit when I closed the application. Could this cause the network filter driver to malfunction?

    I also notice that it takes much longer time to establish a wireless connection. It shows I am connected to the AP, but no packets is coming through as if the system is waiting for something and it timed out.
    yes! I just wanted to confirm that Virutal Machine Network Service driver removal (not uncheck but uninstall) from NIC used items solved this problem. Thx to all you :)
    29 июля 2009 г. 20:18
  • I had the same problem but I did not have VirtualBox installed.  I found out that Connectify will cause it as well.  After I uninstalled it, I was able to connect to my VPN networks.
    21 июня 2011 г. 13:28
  • I can confirm that the same thing happens with the Connectify program. Uninstalling it solved the problem for me. I will try to install it again to see if I can tweak some settings to make it work side by side with my VPN connection.

    Per

    • Предложено в качестве ответа Vadim Sorokin 9 сентября 2011 г. 13:17
    • Помечено в качестве ответа JAgostoni 25 октября 2011 г. 17:43
    22 июня 2011 г. 13:02
  • Thanks! I had the same problem. You saved me some time.
  • Grrrrrrrrrrr it was fuffing CONNECTIFY!!!! After literally feeling like slicing my wrists over this frustration, and seeing millions of posts referring to Virtual PC (Not installed on my PC) I found this thread and uninstalled Conecftify. Everything works great now! I didnt even KNOW I had that shitty little program installed ><

     

     

    Thanks guys! You have NO idea how relieved I am now :)

    • Предложено в качестве ответа BinayaRaj Shrestha 25 октября 2011 г. 17:31
    • Помечено в качестве ответа JAgostoni 25 октября 2011 г. 17:43
    22 июля 2011 г. 15:40
  • Having this issue as well. I did have connectify on which I took off again and have just noticed a few days later that my VPN no longer connects with this error. I am guessing Connectify did something and I will need to re-install the WAN miniport drivers?
    • Предложено в качестве ответа Rudyreliableunit 24 сентября 2013 г. 2:53
    • Отменено предложение в качестве ответа Rudyreliableunit 24 сентября 2013 г. 2:53
    • Предложено в качестве ответа Rudyreliableunit 24 сентября 2013 г. 2:53
    30 июля 2011 г. 9:34
  • I had the opportunity to work with a client about this 651 windows error (vpn). We tried all most everything on the books nothing work. Guess what worked: reinstalation of windows problem fixed

    24 сентября 2013 г. 3:01
  • Hello,

    I want juste to sgnal that I have the same issue.

    After uninstalling virtualbox it work without problem.

    Thanks,

    AAZRI

    28 декабря 2016 г. 14:06
  • I have the same problem after VirtualBox installation.
    Uninstall VirtualBox solve the problem for me.

    Do you have VirtualBox or other Virtualization software ?

    Thanks a LOTTT! I had the same problem, only uninstalled the Oracle Vitrual Box and the problem was solved

    I have VM Ware too, I had not to uninstall it.

    ;)

    10 марта 2018 г. 13:45