The device, \Device\Ide\iaStor0, did not respond within the timeout period. RRS feed

  • Вопрос

  • I have windows 7 64 bit and I keep getting hangups with the event error

    I have downloaded drivers and all are up to date. My machine is only about 4 months old i5 processor Dell. What can I do???

    The device, \Device\Ide\iaStor0, did not respond within the timeout period.

    14 июля 2011 г. 13:10

Все ответы

  • Look in your Windows System Event Log for more information.

    You may well be having a hardware problem, and Dell should service it.  If you call them they will ask you to diagnose the problem, and having information from the event log will be helpful for you to make your case.

    If you can, do a full backup as soon as you can, as disk drives do sometimes fail progressively, allowing you time to get your data off them.


    14 июля 2011 г. 14:38
  • I've been having similar problems, see also this post:


    15 июля 2011 г. 14:54
  • Hi,


    Usually this message is being posted due to hardware problems with either the controller or, more likely, a device that is attached to the controller in question. The hardware problems can be associated with poor cabling, incorrect termination or transfer rate settings, lazy or slow device responses to relinquish the SCSI bus, a faulty device, or, in very rare cases, a poorly written device driver.


    The following are some troubleshooting tips to help diagnose and pinpoint the problem:

    ·         Read the SCSI controller manufacturer's technical manual to determine the termination requirements. Many modern SCSI controllers require active terminators (at least one of the devices on the bus must provide termination power). Proper termination involves both a terminator (resistor) and a device that supplies a signal to the bus for termination power. The SCSI-2 standard specifies that a controller (initiator) must supply termination power. Therefore, any controller that claims to be SCSI-2 compatible probably does supply termination power, but you should check if you are unsure. Also, many devices, especially drives, give you the option of providing termination power; if you have a jumper on the drive that reads Trmpwr, you should enable this jumper.

    ·         If both internal and external SCSI devices are attached, make sure the last device on each SCSI chain is terminated, and that intermediary devices are not.

    ·         If only a single SCSI chain is used (either all internal or external), ensure the last device of the SCSI chain is terminated and the SCSI controller itself is terminated. This is usually a BIOS setting.

    ·         Check for loose or poor quality SCSI cabling. When you have a long chain of cables with mixed internal and external cabling, you run the risk of degrading the signal. Even though the SCSI specification may specify a long distance, the specification assumes cabling that allows no leakage or interference, and the reality is generally a shorter distance. Whenever you have 6-foot or longer external cables, you should replace them with 3-foot cables.

    ·         Note when the event messages are posted and try to determine if it coincides with certain processing schedules (such as backups) or heavy disk processing. This will help to determine what device may be causing the errors.

    Note The reason that drives tend to have these types of problems under heavy stress is often slow microprocessors. In a multitasking environment, the processor may not be fast enough to process all the I/O commands that come in nearly simultaneously.

    ·         Slow the transfer rate settings if the timeouts are associated with tape drives - using 5MBS transfer rate usually cures the timeouts.

    ·         Simplify the SCSI/IDE chain by removing devices, or move the device in question to another controller. If the problem follows the device, you should replace it.

    ·         Check the revision of SCSI controller BIOS and device firmware revisions. Contact the manufacturer for the latest revisions. See the Checking the Model Number and Firmware Revision section below for the procedure on how to do this.

    ·         Check the SCSI device drivers version. The SCSI driver is located in the %Systemroot%\System32\Drivers directory. Look at the version in the file properties, and check whether the SCSI manufacturer has a newer version.

    ·         Remove other controllers that may create bus contention problems.

    ·         A low-level format performed by the SCSI controller may resolve these event messages.

    ·         Use a different make or model of any suspect hardware.

    Please refer:




    Also the issue may be the result of Aggressive Link State Power Management (ALPM) on the PCI-Express bus negotiating a lower power state for the link between the controller and disk when there is no activity. When ALPM works, disk requests are queued, the serial link revived, and the queued requests are sent to the relevant disk; this requires a disk that supports ALPM.


    Please try to modify the advanced settings of your active power management scheme in Windows to turn PCI Express Link State Power Management off.


    1.       Click Start button, choose Control Panel.

    2.       Move to Control Panel\All Control Panel Items\Power Options. Click Change plan setting in your current power plan.

    3.       Click “Change advanced power settings”, move to PCI Express-> Link State Power Management, turn off the option.


    Hope that helps

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    27 июля 2011 г. 10:09
  • I have windows 7 64 bit and I keep getting hangups with the event error

    I have downloaded drivers and all are up to date. My machine is only about 4 months old i5 processor Dell. What can I do???


    The device, \Device\Ide\iaStor0, did not respond within the timeout period.

    Please describe the model and specs.

    The iaStor is Intel's raid software, which Dell uses with it's Intel based computers.

    Was the computer built with RAID and multiple drives?

    Dell support would be the first place to begin as the computer is still under warranty. Get the issues solved by Dell before the warranty expires.

    27 июля 2011 г. 12:56
  • Hi I also experience this problem and have applied the following ... cudos to the original uploader. I edited my registry after receiving countless "The device, \Device\Ide\iaStor0, did not respond within the timeout period" and have not had a single error since applying the fix



    If there are no "Ports" under the iaStorV/iaStor Parameters, you will need to Manually Creating the Registry Location and Keys:

    1. Go to Start-> Run..

    2. Type in RegEdit and hit the Enter Key..

    3. Go to the following Key location to insert or configure the registry keys for LPM:






    4a. Right click "Parameters" select "New" then name it "Port0".

    4b. Left click "Port0" to open and in the pane with Name/Type/Data, Right click select "New" then "DWORD" and name the new value "LPM".

    4c. Repeat 4a/4b "LPMDSTATE" and "DIPM".


    5.  When you want to ad the other Ports also to registry, then repeat the steps from 4a to 4c and name it Port1, Port2, Port3, Port4 and Port5.


    At the end - here is the text excerpt from Intel about LMP in the Rapid Storage since Version 10:


    Link Power Management with Intel® Rapid Storage Technology

    Intel® Rapid Storage Technology implements the Link power management (LPM) feature described by the Serial ATA specification to overcome the power demand of a high-speed serial interface, SATA and providing the capability of SATA at the minimum power cost. LPM, when used in conjunction with a SATA hard drive that supports this feature, enables lower power consumption. LPM was initially enabled by default on mobile platforms starting with ICH6M with Intel® Matrix Storage Manager. Starting with ICH9R this feature has also been supported on desktop platforms with Intel® Matrix Storage Manager 7.5 release but not enabled by default. Beginning with the Intel® Rapid Storage Technology 10.0 release, LPM support is enabled by default on both mobile and desktop platforms. OEM’s who wish to modify the default settings for LPM on their platforms can follow the instructions in the following section(s).

    Instructions to disable/enable LPM

    After system is setup with OS and Intel® Rapid Storage Technology installed, follow the below instructions to modify the default LPM support.

    NOTE: Beginning with the Intel® Rapid Storage Technology 10.0 release, the registry keys are no longer populated in the Windows registry by default. The RST driver does not require the registry keys to be present to support the default settings.

    1. Go to Start->Run
    2. Type in RegEdit and hit the Enter Key.
    3. Go to the below mentioned location to insert or configure the registry keys for LPM
    NOTE: OEM’s need to configure the LPM settings by port. Ports are numbered starting with zero (please refer the desired platform EDS for the number of ports supported on that platform)

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame

    4. Now add the following registry keys under the registry location mentioned in step3, if they are not available (These registry keys are not available by default, they can be added by using utomated scripts, .reg files, executable utilities, etc). If you find the below registry keys already available, you can modify the values for desired support. Values are modified on a port by port basis so modify all ports that you wish the changes to be supported on. **

    “LPM”=dword: 00000001 {dword: 00000000->Disable; dword: 00000001->Enable} [default = Enabled]
    “LPMSTATE”=dword: 00000000 {dword: 00000000->Partial; dword: 00000001->Slumber} [default = Disabled] (Note: the driver ignores this key when the LPM key’svalue is not set to 1. So when LPM value is 0, this value is N/A.)
    “LPMDSTATE”=dword: 00000001 {dword: 00000000->Partial; dword: 00000001->Slumber} [default = Enabled]
    “DIPM”=dword: 00000001 {dword: 00000000->Disable; dword: 00000001->Enable} [default = Enabled]

    **Warning: If you edit the registry incorrectly, you can cause serious problems that may require you to reinstall your operating system. Intel does not guarantee that problems that are caused by editing the Registry incorrectly can be resolved.

    It was originally aimed at SSDs but (fingers crossed this may also help you) back up registry before making any changes though





    • Предложено в качестве ответа Ozlefty 18 августа 2011 г. 9:25
    18 августа 2011 г. 9:23
  • Hi Ozlefty, your advice worked fine for me. The OCZ Vertex 3 now works smoothly in an Elite Book 8760w running Win7 x64.




    17 сентября 2011 г. 9:23
  • Dear Marko,

    Can you tell me how you managed to install Win7 x64 on Vertex 3 on 8760w? I have the same config.

    Installed manually Vertex 3 in first bay (oroginal 500 gig on the second), set SATA to IDE in BIOS, installed W7.

    But now when I try to put fix in HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci\Start (3 -> 0) and then after restart change in BIOS to AHCI, I get blue screen when loading Win 7.

    Please help.





    20 сентября 2011 г. 10:15
  • Hello Michael,

    Sorry for coming by that late ... did you solve your problem? I'm using the same configuration with AHCI. For some time I had a blue screen about once a week. After updating the Vertex’ firmware to something above 1.15 everything worked fine. No BSD since then.

    Regards, Marko


    Regards, Marko

  • I am seeing many of these messages in my Event Viewer as well.  I have a HP EliteBook 8570s, also about 5 months old, Windows 7 Pro 64-bit.  I have a HP docking station that I use at the office.  Would undocking the laptop, then closing the lid (hibernation mode) do this?

    I am certainly not doing an orderly shutdown, and going from docking station to battery would change some of the things mentioned above.  For example, the dock has 4 USB ports, HDMI, sound, mic, and AC power.

    Just wondering if that would make some of these types of errors happen...


    24 января 2014 г. 14:08
  • Doing the regedit changes under "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStor\Parameters\" didn't work for me.

    Just wanted to share what worked for me; 

    Device Manager -> IDE ATA/ATAPI-controller -> Uninstall AHCI / ATA controller driver and driver package -> Reboot and let Windows install the correct driver.

    No more iastor-errors :) 

    • Изменено AronFB 24 ноября 2014 г. 13:04
    24 ноября 2014 г. 13:04
  • @aronfb, ive had trouble with this same error for a while.  I have a Samsung Series 7 laptop NP700Z5A that started giving me the IaStor0 errors, ended up shelving the laptop for a while because I couldnt resolve it.

    Got the laptop out this weekend and tried this method of uninstalling/detecting/reinstalling the driver for "IDE ATA/ATAPI controllers > Standard AHCI 1.0 Serial ATA Controller" in the Device Manager.  That seems to have stopped the IaStor0 errors!  The drivers are all from Microsoft, the version says 6.1.7601.18231.

    However... I am getting a new error now in the Event Viewer... from atapi source: "The driver detected a controller error on \Device\Ide\IdePort0"  I didnt get any of these before reinstalling the driver.  And still experiencing intermittent system stutter/freezing.

    Possible correlation... I am getting errors from volsnap source: "The shadow copies of volume C: were aborted because of an IO failure on volume C:"  Not sure if this is related?

    Another possible correlation... CrystalDiskInfo is reporting a warning on "Current Pending Sector Count" with values of Current 100/ Worst 100/ Threshhold 0/ Raw Values 0000000001.  Drive health status listed as "Caution".  No other warnings on other attributes.  Ran DSKCHK twice and still same warning.

    Trying to pinpoint the issue...  Do I still not have the right driver installed?   or is the controller bad?    Or is the drive failing?  Should I insert a new drive and reinstall Windows, see if that clears it all up?   This laptop ran fine for the first couple of years.

    • Изменено AlphaGeekboy 22 января 2018 г. 21:19
    22 января 2018 г. 21:16