none
проблема с Sysprep в 1803 RRS feed

  • Общие обсуждения

  • Доброе время суток уважаемые! Такая проблема. После запаковки эталонного образа с помощью встроенной утилитой sysprep с последней версией win 10 1803, и последующей распаковкой его на любой, даже на той же машине, появляются системные процессы, которые грузят проц на 100% в течении нескольких минут, это происходит КАЖДЫЙ РАЗ при перезагрузке, что очень сильно напрягает. До применения sysprep эти процессы не давят на проц. Ни на каких других версиях Windows такого не было (проверил на 1709 - не такой проблемы). Может кто сталкивался?


Все ответы

  • Неужели никто не знает? Ответьте хоть что нибудь!
  • Да, такое поведение является нормальным (у меня такое же бывает, но только при первом старте), с одной оговоркой: оно закончится (должно) когда всё "установится" и "настроется".
  • У меня и при 51 первом старте тоже самое - другими словами загрузка каждый раз продлевается еще на пару минут, и ИСКЛЮЧИТЕЛЬНО из-за sysprep и ИСКЛЮЧИТЕЛЬНО на 1803! На более ранних версиях, вплоть до windows XP этой проблемы нет, также если не запускать sysprep на 1803 эта проблема тоже не возникает! Как можно испортить то что работало десятками лет?






  • Служба поддержки работает просто супер! А еще требуют соблюдать лицензионные соглашения и заставляют обновлять систему! Как вот обновляться после такого? 
  • тут нет службы поддержки. так что советую успокоиться.
  • Может подскажете по какому адресу она находиться?
  • Может подскажете по какому адресу она находиться?

    Начните тут:

    https://support.microsoft.com/ru-ru/assistedsupportproducts

    Под рукой имейте документы на лицензию и кредитку для оплаты. 


    This posting is provided "AS IS" with no warranties, and confers no rights.

  • Что значит начните? У Майкрософт несколько служб поддержки? Я хочу сообщить об ошибке в ОС, подскажите где напрямую это сделать.

  • Что значит начните? У Майкрософт несколько служб поддержки? Я хочу сообщить об ошибке в ОС, подскажите где напрямую это сделать.

    Поддержка не занимается принятием сообщений о предполагаемых ошибках, а предназначена для решения конкретных проблем пользователей. 

    Если вам не нужна поддержка и вы хотите лишь сообщить о проблеме, то для этого следует использовать инструмент Feedback Hub в Windows 10. 

    https://support.microsoft.com/ru-ru/help/4021566/windows-10-send-feedback-to-microsoft-with-feedback-hub-app


    This posting is provided "AS IS" with no warranties, and confers no rights.

  • Что значит начните?
    "начните" значит "сделайте всё сами". Никогда с пользовательской ТП не общался, как она работает не знаю. Ссылки Вам дали - начните с них. если там не помгоут - пишите сюда, чем сможем - поможем.
  • Спасибо! Сам в первые буду общаться, заказал себе телефонный звонок, еще и отзыв в приложении оставил, буду ждать результата! Еще раз спасибо за наводки!
  • Так и не справился с проблемой(( Вот что я делаю:

    беру девственно чистую 1803, ставлю, захожу в аудит, кидаю в автозагрузку только малюсенькую утилитку starter для отображения графика загрузки цп в трее и все, без нее я б может и не заметил этих процессов (ошибки точно не из-за нее). Вот что получается:

    Другими словами, все ок. Далее запаковываю с перезагрузкой через sysprep, при чем совершенно без ошибок, дальше сама перезагружается, дожидаюсь установки, опять же перехожу по ctrl+shift+f3 в режим аудита, чтоб поскорее пропустить экран приветствия. И тут начинается:

    И продолжается около минуты, но при каждой перезагрузке потом, комп на i7-3770, 8гб, да и на паре ноутов пробовал - тоже самое, то есть проблема не в железе, да и на предыдущих версиях такого нет, на 1709 все прекрасно, уже всю голову сломал.
    Пробовал предварительно последние накопительные обновы запихнуть через дисм++ - тоже самое((




    1 июня 2018 г. 18:34
  • а если сделать так:
    - установить чистую 1803
    - запаковать sysprep-ом сразу без аудита, ничего не доустанавливая
    - развернуть систему из образа

    второй вариант: тоже самое только в среде Hyper-V подготовить образ

    1 июня 2018 г. 19:03
  • А какая разница? я не хочу на экране приветствия ничего выбирать, поэтому сразу перехожу в аудит, хотя и без аудита тоже самое. И я ничего и не доустанавливал, одна маленькая утилита не считается, проверял без нее тоже самое, делаю это все на oracle VB, я не думаю что она сильно отличается от hyper-V



  • Вот проверим, и узнаем есть ли разница или нет.
  • Буду ждать, отпишитесь пожалуйста по результату
    2 июня 2018 г. 11:03
  • Ну..... Я как бы всегда делал образы на Hyper-V, и никогда подобных проблем не было.

    Вы проверьте у себя. Я это имел ввиду, когда писал "а если сделать так" ;)

    2 июня 2018 г. 11:30
  • Ну а я ка бы всегда делал на virtual box, и тоже никогда подобных проблем не было до выхода 1803, Hyper-V - это таже вируалка только от microsoft, попробую конечно, но совсем без виртуализации, т.е. на обычной машине получается тоже самое, я не думаю что Hyper-V это единственное что мне тут поможет, это как бы не логично!
    2 июня 2018 г. 16:04
  • Как я и предполагал, на hyper-v все тоже самое, да и хрен с ней с этой 1803, просто если они не исправят ошибку - будет не очень приятно, не буду же я всю жизнь на 1709 сидеть, на котором у меня прекрасно получается сделать себе идеальный образ.

    Как я и предполагал - в hyper-v все тоже самое, помогите пожалуйста решить проблему! Хотя конечно можно забить и сидеть еще год на 1709, но хочется решить вопрос




    4 июня 2018 г. 10:35
  • Уже как только не пробовал, в т.ч. на нескольких ПК, занимаюсь этим порядка 15 лет, никогда таких проблем не было, я уже в отчаянии.
    6 июня 2018 г. 12:34
  • Запустите "Process explorer", посмотрите какой именно процесс и его родительские или дочерние процессы вызывают такую нагрузку.
    • Изменено Anahaym 6 июня 2018 г. 12:41
    6 июня 2018 г. 12:40
  • Я в процесс эксплорере не сильно разбираюсь, но вот его лог https://cloud.mail.ru/public/Eo5u/wTfqYP7CM вирусов там нет, просто облако майл ругается на то что не проверено, хотя я думаю вы в этом разбираетесь лучше

     






    6 июня 2018 г. 15:21
  • Помойму и без Process explorer дело ясное, что дело темное
    6 июня 2018 г. 15:25
  • Добрый день, а не могли бы вы записать видео с виртуальной машины, как вы подготавливаете систему через /generalize?
    15 июня 2018 г. 13:55
  • Тоже самое делаю, а нет ссылки на вашу сборку, подготовленную сиспреп?
    16 июня 2018 г. 9:28
  • Тоже самое делаю, а нет ссылки на вашу сборку, подготовленную сиспреп?

    Добрый День.

    Уважаемый Александр Сметков,

    На форуме запрещено правилами выкладывать линки на софт подобного рода,так же не стоит подталкивать отвечающих нарушать условия EULA.


    Я не волшебник, я только учусь MCP CCNA. Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Пометить как ответ" или проголосовать "полезное сообщение". Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть без каких-либо гарантий. Блог IT Инженера, Twitter, YouTube, GitHub.

    16 июня 2018 г. 13:40
    Модератор

  • У меня вот такое каждый раз при загрузке? это нормально?

    18 июня 2018 г. 12:40
  • В итоге решил проблему отключением службы "перечисления уст-в чтения смарт-карт", видимо она после sysprep не отключается при старте и продолжает грузить ЦП, из-за нее также процесс LSM еще больше грузит ЦП, если эту службу в "отключено" перевести - то все норм, но теперь появляется при старте на 5 сек "служба защиты программного обеспечения", ее раньше не было. Но 5 сек не минута, уже хорошо, только что с той службой то делать - в отключено так и держать?
    6 июля 2018 г. 10:56
  • проверил у себя:
    PS C:\WINDOWS\system32> Get-Service ScDeviceEnum | fl -Property *
    
    Name                : ScDeviceEnum
    RequiredServices    : {}
    CanPauseAndContinue : False
    CanShutdown         : False
    CanStop             : True
    DisplayName         : Smart Card Device Enumeration Service
    DependentServices   : {}
    MachineName         : .
    ServiceName         : ScDeviceEnum
    ServicesDependedOn  : {}
    ServiceHandle       :
    Status              : Running
    ServiceType         : Win32OwnProcess, Win32ShareProcess
    StartType           : Manual
    Site                :
    Container           :
    
    Она и возможно и не должна быть выключенной...
    Если Смарт-картами не пользуетесь, то, возможно, можно оставить её выключенной. Надо гуглить.
    6 июля 2018 г. 11:50
  • Еще службу "Распространение сертификатов" отключил, из-за нее тоже грузит, вообщем как только отключаю эти две службы - проблема уходит. Но службы не хотелось бы вообще отключать.

    Отключение службы "Распространение сертификатов" sysprep не запоминает в отличии от "службы перечисления уст-в чтения смарт-карт" и переводит в режим запуска "автоматически", что приводит к излишней нагрузке на ЦП при каждой загрузке, приходится каждый раз ее отключать самому после разворачивания образа.



    6 июля 2018 г. 12:07
  • Эта служба тоже работает, вот только метод запуска у ней - вручную по тригеру:

    Get-Service CertPropSvc | fl -Property *
    
    Name                : CertPropSvc
    RequiredServices    : {RpcSs}
    CanPauseAndContinue : False
    CanShutdown         : True
    CanStop             : True
    DisplayName         : Certificate Propagation
    DependentServices   : {}
    MachineName         : .
    ServiceName         : CertPropSvc
    ServicesDependedOn  : {RpcSs}
    ServiceHandle       :
    Status              : Running
    ServiceType         : Win32OwnProcess, Win32ShareProcess
    StartType           : Manual
    Site                :
    Container           :

    Проверьте групповые политики, может где-то стоит принудительное переключение режима запуска в "автоматический".

    6 июля 2018 г. 12:42
  • Дело в том, что я ничего не настраивал в групповых политиках, вообще беру девственно чистый образ, запаковываю сиспреп, потом сразу же распаковываю и вот что получается:

    S C:\Users\Администратор> Get-Service CertPropSvc | fl -Property *


    Name                : CertPropSvc
    RequiredServices    : {RpcSs}
    CanPauseAndContinue : False
    CanShutdown         : True
    CanStop             : True
    DisplayName         : Распространение сертификата
    DependentServices   : {}
    MachineName         : .
    ServiceName         : CertPropSvc
    ServicesDependedOn  : {RpcSs}
    ServiceHandle       :
    Status              : Running
    ServiceType         : Win32OwnProcess, Win32ShareProcess
    StartType           : Automatic
    Site                :
    Container           :

    При этом, если отключить эту службу и перевести в режим запуска вручную, то лишние нагрузки на ЦП пропадают:
    PS C:\Users\Администратор> Get-Service CertPropSvc | fl -Property *


    Name                : CertPropSvc
    RequiredServices    : {RpcSs}
    CanPauseAndContinue : False
    CanShutdown         : False
    CanStop             : False
    DisplayName         : Распространение сертификата
    DependentServices   : {}
    MachineName         : .
    ServiceName         : CertPropSvc
    ServicesDependedOn  : {RpcSs}
    ServiceHandle       :
    Status              : Stopped
    ServiceType         : Win32ShareProcess
    StartType           : Manual
    Site                :
    Container           :


    6 июля 2018 г. 12:51
  • для информации: процесс выпуска сертификатов в 1803 (запрос в самой ОС) в настоящий момент не работает. Может это как-то связанно с Вашей проблемой.
    6 июля 2018 г. 13:32
  • Подскажите пожалуйста, как сделать чтоб sysprep не переводил в режим запуска автоматически службу "Распространение сертификата" после /generalize. Может как то в файл ответов добавить, чтоб он эту службу не включал вообще? Отключение других служб запоминает, а этой нет.
    7 июля 2018 г. 21:22
  • единственная идея есть - групповой политикой её выключать. но тогда надо в домен добавлять.
  • Спасибо, конечно, но как нибудь без домена обойдусь, у меня обычная домашняя группа. Я обычно эталонный образ создаю, с которого ставлю потом на все свои домашние девайсы и не только) До выхода 1803 у меня никогда таких проблем не было. Всегда создавал себе эталон, настраивал как нужно, запаковывал сиспреп, потом распаковывал аж на планшетах на windows, а тут уже 3 месяца мучаюсь, в итоге нашел только из-за чего это все, а как исправить не пойму, помогите службу отключить пожалуйста, ведь можно же как то через файл ответов
    9 июля 2018 г. 10:31
  • УРА!! Победа!! В Dism++ смонтировал виртуальный диск, на котором установлен и подготовлен с помощью sysprep мой эталонный образ с 1803, затем в самом нижнем разделе "Файл ответов" -> "PostSysPrep" в меню Dism++ добавил строчки 
    sc config CertPropSvc start= disabled
    sc config ScDeviceEnum start= disabled
    и заработало! Нет больше этих дурацких процессов в диспетчере задач. 
    16 июля 2018 г. 8:45