none
Comando "runas" não funciona para um determinado aplicativo. RRS feed

  • Вопрос

  • Olá.

    Não consigo executar o comando runas para um determinado aplicativo. Consigo executar para vários outros, mas este em especifico não funciona. Utilizei a sintaxe:

    runas /user:dominio\usuário c:\aplicativo.exe

    Desde já agradeço.

Ответы

  • Pessoal,

    Está parecendo problema de aplicativo.

    Quando o processo inicia com as credenciais alternativas, um novo ambiente é criado.
    Jaderson, tente colocar um "/env" na linha de comando, ou então executar um arquivo BAT com RUNAS, trocando o diretório atual antes de chamar o executavel:

    -- ARQUIVO BAT --

    CD \FOLDER
    APP.EXE

    -- RUNAS --

    RUNAS /USER:DOMAIN\USER /ENV /SAVECREDS arquivo.bat

    Espero que ajude.


    Marcelo Lucas Guimarães - MCP, MCTS, MCDBA, MCITP Blog: http://mlucasg.wordpress.com


    • Изменено MarceloLGuimaraes 4 июня 2013 г. 17:06 Incompleto
    • Помечено в качестве ответа Jader Silva 4 июня 2013 г. 19:50
    4 июня 2013 г. 16:50

Все ответы

  • Olá.

    Não consigo executar o comando runas para um determinado aplicativo. Consigo executar para vários outros, mas este em especifico não funciona. Utilizei a sintaxe:

    runas /user:dominio\usuário c:\aplicativo.exe

    Desde já agradeço.

    Obs: Se eu executar o aplicativo da maneira convencional (duplo clique) ele abre normalmente. Preciso usar o runas pois tenho que usar o parâmetro "savedcreds!".
  • Boa tarde Jader

    Coloque no programa assim.

    runas /user:dominio\usuario /savecred "c:\caminhodoprograma\programa.exe"

    Espero ter ajudado

  • Bom dia Bruno

    Obrigado pela resposta, mas o erro continua ocorrendo. Uso o mesmo comando em outro executável do mesmo fornecedor e funciona corretamente. Quando estou logado na estação com a conta com que quero que funcione pelo runas e tento abrir o software da maneira convencional ele abre corretamente. Se tento via linha de comando a interface do software apenas "pisca" de uma forma quase imperceptível.

    3 июня 2013 г. 12:22
  • Jader você colocou o "savecred"?
    3 июня 2013 г. 14:10
  • Jader, somente para critérios de teste, você consegue rodar o 'runas /user:usuario cmd' -> digitar a senha e na nova janela do cmd que abrir executar o aplicativo desejado?

    Dependendo do path que ele tenta executar, pode ocorrer problemas devido estar incompleto do ponto de vista da aplicação devido estar em ambiente de outro usuário.


    Att, Nino http://www.TInoBar.com.br

    4 июня 2013 г. 15:46
  • Pessoal,

    Está parecendo problema de aplicativo.

    Quando o processo inicia com as credenciais alternativas, um novo ambiente é criado.
    Jaderson, tente colocar um "/env" na linha de comando, ou então executar um arquivo BAT com RUNAS, trocando o diretório atual antes de chamar o executavel:

    -- ARQUIVO BAT --

    CD \FOLDER
    APP.EXE

    -- RUNAS --

    RUNAS /USER:DOMAIN\USER /ENV /SAVECREDS arquivo.bat

    Espero que ajude.


    Marcelo Lucas Guimarães - MCP, MCTS, MCDBA, MCITP Blog: http://mlucasg.wordpress.com


    • Изменено MarceloLGuimaraes 4 июня 2013 г. 17:06 Incompleto
    • Помечено в качестве ответа Jader Silva 4 июня 2013 г. 19:50
    4 июня 2013 г. 16:50
  • Obrigado Marcelo!

    Funcionou utilizando as duas opções que passaste.

    Valeu!

    4 июня 2013 г. 19:53
  • Parabéns Marcelo!

    http://insidestecnologia.blogspot.com.br

  • Pessoal,

    Está parecendo problema de aplicativo.

    Quando o processo inicia com as credenciais alternativas, um novo ambiente é criado.
    Jaderson, tente colocar um "/env" na linha de comando, ou então executar um arquivo BAT com RUNAS, trocando o diretório atual antes de chamar o executavel:

    -- ARQUIVO BAT --

    CD \FOLDER
    APP.EXE

    -- RUNAS --

    RUNAS /USER:DOMAIN\USER /ENV /SAVECREDS arquivo.bat

    Espero que ajude.


    Marcelo Lucas Guimarães - MCP, MCTS, MCDBA, MCITP Blog: http://mlucasg.wordpress.com


    Bom Dia Marcelo,

    Estou chegando nesse tópico alguns anos atrasado :)

    Inicialmente vim pela similaridade do problema do autor do post. E no meu caso o runas parece que funcionava pela metade quando eu usava o /savecred o programa não abria, vendo as opções do comando está escrito "/savecred" e eu li na tua resposta que você escreveu "/savecreds" (com S) ai pensei não custa tentar.

    Alterei os meus scripts e foi perfeitamente. Muito obrigado pela sua dica.

    13 сентября 2017 г. 14:10
  • Muito Obrigado!
    18 марта 2019 г. 13:48