none
Windows 8 backup (Win7 File Recovery system image) creation to NAS device fails with error 0x807800C5

    Вопрос

  • Hi,

    I have a ZyXEL NSA310 NAS device on my network that I use for backups (as well as a media server). I have been very happy with it as, amongst other things, it has a gigabit Ethernet connection. I recently upgraded my home laptop from Win7 Pro to Win8 Pro. Under Win7 the NAS device worked perfectly as the backup target. I could back up file sets and - most importantly to me - create a system image on the device should I need to restore the system in the event of a full disk failure.

    When I upgraded to Win8 it kept the Win7 settings and it looked like it was just going to work, then as it came to create the system image it failed with error code 0x807800C5 and message "The version does not support this version of the file format".

    I have searched the internet and seen that others have had similar issues on Win7 and Win8 with NAS devices where they have had to hack the device to get it working - though it isn't clear that this has been successful for everyone. This isn't an option for me as the NSA310 is a closed device and in any event I don't see why I should have to hack the device when clearly this is a Win8 issue (since Win7 worked perfectly).

    Does anyone have any ideas how to fix this issue so that I can create the full backups I require?

    Thanks,
    Phil

     

    ---

    Event Log messages:

    Log Name:      Application
    Source:        Microsoft-Windows-Backup
    Date:          13/01/2013 23:14:52
    Event ID:      517
    Task Category: None
    Level:         Error
    Keywords:     
    User:          SYSTEM
    Computer:      Home-Laptop
    Description:
    The backup operation that started at '‎2013‎-‎01‎-‎13T23:13:43.523158000Z' has failed with following error code '0x807800C5' (There was a failure in preparing the backup image of one of the volumes in the backup set.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

    Log Name:      Application
    Source:        Windows Backup
    Date:          13/01/2013 23:14:56
    Event ID:      4104
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Home-Laptop
    Description:
    The backup was not successful. The error is: There was a failure in preparing the backup image of one of the volumes in the backup set. (0x807800C5).

    14 января 2013 г. 0:21

Ответы

  • Hello Martin,

    Looks like protocol SMB 2.1 triggered this error "Incorrect function",

    2 methods could way around this symptom: "max protocol = SMB2_02" or "max protocol = NT1" 

    Steps:

    1) Edit /etc/samba/smb.conf.template

    2) Find "max protocol = SMB2" , and replace it with "max protocol = SMB2_02"

    3) service samba restart

    And try to backup again to see if error "Incorrect function" is gone,

    thanks.

    • Предложено в качестве ответа Martin Pelant 9 марта 2014 г. 12:29
    • Помечено в качестве ответа David WoltersModerator 4 апреля 2014 г. 15:53
    9 марта 2014 г. 12:06

Все ответы

  • Hi,

    What is the volume format? I think it should be NTFS. If not, we need to convert to NTFS and try to back up again. File History supports Network Location on NAS.


    Juke Chou
    TechNet Community Support

    16 января 2013 г. 9:43
    Модератор
  • Hi Juke,

    The file format of the NSA310? The online documentation says: "

    3.

    What is the file system supported in NSA310?

    Internal file system: XFS or EXT4.

    "

    However, the point is that "Windows 7 File Recovery" worked perfectly well under Windows 7 with this network device, but Windows 8 has broken it. It needs to be fixed in Windows, or at least I need a usable workaround.

    I read somewhere that Windows 8 "Windows 7 File Recovery" backups use the new VHDX format for system image backups? If this is causing the problem is there a way to use the old VHD format? I don't need an image backup of >2Tb, my HDD is only 0.5Tb. 

    Thanks,
    Phil


    • Изменено PTR000 16 января 2013 г. 10:00
    16 января 2013 г. 9:59
  • Hi,

    I'm still having this issue. Does anyone have any ideas?

    Thanks,
    Phil

    26 января 2013 г. 21:21
  • Hi,

    I'm still having this issue. Does anyone have any ideas?

    Thanks,
    Phil

    I'm having the EXACTLY the same issue with an IOmega storcenter ix2-200 that used to work perfectly under Windows 7 Pro. What is most infuriating is that the backup control panel correctly solicits the NAS directory and looks like it is going to work before failing as described.

    28 января 2013 г. 1:30
  • As a follow up to my last post...

    For a workaround, if your NAS device supports the creation of an iSCSI target then this can be mounted as a local disk and appears to work around the file format/block size issues with direct use of a NAS as a backup destination. Just remember that after you have created the iSCSI target on your NAS drive (using its setup procedures) and made it visible as an iSCSI portal (using windows iSCSI initiator setup)  that you still have to use windows' disk management tools to format it and create a volume the same way as if you had attached a new unformatted HDD. It can then be used as a viable backup destination for the windows 7 file recovery tools in windows 8.

    This workaround appears to work fine on my IOMega storcenter ix2-200 so I hope it works for your ZyXEL device. I have not done an A/B performance comparison of NAS versus iSCSI, but subjectively it appears to be about the same.

    -willis

    • Предложено в качестве ответа willis2 29 января 2013 г. 5:01
    29 января 2013 г. 4:57
  • Thanks willis! I will look into the iSCSI route. A quick Google search and I can see some mention of the NSA310 and iSCSI so maybe it does support it.

    One question: Have you ever attempted to restore a system image from a NAS iSCSI device with a Win8 Restore Disk? Is it easy? I just want to be sure that it is possible to do so in case the worst happens and I need to restore the entire image onto a new disk.

    Hopefully Microsoft will fix the issue with the standard NAS setup with an update in the future, but I don't want to wait for it.

    Thanks again,
    Phil

    29 января 2013 г. 12:01
  • Thanks willis! I will look into the iSCSI route. A quick Google search and I can see some mention of the NSA310 and iSCSI so maybe it does support it.

    One question: Have you ever attempted to restore a system image from a NAS iSCSI device with a Win8 Restore Disk? Is it easy? I just want to be sure that it is possible to do so in case the worst happens and I need to restore the entire image onto a new disk.

    Hopefully Microsoft will fix the issue with the standard NAS setup with an update in the future, but I don't want to wait for it.

    Thanks again,
    Phil

    Hi Phil,  No I have not had to do this yet, but I see no reason why it shouldn't work as the iSCSI disk looks just like a regular hard disk to the OS. I agree that Microsoft should fix the direct NAS support as the iSCSI approach does have the downside of dedicating a fixed chunk of your NAS drive to the iSCSI disk that you have to choose when you create the disk whereas the direct NAS just uses the actual space currently needed by the backup. Also I had some trouble getting authentication (access rights) to work so I left the iSCSI portal as open access - which is OK for a home solution but not a good idea in general. I will revisit this for my own setup and see if I can get it working but just wanted to mention it in case you have the same issue. It manifests itself as not being able to connect to the iSCSI portal due to failed authentication when running iSCSI initiator setup.

    -willis


    • Изменено willis2 29 января 2013 г. 12:16
    29 января 2013 г. 12:12
  • No iSCSI on this NAS, so unfortunately not a solution for me :(

    (Thanks anyway willis, that may help others with this issue!)

    29 января 2013 г. 21:53
  • All quiet from Microsoft? Any ideas on how to make this 'broken' feature work on Win8? It was fine on Win7...

    Thanks,
    Phil

    6 февраля 2013 г. 21:49
  • I'm having the same issue but, interestingly, I'm backing up to a NTFS hard drive that is connected by USB 2.0 to my NAS as extended storage.  When I connect the drive by USB directly to the computer the image backup completes without error.  When I connect through the NAS I get the same error you got.  Obviously, the issue is not the drive format or even the backup file format but maybe something to do with the MTU size or other communication parameter in the NAS.  Any thoughts anyone?
    6 марта 2013 г. 16:01
  • Hi - sorry to hear you're having the same trouble. Does the drive show up as NTFS when exposed via the NAS device?
    14 марта 2013 г. 23:43
  • So, I've been saving my Windows image backups regularly to my iSCSI disk, everything working nicely. But now when I need it, I can't find any way to open the iSCSI drive from within the Win8 Restore Disk environment. I'm working to copy the entire image to an external USB drive that is recognized by the Restore Disk environment, but any suggestions out there as to how to open iSCSI connection within Restore Disk environment?

    Andrew S. Martin

    6 сентября 2013 г. 18:00
  • Hello Phil,

    Have the same problem with W8Pro. Never had this issue on my Homeserver, but i'll needed to switchs to another solution because the hardware did not support the 3TB disk i'll bought. So i'll went for the NAS solution.

    When you disable in the backup settings the backup of the System partition and EFI then you backup will be succesfull. This is not what you want, but with the buildin backup tooling from W8 the only solution on this moment to backup the lokal drives and settings to youre NAS solution. So be aware you can't recover by a full diskcrash with the DVD ore USBkey W8recoversolution.

    Hope the NAS builders and Microsoft can fix this issue for there customers.

    16 сентября 2013 г. 12:02
  • I am having the exact same problem with Win 8.1  Pro and my Ready NAS Duo, which like many of your NAS devices worked fine under Win7 Pro.  Why does Microsoft seem determined to make life more difficult for us, and then abandon us on the forums? Help!
    7 декабря 2013 г. 16:12
  • The same issue! 

    Win 8.1 Pro + WD MyCloud

    I can't use file history because I have hundreds of thousands of files which would take a century to transfer over WiFi file by file due to the latency so I thought I could at least make a full backup to my NAS (I can copy large files over WiFi with acceptable 200Mbps).

    But it doesn't work neither :/
    • Изменено Martin Pelant 12 декабря 2013 г. 23:20
    12 декабря 2013 г. 23:19
  • Hello all,

    If the error detail said: "The version does not support this version of the file format",

    this failure could be fixed by adding "strict allocate = yes".

    1) Go to NAS side and find out the path of smb.conf (for example, /etc/smb.conf).

    2) Add "strict allocate = yes" under section [global].

    3) Restart samba service.

    Reference:

    http://blogs.technet.com/b/asiasupp/archive/2010/11/03/windows-server-backup-failed-with-error-quot-the-version-does-not-support-this-version-of-the-file-format-quot.aspx

    9 марта 2014 г. 11:09
  • The log says:

    Backup of volume \\?\Volume{3b94b3b3-11e9-12e2-bf66-807e6f6d6983}\ has failed. Incorrect function.

    9 марта 2014 г. 11:14
  • Hello Martin,

    Could you check /etc/samba/smb-global.conf,

    and post what is the parameter "max protocol" or "server max protocol",

    thanks.

    9 марта 2014 г. 11:32
  • here is my smb-global.cfg

    [global]
      load printers = no
      printable = no
      log file = /var/log/samba/log.smbd
      max log size = 50
      deadtime = 30
      enable core files = no
      security = user
      encrypt passwords = yes
      passdb backend = smbpasswd:/etc/samba/smbpasswd
      create mask = 0775
      force create mode = 0775
      directory mask = 0775
      force directory mode = 0775
      local master = yes
      domain master = no
      preferred master = auto
      os level = 5
      use sendfile = yes
      dns proxy = no
      idmap uid = 10000-65000
      idmap gid = 10000-65000
      admin users =
      null passwords = yes
      map to guest = bad user
      guest account = nobody
      force group = share
      unix extensions = no
      acl check permissions = false
      max protocol = SMB2
      browseable = yes
      syslog = 1
      socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=2048000 SO_SNDBUF=2048000
      min receivefile size = 16384
      smb encrypt = disabled
      writeable = yes
      delete veto files = true

      ## Note: be careful when setting "dos filemode=yes".  We have seen where Samba does not
      ## handle this properly (and crashes) upon a rename of a file where the authenticated user is not the owner.
      ##dos filemode = yes

    9 марта 2014 г. 11:52
  • Hello Martin,

    Looks like protocol SMB 2.1 triggered this error "Incorrect function",

    2 methods could way around this symptom: "max protocol = SMB2_02" or "max protocol = NT1" 

    Steps:

    1) Edit /etc/samba/smb.conf.template

    2) Find "max protocol = SMB2" , and replace it with "max protocol = SMB2_02"

    3) service samba restart

    And try to backup again to see if error "Incorrect function" is gone,

    thanks.

    • Предложено в качестве ответа Martin Pelant 9 марта 2014 г. 12:29
    • Помечено в качестве ответа David WoltersModerator 4 апреля 2014 г. 15:53
    9 марта 2014 г. 12:06
  • Hello Martin,

    Looks like protocol SMB 2.1 triggered this error "Incorrect function",

    2 methods could way around this symptom: "max protocol = SMB2_02" or "max protocol = NT1" 

    Steps:

    1) Edit /etc/samba/smb.conf.template

    2) Find "max protocol = SMB2" , and replace it with "max protocol = SMB2_02"

    3) service samba restart

    And try to backup again to see if error "Incorrect function" is gone,

    thanks.

    Thanks, SMB2_02 fixed the issue. Now when I start the backup with this command, it looks like it is working properly (no errors yet and I'm at 20%) 

    WbAdmin start backup -backupTarget:\\wdmycloud\MyBackup -include:C: -allCritical -quiet

    9 марта 2014 г. 12:26
  • Hello Martin,

    Glad to know this error "Incorrect function" is resolved.

    Here is a hotfix for Windows 8 and WS 2012 might also handle this "Incorrect function" :

    http://support.microsoft.com/kb/2920193/en-us

    But the hotfix for Windows 8.1 and WS 2012 R2 is likely not available yet.

    9 марта 2014 г. 13:02
  • hallo people's this problem relies in setting bigger sectors/ clusters  than 4kb on the harddiskdrive.

    becarefull with that because you'll and up with a nonbootalbe system. wich cannot be fixed.

    put your mindset to install windows from scratch on a drive already set with bigger clusters.

    yesterday i've made a backup that didn't give those errors wich i also had everytime... so it works!!

    good luck on that

    29 апреля 2015 г. 1:32