Windows 7 - VPN Missing Device RRS feed

  • คำถาม

  • I have a machine running Windows 7 Professional 64-bit. Having an issue with Windows VPN connections. Getting the 797 - Device Missing error when I try to connect. I searched up and down this solutions database and all over the internet, and I can't seem to solve my issue.

    When I look at my device manager, under network adapters, I can see that I have a WAN Miniport (PPTP) adapter, but when I look at the properties of the VPN connection I created, it shows "Modem Removed- Unavailable device()" under Connect using. To me, it seems like it's trying to use a modem that doesn't exist, and not my network card.

    I've checked all my services associated with the connection, I am unable to get the "Remote Access Auto Connection Manager" service to start. It fails with the error code "0x80000048: 0x80000048" and that's all I get. Checked my system and I do see the rasacd.sys file in my Windows\System32\drivers folder as rasacd.sys. I check my device manager, and I do not have anything under Network Adapters as "RAS Async adapter" even when I'm showing hidden devices.

    I've tried deleting the connections and recreating them. It seems like even though I'm specifying that I want to use my internet connection, it is trying to use a modem that doesn't exist. I just tried doing what's listed in this article, and it did not help either.

    Anything else that's listed out there as a possible solution, I've tried (deleting contents of the windows\system32\logfiles\wmi\rtbackup folder), and nothing has worked. Trying to see if there is anything else I can do short of having to reformat the system.



    16 กุมภาพันธ์ 2558 19:56



  • Hello Ryan,

    Can you use other computer to connect the VPN?
    If you can’t, please check the VPN configuration.

    Please take the following steps for troubleshooting:
    1. Go to the manufacturer website and update the latest network driver
    2. Go to Control Panel\All Control Panel Items\Troubleshooting\All Categories and run the Network Adapter troubleshooter

    Please open the event viewer and check if there are any related error log. For more information about the event log, please refer to the following article.

    Best regards,
    Fangzhou CHEN

    Fangzhou CHEN
    TechNet Community Support

    18 กุมภาพันธ์ 2558 9:05
  • Thanks for the reply.

    1) I recently updated to the latest drivers off of the HP website.

    2) Ran the troubleshooter, was not able to identify any problems with my network adapters.

    Here's the error I get when I try to connect:


    Here's what my network adapter screen looks like:

    By that icon, it looks like it is trying to use a modem to dial-up, but when I set up the VPN connection I am telling it to use my existing internet connection.

    I don't have any error messages in the system or application event log when I try to connect, only the above error messages.

    18 กุมภาพันธ์ 2558 16:06
  • Hello Ryan,

    Can other users normally use the VPN?

    Please take the following steps for troubleshooting:
    1. If you install any third-party VPN connection program, remove them and check if the issue still exists.
    2. Create a new account and check if the issue persists in the new profile.
    If you can normally use the VPN in the new profile, please refer to the following article to fix the corrupted profile.
    3. Preform a clean boot to exclude the cause of software conflicts

    For more information, please take a look at the following thread similar to this issue.

    Best regards,
    Fangzhou CHEN

    Fangzhou CHEN
    TechNet Community Support

    • เสนอเป็นคำตอบโดย Karen HuModerator 24 กุมภาพันธ์ 2558 9:27
    • ทำเครื่องหมายเป็นคำตอบโดย arnavsharmaModerator 9 มีนาคม 2558 3:46
    21 กุมภาพันธ์ 2558 6:08
  • I'll give this a shot when I get the chance in the next few days and let you know.


    Ryan Chiocchio

    24 กุมภาพันธ์ 2558 12:35
  • As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.  <o:p></o:p>

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.  <o:p></o:p>

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.  <o:p></o:p>


    Arnav Sharma | Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • ทำเครื่องหมายเป็นคำตอบโดย arnavsharmaModerator 10 ตุลาคม 2559 2:06
    9 มีนาคม 2558 3:46
  • This thread should not be closed.

    I have observed the same symptoms when I installed on my Windows 7 64bit Azure point-to-site 64bit vpn client. This client has broken my system. I cannot connect to Azure VPN as well as I cannot create new VPN. Existing VPN connection works, but even coping this existing connection is impossible. New copied connection doesnt work. Instead of ip address field of VPN server I can see "Modem removed" field.

    3 มีนาคม 2559 9:57
  • I am having the same issue with 2 of my Windows7 64bit laptops.  They have basically the same software as other workstations in our office, but when I try to set up the VPN I get the same behavior as described above:  I enter all the info for the VPN connection, but when I then go to "Change Adapter Settings", choose the new VPN connection and view the properties, it shows as a dial-up connection with the vpn address in the telephone number text box.
    26 กันยายน 2559 21:05