none
RDP/TS - Printing Error RRS feed

  • คำถาม

  • Hi,

    Not sure if this is the correct place to post regarding my issue, it's related to Printing/Printer Redirection on Remote Desktop Services!

    We have a Remote Desktop Server which day to day operates perfect. It's running Server 2016 DC, recently installed.

    We have been having this issue which either happens each day or every two days. We have printer redirection enabled and it works fine, however at some point during the day the server continues redirecting printers. When trying to print however the following error appears:

    The document Print Document, owned by <user>, failed to print on printer OfficePrinter (redirected 14). Try to print the document again, or restart the print spooler. 
    Data type: RAW. Size of the spool file in bytes: 1015048. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\APP1. Win32 error code returned by the print processor: 2147500037. Unspecified error
    

    Another error I seen was the below, which appears multiple times too.

    Application popup: Windows - Application Error : The instruction at 0x00007FFA5C56E616 referenced memory at 0x0000000000000074. The memory could not be read.
    
    Click on OK to terminate the program

    I did notice when going into Devices and Printers on the Remote Desktop Server the 'Computer/Server' has a status of "Device Setup in Progress" - I noticed the "Device Setup Manager" service was running - which should only be triggered when needed, tried to stop and restart the service however with no luck.

    I have tried restarting the Print Spooler, with no difference I also checked to see if we are using  Type 3 or Type 4 drivers as I read Type 4 can cause these kind of issues.

    The resolution at the moment, is to get users to log off and restart and this fixes it for a period of time!

    If anyone has some ideas or anything to try/look into, please let me know!

    Thanks,

    Adam

    30 เมษายน 2561 7:46

ตอบทั้งหมด