none
How to associate a protocol with a program? RRS feed

  • คำถาม

  • I would like to associate TEL protocol handler with a specific application installed on my Windows 8 system.

    I go to "Associate a file type or protocol with specific program" tool in Control panel and see that TEL is already associated with Google Chrome from some reason.

    https://skydrive.live.com/redir?resid=2DF593E3577864D3!109&authkey=!AMqiLlZTWxaD8zo

    I click Change Program and I see no viable options there.

    https://skydrive.live.com/redir?resid=2DF593E3577864D3!110&authkey=!AOBbAxw2mDYCnpc

    Then I go to "Set a Default Program" tool and I do not see my application there in the list (it is installed property):

    Anyway, I click on Google Chrome and then on "Choose Defaults for this program". I see the TEL protocol checked but I cannot uncheck it???

    https://skydrive.live.com/redir?resid=2DF593E3577864D3!112&authkey=!ANRhdtA0lXY3zC0

    Can someone please help me on this one?

    Thanks a lot!



    15 เมษายน 2556 8:56

คำตอบ

ตอบทั้งหมด

  • Go to charm menu, search, setting, type in default program. You will find what your looking for there. When you choose default and click on a file type and choose a program, or if the program is not in the list there is an option to browse your pc. There is also a option to choose a default program instead of filetype
    • แก้ไขโดย colakid 15 เมษายน 2556 10:21
    15 เมษายน 2556 10:16
  • Sorry, but I could not understand where to go?

    If you're talking about Default Programs in Control Panel, it doesn't work for me - see above why.

    And, I'm not trying to associate a file type. I'm trying to associate a protocol. There is no "browse your pc" option for protocols...

    15 เมษายน 2556 10:57
  • If you're talking about Default Programs in Control Panel, it doesn't work for me - see above why.

    FWIW I see more options when I do that with the owner account in admin mode.   E.g. I just tried to add .dmp as a new extension.  It wasn't showing so I tried using assoc in a cmd window and was forced to elevate that as well to do that.  So now I have a previously unknown extension with an unassigned filetype and could now assign it to a program.   Perhaps you could do that with your program?  Then if you tried using the command which says "Make a program the default for all the file types and protocols it can open" you would be able to do what you want?

    Otherwise does your program not have a way of registering for the protocol it wants to use?  Then presumably you could change the default program from Chrome to it using the "Associate a file type or protocol with a program" command more straightforwardly.

     
    Good luck

     
    Robert Aldwinckle
    ---

    15 เมษายน 2556 20:55
  • Go to the top right of screen to open the charms menu, click on setting, click in search, type in default. Here you can accomplish what your looking for

    Thanks but I clearly explained in my post why this does not work for me. 


    16 เมษายน 2556 12:04
  • Thanks but I clearly explained in my post why this does not work for me. 


    While you were logged in as the owner and acting as an administrator?
    16 เมษายน 2556 12:27
  • If you're talking about Default Programs in Control Panel, it doesn't work for me - see above why.

    FWIW I see more options when I do that with the owner account in admin mode.   E.g. I just tried to add .dmp as a new extension.  It wasn't showing so I tried using assoc in a cmd window and was forced to elevate that as well to do that.  So now I have a previously unknown extension with an unassigned filetype and could now assign it to a program.   Perhaps you could do that with your program?  Then if you tried using the command which says "Make a program the default for all the file types and protocols it can open" you would be able to do what you want?

    Otherwise does your program not have a way of registering for the protocol it wants to use?  Then presumably you could change the default program from Chrome to it using the "Associate a file type or protocol with a program" command more straightforwardly.

     
    Good luck

     
    Robert Aldwinckle
    ---

    ASSOC if for associating file extensions. It does not work for protocols. At least I couldn't make it work for protocols.

    And, yes I'm using administrative account with owner rights on my system.

    My program doesn't have a native way of registering for that protocol but it handles this protocol calls and so I have to register it for that protocol.

    I also see more option when associating file extensions but they do not appear for protocols.


    16 เมษายน 2556 12:53
  • Found a solution for my problem:

    http://msdn.microsoft.com/en-us/library/windows/desktop/cc144154(v=vs.85).aspx

    It is complex and requires manual reg editing but now my program shows in the list when I click "Change Program".

    • ทำเครื่องหมายเป็นคำตอบโดย Atanas Dyulgerov 16 เมษายน 2556 14:12
    16 เมษายน 2556 14:11
  • Then if you tried using the command which says "Make a program the default for all the file types and protocols it can open" you would be able to do what you want?

    ASSOC if for associating file extensions. It does not work for protocols. At least I couldn't make it work for protocols..


    I was only using that as an example of how (an easy way) to make a program appear in the list where it wasn't previously in the list.   It would be up to your program to understand when it was called that it was being allowed to register both extensions and protocols (emphasis repeated).

    I didn't bother trying it but an obvious extension of that idea to try would be to see if you could create a new "file type" manually e.g. using the ftype command.  Then if that showed up in the GUI list in the same way that the extension did you could have tried assigning your program to it instead, thus getting your program in the list, and thus enabling your program to be treated with the other command.

    If you just wanted to do a registry hack  NirSoft's  FileTypesMan  would have been a better alternative.

     
    FYI

     
    Robert
    ---

    16 เมษายน 2556 16:21
  • Here is the easiest way to accomplish this:

    http://www.expta.com/2013/04/fixing-tel-links-with-lync-2013-on.html

    29 มกราคม 2557 22:07
  • Did not read all the post but here we go. If this was tried then ignore

    1 goto charms

    2 search for defaults

    3 a selection of defaults will come up

    4 choose defaults apps for each protocol

    This is limited to the defaults

    Edit: as mention if the default is not what you want you will need to do the registry fix and they are easy to find which you have already.

    Edit remember to backup your system or the registry keys your changing, export that incase you have a backfire. Call the name xxx.reg. You will be able to double click it to merge it back






    • แก้ไขโดย colakid 29 มกราคม 2557 23:24
    29 มกราคม 2557 22:26
  • could you go into more detail on which registry keys you added?
    2 เมษายน 2557 14:16
  • I'm experiencing this exact same problem on Windows 10. Unfortunately, the link to associate Tel protocol that pertain to Windows 10 is no longer available. I am very familiar with System Registry setup even using PowerShell. I just haven't found the Key that control this setting. Could someone help me please?
    19 พฤศจิกายน 2562 1:55