none
windows cannot connect to the printer the local print spooler service is not running please restart the spooler or restart the m RRS feed

  • คำถาม

  • We have 7 computers on a local network 3 of them have local printers 2 and are brand new Vista equiped. we shared the local printers on the vista machines but they are unaccessable from one vista to the other... it works from an XP to a Vista, but not from a Vista to a Vista.... go figure.... When we try to add the printers, the error message that we get is: "windows cannot connect to the printer. the local print spooler service is not running. please restart the spooler or restart the machine."

    I would appreciate any help...

    Thank you

    27 กุมภาพันธ์ 2550 4:19

คำตอบ

  • I ran into this exact same issue today.

     

    The way we fixed it was by checking the Properties on the Print Spooler service under services.msc.

    Go to the Log On Tab and make sure that the 'Local System account' option is selected along with the 'Allow service to interact with desktop' box.

     

    Then set the Print spooler service to auto and start it.  After that you should have no problem installing your printer (s). 

    2 มิถุนายน 2550 22:03
  • You can start the Print Spooler using the following procedure:

    1. In the Administrative Tools folder (click Start, then Control Panel, then System and Maintenance and then Administrative Tools), open the Services snap-in.
    2. Locate the Print Spooler service in the list of services and confirm that the status is Started. If it is not, select the service and on the Action menu, click Start.

    You can also do this from an elevated command prompt window (right-click Command Prompt in the Start menu and click Run as Administrator) by typing the following command: net stop spooler && net start spooler

    (This is actually two commands, "Net stop spooler" and "Net start spooler", entered at the same time so that Windows processes both commands, one after the other).
    22 ตุลาคม 2550 0:08
  • I was also having the same problem.  I was trying to connect to the shared printer by opening up the network page, finding the shared printer on the computer that had it, right clicking on the printer name and selecting "Connect..." from the context menu.   This did not work as it failed with the same error reported above.

    I then tried connecting to the printer by going to the Printer page and selecting "Add a printer" from the button above.  This opened up a Wizard that searched for printers available.  I saw the printer I wanted and successfully connected to it and made it my default.

    Hope this helps anyone having this annoying problem.

    17 มีนาคม 2550 23:57
  • This can happen if Print Spooler needs other services, and these services are not running. To resolve this issue, use the following procedure:

    1. In Services, right-click Print Spooler and then click Properties.
    2. Click the Dependencies tab. The first box lists all of the system services that must be running for Print Spooler to start. These are the dependencies.
    3. Make a note of each service, click OK and then start each service upon which Print Spooler is dependent, if the service is not already started. If a service was not started, right-click it, click Properties and then confirm that the Startup type is Automatic.

    I hope that this helps!

    22 ตุลาคม 2550 0:31
  • Start > Run > cmd and type "net stop spooler" after that "net start spooler" or start > run > service.msc and restart it over the GUI.

     

    Regards,

    Kuskaya

     

    10 กันยายน 2550 20:05

ตอบทั้งหมด