none
Weird NCSI issue in Windows 10 Insider Prevew builds RRS feed

  • Soru

  • Hey everyone!

    I am having a strange problem with NCSI on new Windows 10 Insider Preview builds.  I just upgraded this week to the latest there, which is build 18970.  I also had it on 1903 before that I believe, but would have to verify. 

    Basically, we use Pulse Secure for VPN, and everything works fine, UNTIL we connect to this VPN tunnel.  Not sure why, but NCSI is failing to detect Internet connectivity, even though I can physically get to http://www.msftconnecttest.com/connecttest.txt .. I am not sure where the disconnect is, but on 1809 and 1803, it worked fine.

    The reason this is such a big deal, is Microsoft Office 365 client applications like Outlook refuse to even try to connect to services if NCSI isn't detecting Internet connectivity, even though there totally is. 

    If I disconnect the VPN, and then launch Outlook it works, and CONTINUES to work when I reconnect to VPN.  It's only the initial launch that fails, because that's how Microsoft Office works.  It takes that "No Internet Access" as gospel, even though there IS Internet connectivity.

    We use a proxy in our environment, and all Internet traffic is routed through the VPN tunnel when connected.  I am able to get to the website shown here with the proxy hard-coded, or it being transparently proxied, which takes a proxy setting out of the equation, as well as the proxy itself, since as you can see here, the website works.  NCSI isn't.    Please help...

    5 Eylül 2019 Perşembe 01:45