Reporting service not working after upgrade of DPM RRS feed

  • Soru

  • Hello,

    Done an upgrade from DPM 2016 to DPM 2019 and after this reporting service is not working as it should.
    When clicking reporting in the GUI it shows up as it should - but when trying to get a report e.g status report I get a login prompt.
    If trying to login with DPM reporting service account it doesnt work - same with domain admin account - if I type in the password the login comes back and generates the ID4625 in the security event log.
    I can and have tried to change the user and password from the RS configuration manager but same problem.

    At some point in the troubleshooting this error showed up for the service account/domain account when browsing to the Web portal URL:

    The permisson granted to user "domain\serviceaccount" are insufficient for performing this operation. (rsAccessDenied)

    For the domain account I get this in the securit log:

    Event ID 4625
    Unknown user name or bad password - 0xC000006E

    So its clearly a permission problem somewhere but I cant figure out where ? And how could this happen during an upgrade of DPM ?

    Is there a way to just simply reinstall reporting service or do I need to reinstall both SQL and DPM ?

    Thank you very much in advance for any input


    22 Ağustos 2019 Perşembe 14:39

Tüm Yanıtlar

  • Hello Mikael,

    This is not normal behavior, could you please provide more details about your environment and which steps you took for upgrading DPM 2016 to DPM 2019?

    Provide the following details:

    • DPM server operating system version.
    • SQL Server version and build.
    • SQL Server Reporting Services version.

    Best regards,

    Blog: LinkedIn:

    22 Ağustos 2019 Perşembe 16:15
  • Hello Leon,

    Sorry for the late reply.

    I followed these steps:

    DPM server version is Windows 2016 version 1607 with the latest security updates

    SQL and reporting service have SQL server 2016 and version is 13.0.4259.0

    I know its not the latest but dont want to mess things up even more without checking here :)

    Thanks in advance


    28 Ağustos 2019 Çarşamba 09:09
  • Ok all good there, something didn’t go right in the upgrade even though sll is shown as ”OK”..

    Can you check how the permissions look like in the Report Manager? Browse to the DPM’s SSRS web portal url and check the permissions there, you can also try to add yourself there (with full permissions) to see if you can access the reports.

    Blog: LinkedIn:

    28 Ağustos 2019 Çarşamba 15:30
  • Sorry if i was unclear.

    If I try to go to the SRSS web portal I get the above errors so I cant add any permissions.- at least not that way.

    29 Ağustos 2019 Perşembe 12:23
  • Did you try like this:

    1. Start your browser with "Run as administrator".

    2. Open your http://DPMSERVER/Reports

    3. Click on the settings gear and select Site settings.

    4. Click on Security.

    5. Add group or user. (try with System Administrator)

    6. Then go to Home.

    7. Click on Manage folder.

    8. Add group or user (Add at least Content Manager, you can try with more too).

    9. Restart your browser and try again.

    Also verify your permissions in the SQL Management Studio for your ReportServer database.

    Blog: LinkedIn:

    29 Ağustos 2019 Perşembe 12:46
  • I tried this - but fails on step 3 - dont have a site settings option unless you mean internet options and then the security tab - but under there there are not possible to add any users or groups from what Ive found
    29 Ağustos 2019 Perşembe 19:19
  • What I meant is the following:

    Did you verify the permissions in the SQL?

    Blog: LinkedIn:

    29 Ağustos 2019 Perşembe 19:31
  • I dont get that page when going to http://dpmserver/reports - I come to a quite basic internet explorer page where it shows one link to the reports.

    Checking the permissions both accounts are SA and public. Looking at user mapping both accounts are dbowner, public and RSExecRole set

    As a test I added db_datareader on the DPMDB for both accounts - found some blogs pointing that could be the problem and I got another error - I actually got 1 step longer - I get the login box - I type in the user name and password and get this page

    In addition I tried to login to reporting services through management studio - that works without any problems.

    2 Eylül 2019 Pazartesi 07:30
  • Something's mixed up, the result you're seeing is the ReportServer page (i.e http://dpmserver/ReportServer)

    Could you please verify the Report Server Configuration Manager for the DPM SQL Server Reporting Services?

    Check the Web Service URL and the Web Portal URL, and provide screenshots of both.

    It should look similar to this:

    Blog: LinkedIn:

    2 Eylül 2019 Pazartesi 08:21
  • The URLs was the opposite of what you posted - meaning reports was under web service URL and vice versa - i changed it so it looks like your screenshots but I still get the same error.

    And now when I go to http://dpmserver/reports I get a the webpage cannot be found.
    If I go to reportsserver I get the login but coming back to second screenshot from previous post.

    Screenshots before the change

    Screenshots after the change

    2 Eylül 2019 Pazartesi 08:53
  • Since the URLs were configured wrongly, I suspect the reporting services configuration file is still wrongly configured.

    Easiest would probably be to reinstall the SQL Server Reporting Services, it doesn't take long (you won't lose any data).

    1. Uninstall SQL Server Reporting Services.

    2. Re-install SQL Server Reporting Services.

    3. In the Report Server Configuration Manager under the Database tab, select Change Database and select "Choose an existing report server database".

    4. Provide the same credentials as you were using previously (that has access to the report server database).

    5. Configure both Web Service URL and Web Portal URL by going to each tab, and click Apply.

    Then test the URLs once again to check if the issue persists or not.

    Blog: LinkedIn:

    • Yanıt Olarak Öneren Leon Laude 30 Eylül 2019 Pazartesi 17:40
    2 Eylül 2019 Pazartesi 09:26
  • Hi,

    Just checking to see if you have any update?

    (Please don't forget to mark helpful replies as answer, this helps the community to recognize helpful contributions)

    Blog: LinkedIn:

    30 Eylül 2019 Pazartesi 17:40