Microsoft Wireless Display Adapter - pairing fails on many laptops RRS feed

  • Soru

  •  We are looking for a wireless mirroring option for our school classrooms that is not too expensive so we bought one of the MS Wireless Display Adapters to try it out.  We tried it on three different model laptops with Windows 10 and an older Surface.  The older Surface (Windows 10 on it) worked.  However, the three laptops did not.  It acts like it is connecting, shows the machine name on the screen, and then after awhile says the pairing failed.

    Two of the laptops are newer HP Probook models and one is a Daktech laptop that is not too old.  I updated the wifi and video drivers on the laptop but it didn't make a difference.  The MS Adapter has the latest firmware on it.  Windows 10 is current versions.

      I have tried a number of different things I found online to try with no success. 

      Any ideas?  Does Microsoft provide actual phone support for these?  
      Or do these just stink, and if so, has anyone found a better alternative that is not too pricey?

    Thank you!



    19 Şubat 2018 Pazartesi 15:59

Tüm Yanıtlar

  • Hi David,

    Would you provide the OS version on those devices (contains the Surface one)?

    I know Microsoft provide Tel support, but it might cost money.

    Seems like the website:


    23 Şubat 2018 Cuma 08:28
  • acts like it is connecting, shows the machine name on the screen, and then after awhile says the pairing failed. 

    Make sure that you remove any previous instances of the connection (e.g. in Bluetooth and other devices).  There is a link to that Settings dialog from the Connect dialog (Win-K).  Otherwise there will be a Local Area Connection* associated with the Wi-Fi Direct device that you could try using the troubleshooter on.  This is new in the W10 FCU--not seen before that.

    Robert Aldwinckle

    24 Şubat 2018 Cumartesi 05:23
  • I have found the Microsoft Miracast to be very reliable until now, just recently I have found two issues, which may be connected. I have connected to a brand new Miracast - it worked fine with v2.0.8350. I tried updating the firmware and it doesn't feel like it completes correctly, however, when the Adapter restarts it says that it is on v2.0.8372. From then on, the connection starts but then fails "Pairing failed - try again". I have the latest version of Windows 10 which is fully up to date with patching. Any suggestions please?


    5 Mart 2018 Pazartesi 11:04
  • Mine still saying v2.0.8350 but I have the same problem. I´m completly unable to connect it with my Surface 4Pro. I was able to connect it before trying to update it to the last fimware.

    19 Temmuz 2018 Perşembe 11:12
  • unable to connect 

    Did you Remove the old connection?  BTW supposedly I am at 8381.  As usual I forgot to Remove the old connection before getting everything working again.  I even had an unsent Feedback report open about that as a reminder.

    Robert Aldwinckle

    19 Temmuz 2018 Perşembe 12:30