Age of Empires 2 [compatibility issue(s)]


  • Computer game
    Age of Empires 2
    Age of Empires 2: Age of Kings
    Age of Empires 2: The Conquerors

    Computer game is A.K.A.

    AoE2, AoK, and Ao2: AoK.

    Windows 7 RC (64-bit)
    With Windows 7 RC (64-bit), the game could run just fine, but with color issues as if we had suddenly forgotten what the color of the grass looked like (green, right?). In order to resolve this issue, the only thing we were left with was to press Ctrl+Alt+Del and close explorer.exe or of course do it by making a batch file that automatically took care of the problem. No further solution was given by Microsoft, no further attempt was made.

    Windows 7 Enterprise (64-bit)
    With Windows 7 Enterprise (64-bit), the game simply cannot run anymore. You get into the game's menu, but as soon as you either click to start a campaign, scenario, or even the map editor, the game shuts down. Windows 7 then gives you a message that says "Haha, this game is too old and us here at Microsoft don't care," without sounding to vulgar about this whole ordeal.

    How can this issue be resolved?

    How come this game, that is still one of the most popular strategy games up-to-date, has not been given any updates?
    - Compatibility
    - Screen resolution
    - Color debt
    - Game engine (at one point there are so many entities in the game that it ends up lagging no matter what computer you have)

    Before you give me any answers,
    1.) DirectX 9.0c does not work
    2.) Shutting down explorer does not work
    3.) TAB in and out of the game indefinitely does not work
    4.) Searching the web for tools that may or may not work, does not work
    5.) Solve the issue myself without the proper tools, does not work
    6.) Remaking the game is an infraction on copyright legislations because Microsoft still holds brand
    01 Mart 2010 Pazartesi 22:33


Tüm Yanıtlar

  • Hi,

    Try to run the game in compatible mode, just follow the example link Also do not forget choose "Run as administrator".

    02 Mart 2010 Salı 08:03
  • What is the brand and model of graphic card? In Windows 7 Compatibility Center, Age of Empires 2 is compatible with Windows 7 64bit. You may need to contact the graphic manufacturer to obtain the latest graphic driver and download updates for Age of Empires 2. Since this game was designed for older system and only supports 800x600 graphics, please try to adjust the screen resolution down to 800x600 with 256 colors, then launch the game to see if it works.

    Moreover, you can refer to the following methods to get a better game performance.

    Fixing game performance problems

    Best Regards

    08 Mart 2010 Pazartesi 06:57
  • Hi all,

    I have written an application "AOE 2 TC color FIX", which helps you with color issue on AOE 2 The Conquerors. The application can run at the windows backgroung and "watches" in process list, if age2_x1.exe has started. If so, the application AUTOMATICALLY suspends or kills (depends on method you choose) the explorer and relieves it back, when AOC is closed. Test it!

    Looking forward for your tests and replies :)



    de Bill

    P.S.: Virus FREE :-D

    29 Mart 2010 Pazartesi 10:48
  • Also, it is practically imposable to play multiplayer between computers running Windows 7, or any situation involving Windows 7, (it is possible with a combination of Windows 7 and Vista computers if you really work at it). All you can find online about this is a whole lot of other people trying to get it to work and deciding it can't be done.
    10 Haziran 2010 Perşembe 22:43
  • Thanks dale, just from changing to 256 colors in the properties, it's stop my "lag" when i load age of empires up thanks for your help.
    16 Temmuz 2010 Cuma 20:03
  • I have windows 7 enterprise installed, and i have played AOE 2conquerors two times last week, but now i can't get further than the loading screen on the desktop. it IS possible to get it started, but actually i don't know how i got so far.

    btw, epic game (:

    27 Aralık 2010 Pazartesi 14:37
  • All the moderators here do not understand the problem once again.....


    Here is the truth about the issue


    The reason the game will not play on your system is due to the fact it was made for Directx 5 and 6.  If you have the latest Directx installed that is why you get that video driver error message, since the game relies on the older version of Directx.

    The reason I know this answer to be true is the fact I just reloaded my PC with Windows 7 Ultimate, updated all my drivers and all of Windows to latest and greatest, with one exception I installed directx 5 which came with the game and it plays fine on Windows 7 now.


    Go figure, all of the Microsoft support could not figure that one out.....apparently the latest DirectX is not backwards compatible like they are claiming it to be. 


    Ok you Microsoft geniuses and guru's that claim to know a lot about your product.  See if you can duplicate what I have done.

    Clean install of Windows 7

    Update Video and sound drivers to latest

    Apply all of Windows updates

    Then install the game, and then install the directx that came with the game.

    Then Play the game you fools....Don't tell people it is not compatible unless you really know what you are talking about.

    If you install any directx above 2 levels from what the game has on it then you will get that error message, it is a Directx issue not a video driver issue.  Please duplicate what I have done and then tell everyone that this is correct and stop the miscommunication and thinking that you are right all the time.....


    This message will be posted in several areas that deal with Age of Empires II (Gold, The Age of Kings, and The Conquerors Expansion)


    28 Ocak 2011 Cuma 16:24
  • AWESOME fix, man! Thanks!
    30 Haziran 2011 Perşembe 06:21
  • ben has a good idea with the suggestion to install DirectX from the game, but is a little bit off in suggesting DX is not backward compatible.

    Direct X on Win 7 is compatible  for three versions. DX 9, 10 and 11, so DX is compatible to that degree, and by adding the older files it is fully compatible.

    It is unfortunate, however that the pundits at Monopoly$oft made an incorrect decision that no one plays old games any more.

    I too am surprised at how many people are still attached to pre DX9 games. I had to install DX 8 as well.


    I am also curious if ben has 32 or 64bit Win7 as the game is said to be incompatible with 64bit, but I think that would be more an installer issue than

    the game itself.


    01 Temmuz 2011 Cuma 06:48
  • Hello, is there a quicker fix than reinstalling everything? perhaps If I temporarily moved the DirectX folders for 6 through 11 in the windows folder, would that fix it so that the game would run off direct X 5, or would that cause some major windows problems?
    10 Temmuz 2011 Pazar 22:56
  • I know that it is not the bits that matter. Be it the 64 or 32 bit version of windows you have it does the same thing on each one. its just the game itself.
    01 Ağustos 2011 Pazartesi 02:05
  • Wow. A (recently) updated thread on this! The game LOADS on my new vaio. However, as soon as I get past the opening movies (which look and sound perfect), I get to the actual main menu, which sounds ok, but is a grey and black scrambly MESS. Looks sorta like an old analog TV getting static fuzz for lack of a signal. Is this part of the problems for DirectX/256 colors, or is this a different problem entirely? Compatiblity mode and "run as 256 colors" does nothing to the process.



    04 Ağustos 2011 Perşembe 04:46
  • worked thank you
    25 Ağustos 2011 Perşembe 13:53
  • So is it ok to install multiple versions of DX then?

    My two favorites are FSX and AOE2 with The Conquerors expnansion. FSX is running great so I don't to slow that down, AOE2 doesn't even load, it fails with the APPCRASH message. 


    • Yanıt Olarak Öneren Melerland7 16 Ocak 2012 Pazartesi 05:22
    • Yanıt Önerisini Geri Alan Melerland7 16 Ocak 2012 Pazartesi 05:22
    26 Ağustos 2011 Cuma 11:59
  • I had the same problem as everyone else did.  Would not run on Windows 7 64 bit.  I tried the changing the directx - didn't work.  Reset the compatibility mode - didn't work.  This is what I did to get it to work:


    Did the crack updates for AOE 2 and/or AOE 2 Conquers:  Just did a google search for AOE 2 crack.  The crack disable the CD check that is causing the problem.


    Then to fix the color I did the following:

    1. Open notepad and copy/paste the part from the quote box

      • If you have Age of Empires II:
        taskkill /F /IM Explorer.exe
        Start explorer.exe
      • If you have Age of Empires II with expansion:
        taskkill /F /IM Explorer.exe
        Start explorer.exe

    2. Save as Windows7 fix.bat and put it in the same folder where you installed Age of Empires.
    3. Make a shortcut to the bat to access the game and if necessary change the icon so it looks like the actual shortcut


    I tried everything else put it did not work.  Now AOE 2 works in  Windows 7 64 bit.


    I piece these fixes from numerous sites and repair attempts.  Found these to work and everything is running now.

    • Yanıt Olarak Öneren StickyKey 06 Mart 2012 Salı 06:20
    16 Ocak 2012 Pazartesi 05:30
  • Thanks so much to Melerland7 for the fix, and this is why it makes sense:

    Windows Vista and Windows 7 (and probably Windows 8 too) rely on newer Direct X drivers to be running to display the desktop. If the desktop is no longer being displayed, the drivers are unloaded and compatibility mode with pre-9 versions functions properly. Direct X cannot load both new and old drivers at once, but it is compatible to a point. Most games that require Direct X 4, 5, whatever won't display properly because they don't know how to use the new drivers correctly.

    Additionally, I do not recommend multiple version installations of Direct X, they can interfere with each other.

    06 Mart 2012 Salı 06:27
  • bentontech,

    I am having similair problems listed for this game. I tried compatability mode, I've tried just about everything recommended. I want to install the directx that came with my age of empires II gold, but I don't know what to do. I have windows 7 on my computer. Also, do I need to uninstall my current version of directx? and are there any other steps I need to take to be able to play AoEII?

    31 Mart 2012 Cumartesi 21:31
  • This was amazing. Thank you so much! Worked right off the "bat", so to speak... I found my old Collector's Edition discs, re-installed, and almost had a heart attack. Found this thread, and then your post. Super useful. Thanks again!
    08 Nisan 2012 Pazar 05:06
  • Simply do a right click on the Desktop, then open Display resolution properties - and leave them open - (for German OS: "Bildschirmauflösung").

    That's all!

    Start the game and enjoy - no more color issues.

    Whilst above is also not a permanent solution, it is certainly a better than killing explorer.exe as that has adverse effects.

    • Yanıt Olarak Öneren crismes 27 Haziran 2012 Çarşamba 17:13
    27 Haziran 2012 Çarşamba 16:56
  • just having my resolution window opened and dashed down to the taskbar worked like a charm, only/easiest fix i have ever found for a game, now to try this with masters of orion II as well :D
    22 Haziran 2015 Pazartesi 19:50
  • I was able to run aoe, aok, etc on windows 8.1 with no real problem, but on windows 10 the location on the map automatically goes to the top center screen.  When you click on the small map it jumps there and then proceeds to the top center again making the games unplayable.  I had a lot of games that worked on windows XP that quit on windows 8 when my old computer died.  Now, with windows 10 I guess I will have to play games intended for phones instead of real computer.
    31 Temmuz 2015 Cuma 21:07
  • muy de acuerdo con todo lo dicho: es un abuso que merece el rechazo de los clientes de Microsoft y adaptarse a otros sistemas operativos mas justos. Yo he comprado todos los juegos de Age of Empires y de Age of Mthology pero MICROSOFT HA DECIDIDO QUE ¡ Ya he jugado bastante... ahora los niños jugaran a lo que yo desee!
    19 Ekim 2015 Pazartesi 17:27
  • Thank you.  This is the only thing I have seen work.
    13 Mayıs 2016 Cuma 06:16
  • That is not entirely true...

    My pc is already 10 years old, but has directx11 and I just used the 1.0e patch on conquerors expansion, and now it's working.

    However, on my friend's pc, one unist000 file is missing, I think that major files like that that are corrupted or missing are the main problem, not the directx version

    31 Mayıs 2017 Çarşamba 13:18
  • hi

    Im really not good with computers and don't understand a lot of this, however everything I have tried doesn't work. will I actually have to reinstall windows 7 plus how do I download the DirectX from the cd ?? and will I have to remove the current ones ?


    23 Ağustos 2017 Çarşamba 00:36