none
Uninstall Microsoft Virtual WiFi Miniport Adapter Permanantly RRS feed

  • Soru

  • How do I permanantly remove this pos from my laptop? It's giving me errors, when I hit the wireless button (to enable/disable) on the laptop half the time it disables the Microsoft Virtual WiFi Miniport Adapter, not my laptops wireless, I can't connect to APs properly with it running, takes 5 or 6 tries of disabling everything and reenabling.

     

    Didnt have a single issue until this was installed secretly on my machine.

     

    MS post proper solution to PERMANANTLY remove this useless device that just breaks everything.

    13 Mayıs 2010 Perşembe 13:41

Yanıtlar

  • I finally found out how to uninstall the microsoft wifi miniport adapter its so easy all you do is go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow"  also no quotes. at first i thought this was disabling it same as right clicking and disable but actually it disables the service and the microsoft wifi miniport is gone. for some reason its mode gets set to allow instated of disallow  and when you uninstall it it reappears and messes up the networking, example, printers,wifi routers,etc.

    theres no way to uninstall it because it part of windows 7 for sharing wifi. IT WORKS TRY IT.

    its not a bug in windows 7. wow 

    • Yanıt Olarak Öneren test tyler 28 Şubat 2011 Pazartesi 19:03
    • Yanıt Olarak İşaretleyen Allister Wade 29 Eylül 2011 Perşembe 18:12
    28 Şubat 2011 Pazartesi 19:03

Tüm Yanıtlar

  • Hi,

     

    The “microsoft virtual wifi miniport adapter” is related to a new feature in Windows 7, Wireless Hosted Network:

     

    About the Wireless Hosted Network

     

    This device is just a virtual device and it should not affect connecting the wireless network with the physical wireless adapter .

     

    However, if you would like to disable it, please use the command in above article.

     

    Thanks,

    Novak

    • Yanıt Olarak İşaretleyen Novak Wu 24 Mayıs 2010 Pazartesi 02:16
    • Yanıt İşaretini Geri Alan Allister Wade 29 Eylül 2011 Perşembe 18:12
    14 Mayıs 2010 Cuma 07:06
  • I finally found out how to uninstall the microsoft wifi miniport adapter its so easy all you do is go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow"  also no quotes. at first i thought this was disabling it same as right clicking and disable but actually it disables the service and the microsoft wifi miniport is gone. for some reason its mode gets set to allow instated of disallow  and when you uninstall it it reappears and messes up the networking, example, printers,wifi routers,etc.

    theres no way to uninstall it because it part of windows 7 for sharing wifi. IT WORKS TRY IT.

    its not a bug in windows 7. wow     

    • Yanıt Olarak Öneren Anomaly0617 11 Nisan 2013 Perşembe 15:13
    28 Şubat 2011 Pazartesi 18:57
  • I finally found out how to uninstall the microsoft wifi miniport adapter its so easy all you do is go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow"  also no quotes. at first i thought this was disabling it same as right clicking and disable but actually it disables the service and the microsoft wifi miniport is gone. for some reason its mode gets set to allow instated of disallow  and when you uninstall it it reappears and messes up the networking, example, printers,wifi routers,etc.

    theres no way to uninstall it because it part of windows 7 for sharing wifi. IT WORKS TRY IT.

    its not a bug in windows 7. wow 

    • Yanıt Olarak Öneren yellow_astra 21 Mayıs 2012 Pazartesi 06:27
    28 Şubat 2011 Pazartesi 19:01
  • I finally found out how to uninstall the microsoft wifi miniport adapter its so easy all you do is go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow"  also no quotes. at first i thought this was disabling it same as right clicking and disable but actually it disables the service and the microsoft wifi miniport is gone. for some reason its mode gets set to allow instated of disallow  and when you uninstall it it reappears and messes up the networking, example, printers,wifi routers,etc.

    theres no way to uninstall it because it part of windows 7 for sharing wifi. IT WORKS TRY IT.

    its not a bug in windows 7. wow 

    • Yanıt Olarak Öneren test tyler 28 Şubat 2011 Pazartesi 19:03
    • Yanıt Olarak İşaretleyen Allister Wade 29 Eylül 2011 Perşembe 18:12
    28 Şubat 2011 Pazartesi 19:03
  • Got it! And this is September. I have read it all. Tried it all. And only to Uninstall Microsoft Virtual WiFi Miniport Adapter Permanantly is the way. and to do it just as you say:  go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow" also no quotes. It's gone, and when I put the laptop in sleep and wake it up, the inherrant wifi is on and all works well.
    22 Eylül 2011 Perşembe 13:22
  • Hi,

    I've been asked by a Support Engineer at the Microsoft Answers forum to re-create my problem here within the TechNet forum, because it is more complex than what's typically handled there. The thread (my latest reply) in the Microsoft Answers forum is located here: http://answers.microsoft.com/thread/651d3f30-5b8a-4f85-a4a2-d90d07dc74ff

    My problem: the solution described above in this (TechNet) thread works only one time for me, that means, for one sleep-wakeup-cycle. The command "netsh wlan set hostednetwork mode=disallow" does not get persisted, so executing

    • "netsh wlan stop hostednetwork" gets persisted, however,
    • "netsh wlan set hostednetwork mode=disallow" does not get persisted on my machine.

    IOW, running the two commands in an elevated Command Prompt helps exactly one time - as soon as I wake up my machine from sleeping after running this, the WLAN connection gets re-established quickly (less than 5 seconds); but when I check the status with "netsh wlan show hostednetwork" then, the result is that the mode is set to "Allowed" again - and that means, the next time my machine wakes up from sleep mode, it again takes ages (~30 - 50 seconds) before the WLAN-connections gets re-established...

    Does anybody know how I can get the mode=disallow to be persisted?

    Another interesting fact I found before I ran over the solution using those NETSH commands:

    If I change the power saving option "Password protection on wakeup" from "Require a password on (recommended)" to "Don't require a password", everything is fine concerning the time period it takes to establish the WLAN connection after wakeup (that means, even without the NETSH commands as described in this thread).

    So, from my point of view, it seems to be something related to security (probably in conjunction with this hosted network stuff).

    The problem: Disabling "Password protection on wakeup" is not a solution at all for me personally, as I'm on the road with my notebook quite often, and I want to be sure that the data on my notebook isn't accessible without unlocking the screen, in case the device would get stolen or I would loose it somehow... to protect any customer data and other sensitive data on it...

    Any professional input from somebody at Microsoft to finally get a solution for this would be greatly appreciated.

    My hardware: Sony VAIO VPCSB3X9E/B

    Cheers,
    Franz

    16 Şubat 2012 Perşembe 22:31
  • Yes, I see. I had that problem on another computer too. The fix is disabling all network interfaces except the Ethernet and one Wi-Fi card. One reason is because of another Wi-Fi card that is WiMAX capable, and would create a virtual adapter for it. So 1st, disable all network interfaces except the Ethernet and one Wi-Fi card. Then as an admin(and running cmd as Administrator) Type, "netsh wlan stop hostednetwork" and "netsh wlan set hostednetwork mode=disallow" Then reboot the machine and it should not reappear. It took me a couple of tries to get this to work. Hope that helps. :)
    2 Nisan 2012 Pazartesi 23:39
  • I found the manual for your laptop, and low and behold that laptop may have a wwan connection used for connecting to cell phone towers for an internet connection.(wow lots of connections haha). Anyways disable that and run the commands I gave you. If the command doesn't work try "wwan" or "wwlan" instead of "wlan". That's just my 2 cents. Hope that helps. The manual is here (ftp://ftp.vaio-link.com/pub/manuals/consumer/AE27100111.pdf). Read pages 73 to 77.
    3 Nisan 2012 Salı 15:18
  • Ive been having an issue with this virtual miniport adapter for weeks now. I got a new wi-fi router and my wi-fi service was really bad. Ive been searching for the answer for the bad sevice for weeks. Ive even tried doing a factory restore and still within a few hours I get the virtual miniport back on my adapters page. My service provider even asked me if I was using 2 wi-fi adapters at home because the said my wi-fi was being split by the two wifi adapters. So anyway I used your fix from above and PPOOFFF it was gone and excellent service restored. So if anyone is having this issue use this fix. As they already stated it works, and IT DOES. Thank you I would have continued with the bad service thinking it was my brand new computer if it wasnt for this.
    24 Ağustos 2012 Cuma 15:53
  • Hi.

      i've created a hosted network; ssid="NAME"; key=******; authentication= WPA2-Personal; Radio type= 802.11g etc.. but this is the not one that i needed... i want to delete it .. please provide the command for it.
    this networks conflicts with the Dell WLAN adpater,so i've to delete it , instade deleting/disableing the microsoft wifi miniport adapter.
      
        thanking you.



    1 Kasım 2012 Perşembe 22:02
  • was a bit worried about typing commands right into Dos shell but whaddya know... that pesky MS virtual network thingy is gone
    30 Haziran 2013 Pazar 17:07
  • THANK THE GODS!  typical of MS do destroy a system that otherwise was fine.

    my only beef is that now when I wake the machine, it takes way longer than it used to, to be on the net.  before it was almost instant.  now its at least 5 seconds.

    5 Kasım 2013 Salı 22:27
  • First, I apologize in advance for venting here. Second, the answer provided by test tyler actually works.  I followed the instructions given by test tyler. After days of intermittent internet access, hours of following other solutions on the internet for a Atheron AR9285 wireless adapter the solution test tyler provider worked for almost a minute before I lost the Internet connection. I am positive that the latest Windows 7 update caused my loss of Internet. The problem is NOT with my wireless card. The problem is with the addition of the Microsoft Wifi Miniport. I am now ready to switch from all Microsoft products -- all of them. I have used computers since there was only DOS. This "critical update" stopped my business in its tracks. I have decided that any operating system associated with Microsoft is just another experiment with the victims paying the price again and again. No, I don't have a virus (but how are we ever 100 percent sure.) Yes I have the latest driver -- according to Windows. Yes my Wifi is turned on. Thank you test tyler. Although your solution did not solve my problem, it works which is more than I can say for Microsoft Windows. I have a high regard and respect for the effort of the workers who I suspect have a greater vision than I can see. All I know is that I looked very stupid in from of my customers when my business laptop refused to work with my wireless network. My laptop is now completely useless. It is just a hard drive. I am beyond belief that a company with a poor product keeps getting richer. After a short nap I have to return to work and I will start the process of switching to another operating system that has better customer service and quits giving excuses and stops blaming the victim. Again, sorry for the venting. Thank you for your patience.
    8 Kasım 2013 Cuma 09:27
  • I don't know if this seems too obvious a fix to have actually worked, but I simply went into Device Manager and disabled the virtual miniport adapter. I was often getting dropped off my wifi for no apparent reason, so did some poking around and found the MS device along with my Broadcom wifi adapter. Simply disabled the MS device and I haven't had an issue so far, and no dropped wifi.

    26 Kasım 2013 Salı 04:29
  • I finally found out how to uninstall the microsoft wifi miniport adapter its so easy all you do is go to the command prompt as a admin and type this "netsh wlan stop hostednetwork" with no quotes. than type this "netsh wlan set hostednetwork mode=disallow"  also no quotes. at first i thought this was disabling it same as right clicking and disable but actually it disables the service and the microsoft wifi miniport is gone. for some reason its mode gets set to allow instated of disallow  and when you uninstall it it reappears and messes up the networking, example, printers,wifi routers,etc.

    theres no way to uninstall it because it part of windows 7 for sharing wifi. IT WORKS TRY IT.

    its not a bug in windows 7. wow     


    you did not totally uninstall the wifi miniport adapter i check it again and i type "netsh wlan show hosted network" it show all the record of hostednetwork it never disappear using the "netsh wlan set hostednetwork mode=disallow"
    30 Kasım 2013 Cumartesi 04:08
  • Deleted
    23 Aralık 2013 Pazartesi 19:44
  • Just go to Device Manager and uninstall your mini port adapter. That's how you do it without getting grease under your finger nails :)

    E Γ И I И O

    29 Aralık 2013 Pazar 14:47
  • hi 

    thank you works 100%

    9 Mart 2014 Pazar 13:30
  • Creating the batch file and keeping in the start up location will avoid running these commands manually on bootup.

    netsh wlan stop hostednetwork 

    netsh wlan set hostednetwork mode=disallow

    23 Mart 2014 Pazar 17:07
  • Hi,

     

    The “microsoft virtual wifi miniport adapter” is related to a new feature in Windows 7, Wireless Hosted Network:

     

     

    This device is just a virtual device and it should not affect connecting the wireless network with the physical wireless adapter .

     

    However, if you would like to disable it, please use the command in above article.

     

    Thanks,

    Novak

    Am sorry to say this  but am running an Asus KSD53 and the phisical wlan adaptor was affected by these virtual ones with no luck with this command i had to send the laptop back to it's manufacturer!!!
    28 Mayıs 2014 Çarşamba 17:51
  • Doesnt work, it re-instals on start up.
    29 Mayıs 2014 Perşembe 12:30
  • my laptop too.

    Trying the command prompt version now, perhaps it'll last longer. This virtial thing really affects my connection. The wifi card keeps dropping/disconnecting. It's REALLY annoying.

    29 Mayıs 2014 Perşembe 12:31
  • Muchas Gracias , funciona
    7 Haziran 2015 Pazar 08:13
  • You are perfectly correct. This little pest device was causing havoc with my wireless network. Wireless was taking a long time to connect to my laptop. I found it to be the culprit. Disable it and now all is back to normal. Wireless connects up instantly. Bingo!!!
    12 Haziran 2015 Cuma 15:23

  • For those of us just browsing the web and not trying to tempt fate with potential backdoor data collection, this function is really a big red flag for network security. Unless you're hosting a LAN party out on the Navajo Reservation, this 'beta' and largely invasive/outspoken 'function' is just another RPC/RAP service that slaps another half a dozen running processes on the average user.

    Now this would be great if you're in charge of a business network and want to run everything from a laptop in your living room, changing out of your pajamas only for hardware issues, if you didn't cajole your unassuming superiors into getting a community-college grunt to do the dirty groundwork for you.

    Protip: net stop p2pimsvc , turn on System Restore and play around in Services, stopping erroneous ones, observing the dependency trees, and just seeing firsthand which ones actually have any impact at all on anything but accessing a wireless printer. net stop spooler , if you don't even use one.

    DIE WIFI MINIPORT SPY TOOLS
    14 Ağustos 2015 Cuma 15:12
  • Well said Novak Wu~
    • Yanıt Olarak Öneren VirginiaC 7 Ocak 2016 Perşembe 02:58
    • Yanıt Önerisini Geri Alan VirginiaC 7 Ocak 2016 Perşembe 03:00
    • Yanıt Olarak Öneren VirginiaC 7 Ocak 2016 Perşembe 03:00
    14 Ağustos 2015 Cuma 15:13
  • THIS TOTALLY WORKS!  How to uninstall Microsoft Virtual WiFi Miniport adaptors from the Device Manager (Windows 7 Pro)

    1. ONLY IF IT’S AN UPDATED DRIVER, download the Wireless LAN software file for your system.

    2. In Control Panel\Device Manager, right-click on Wireless LAN device and click “uninstall”.

    3. Go to top of device list and right-click on computer name, then on “Scan for hardware
     changes” and allow it to re-install the WLAN driver (navigate to updated version if you have
     downloaded one).

    4. Close Device Manager and open Control Panel\Programs and Features.

    5. Find WLAN Driver in list of installed programs; right click and choose “Modify”

    6. Uncheck “(manufacturer name) My WiFi Technology”, then click “Next”, “Ok”, or whatever you
     need to move to the next page.

    7. Follow the instructions on the screen to complete the modify installation.

    8. After installation is complete, one Microsoft Virtual WiFi Miniport Adapter remains in the Device
      Manager.

    9. Open a command prompt as an administrator

    10. Type the command “netsh wlan set host mode=disallow” and press Enter.

    11. The other Microsoft Virtual WiFi Miniport adapter disappears from the Device Manager.

    12. Restart Windows.

    Both miniport adapters should be gone.

    7 Ocak 2016 Perşembe 03:03
  • Sorry about this . . . I'm new to posting on this site, did it wrong the first time, and apparently there's no way to delete a post :(  I want to share the process I found that really works -- permanently -- so posted again below.

    7 Ocak 2016 Perşembe 03:21
  • Thank you to whoever originally posted this fix. That annoying and useless "Virtual Wireless" is now gone from my Windows 7 laptop.
    28 Mart 2016 Pazartesi 03:35
  • Open Network and Sharing center, select Change adapter settings, right-click on the device and select Disable.

    That's all there is to it!


    Best regards, George

    28 Mart 2016 Pazartesi 13:34
  • Thank you!! I haven't been able to connect to my home wifi for a week and had to use my hotspot. I finally deleted this additional adapter and everything works OK. Just applied your steps and hopefully it will persist.
    7 Nisan 2016 Perşembe 05:34
  • Thank you so much, VirginiaC !

    I've been looking for solution to this Virtual Wifi problem during two weeks.

    The option of two command lines describe above doesn't really work.

    The two Virtual Wifi lines in the Devices Manager finally reappears after next reboot.

    However, with your procedure Virtual Wifi has completely and definitely disappeared, which was the initial question of this discussion.

    100 % resolved and satisfied.

    Bravo


    • Yanıt Olarak Öneren Gabuzomeuh 6 Mayıs 2016 Cuma 23:44
    • Düzenleyen Gabuzomeuh 7 Mayıs 2016 Cumartesi 06:32
    6 Mayıs 2016 Cuma 23:43
  • Hi All,

    I am having more than 1000 WAN Mini port device under network adapter. How can I safely remove them in ONE GO. I cant just sit for one day and remove them MANUALLY.

    My OS is Win 8.1 64Bit.

    Any Help?

    3 Ağustos 2016 Çarşamba 18:11
  • This actually fixed the issue we were having with L560 thinkpads. 

    Thank you again for this,

    21 Ekim 2016 Cuma 12:55
  • Instructions on how to uninstall Microsoft Virtual WiFi Miniport adapters from the Device Manager:

    1. Download the Intel Wireless LAN software file for your system from Lenovo eSupport download site and extract the file onto your system.
    2. Run the Intel WLAN software installer using autorun.exe or setup.exe.
    3. Select “modify install”.
    4. Uncheck “Intel My WiFi Technology”, then click Next.
    5. Follow the instructions on the screen to complete the modify installation.
    6. After installation is completed, one Microsoft Virtual WiFi Miniport Adapter remains in the Device Manager as expected.
    7. Open a command prompt as an administrator.
    8. Type the command “netsh wlan set host mode=disallow” and press Enter.
    9. The other Microsoft Virtual WiFi Miniport adapter disappears from the Device Manager.
    10. Restart Windows.
    • Düzenleyen jo2wunger 15 Kasım 2017 Çarşamba 17:16
    15 Kasım 2017 Çarşamba 17:09
  • that piece of craps in windows 10 too :/ but didnt show up til i downloaded Visual Studio 2017 program, well programs. was like 70 gigs of programs. so cant pin point which program is the dirty low down piece of $&@* that keeps activating that useless $&@* and those programs dont seem to do what i thought they would so im going to delete the whole lot of em, because yah when that adapter runs my wifi signal drops to nothing every few seconds for couple seconds :/ not cool at all
    6 Aralık 2017 Çarşamba 07:57
  • Note that on  my win 7 64 machine, needed spaces around the "=" for the disallow command to work.
    13 Ağustos 2018 Pazartesi 18:02