none
napclientprov.mof is needed During setup.. RRS feed

  • 问题

  • have slipstreamed SP3 into Pro & Home & during setup I receive the following on both versions.

     

    What would be causing this..?

    2008年5月1日 13:30

答案

  • Click on Browser then navigate to C:\Windows\system32\WBEM. You should see the napclientprov.mof file there . Select and click OK to get the installer to continue.
    2010年10月20日 16:46

全部回复

  • Evening Chiners

      Have you taken a look at the cd source? Also are you integrating the source cd? turn down the burning speed or set it to burn at a slower speed.

     

     Suppostly tooth paste and a good backing will help here. But that is not a great recommendation. May cause problems if not done properly!

     

     Local video store has a cleaner, only took 3 minutes to get a clean scratch free disk. Much better recommendation.

     

      Also have you looked at memory stick tests?

      connections to cd\dvd drive?

      Power supply voltages?

      Temperatures?

      Cleaned fans?

      Cleaned lens on the cd player?

      Event logs to see if any other programs have problems?

     

      Cleaning the lenses and if possibly setting the speed of the cd player might help you out here.

     

    Hopefully something helps you out here.

     

    Keith

     

    2008年5月2日 6:14
  • This file is missing ONLY if you integrated other stuff into your newly integrated SP3 disk..  IE7, WMP11 or anything else will cause this problem.. This is due to Driver Signing and SFC_OS.DLL. A scratched disk won't cause this.

    2008年5月2日 22:37
  • I have made an integrated disk using the "new" RTW stand alone installer. I get the same error during install. Also others as well, listed in this thread here:
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3308264&SiteID=17


    This file is missing ONLY if you integrated other stuff into your newly integrated SP3 disk.

    This is NOT true. SP2 with SP3 (RTW not RTM) slipstreamed othing else, I was asked for the file, which does not exist at all.
    2008年5月8日 4:40
  • It does exist. Its not called that when compressed tho. Smile As well, if you use Nlite, click off Options, then the patches tab, and Disable SFC_OS. No more error.

     

    If you get  that error, there is something on the disk thats not supposed to be there that WIndows likes or a file is corrupt. This has been tested by a lot of other users, including the RTM, RTW, and MSDN ISO's.

     

    If you make a brand new ISO from XP RTM -> SP2 -> SP3, you shouldn't get that message. Disable Windows File Protection (SFC_OS.DLL) and see if it still comes up.

     

    As for the errors your receiving Mt.Dew, sounds like your SP3.cab is bad or your driver.cab. Make sure your original disk is not bad before you integrate. If your getting driver signing or testing issues like the other errors and then the napclientprov.mof, one of your cabs is corrupt and thats why your getting the driver signing issue.. And thats why we get napclientprov.mof unless we disable SFC_OS (Windows Driver signing protection). If you integrate anything other than whats included, the drivers are no longer the same as what they were on the CD, so, disabled SFC no longer causes the .mof message. If the other user has nothing on his disks, he is prolly got corrupt .CAB's also as looking up this file in Yahoo/Google comes up with the same thing.. Error only on modified drivers or integrating something with SP3.

    2008年5月8日 12:10
  • Click on Browser then navigate to C:\Windows\system32\WBEM. You should see the napclientprov.mof file there . Select and click OK to get the installer to continue.
    2010年10月20日 16:46
  • Click on Browser then navigate to C:\Windows\system32\WBEM. You should see the napclientprov.mof file there . Select and click OK to get the installer to continue.
    Yup, solved. I'm trying to repair my XP SP2 to SP3 and got this error about napclientprov. Just like Aytter said, then the installation continues. Thx Aytter.

    Hengky
    2010年11月22日 10:32
  • Thanks for this reply worked!!

    But i got to skip the messenger msn... hope it works now
    2013年11月9日 11:29
  • You are the ONE >>> thanks a lot
    2019年2月26日 18:09