none
hyper-v disables vt-x for other hypervisors RRS feed

  • 問題

  • Hello,

    I just installed windows 8 pro on my working computer.
    I work a lot with virtual machines for special os setups. Recently I used Virtualbox for those machines.
    But with windows 8 pro VBox says there is not VT-X available ... (mainboard and processor support vt-x and it is enabled)
    Well it was available before I switched to windows 8 pro.

    I search the net and found a hint that hyper-v might be the cause. I had hyper-v installed because I am planning to migrate to hyper-v from vbox.

    I uninstalled hyper-v and vt-x was available again. Question now is why does hyper-v does disable vt-x for other hypervisors or even better how can i prevent this ?

    2012年12月25日 下午 10:35

解答

  • Because when hyper-V is installed on Windows 8 Pro, the hypervisor is
    running all the time underneath the host OS, and only one thing can
    control the VT hardware at a time for stability.  The hypervisor
    blocks all other calls to the VT hardware..
     
    You could make a boot option to boot without the hypervisor running
    and then VBox could use it, but the Hyper-V VM's couldn't run.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    • 已提議為解答 Chris DeCarlo 2012年12月26日 上午 02:54
    • 已標示為解答 Goeran Bruns 2012年12月26日 下午 09:13
    2012年12月25日 下午 10:53
  • It's pretty easy but it requires a reboot.

    http://blogs.technet.com/b/gmarchetti/archive/2008/12/07/turning-hyper-v-on-and-off.aspx

    It's for Windows 2008 but I'm pretty sure it will work with Windows 8.  I've never actually tested it other than setting auto since I can't do without the hypervisor running.


    Bob Comer - Microsoft MVP Virtual Machine


    • 已編輯 Bob Comer 2012年12月26日 下午 11:00
    • 已標示為解答 Goeran Bruns 2012年12月27日 下午 03:23
    2012年12月26日 下午 11:00
  • Fantastic.

    Worked excatly like you thought. I made a copy of the orginal Windows 8 entry for starting with hyper-v and set hypervisorlaunchtype to off for the orginal entry.
    It is not really comfortable but good enough for testing purposes and since Windows 8 run from ssd a reboot takes just a few seconds.

    Thanks again man !

    2012年12月27日 下午 03:23

所有回覆

  • Because when hyper-V is installed on Windows 8 Pro, the hypervisor is
    running all the time underneath the host OS, and only one thing can
    control the VT hardware at a time for stability.  The hypervisor
    blocks all other calls to the VT hardware..
     
    You could make a boot option to boot without the hypervisor running
    and then VBox could use it, but the Hyper-V VM's couldn't run.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    • 已提議為解答 Chris DeCarlo 2012年12月26日 上午 02:54
    • 已標示為解答 Goeran Bruns 2012年12月26日 下午 09:13
    2012年12月25日 下午 10:53
  • Thanks for the answer, especially the explanation. It is not what I hoped for ... but it does make sense in the end.

    Is there any boot time option for controlling hyper-v operation ? I searched the net ... but most hits revers to boot options for guests ... not the host itself :)
    2012年12月26日 下午 09:18
  • It's pretty easy but it requires a reboot.

    http://blogs.technet.com/b/gmarchetti/archive/2008/12/07/turning-hyper-v-on-and-off.aspx

    It's for Windows 2008 but I'm pretty sure it will work with Windows 8.  I've never actually tested it other than setting auto since I can't do without the hypervisor running.


    Bob Comer - Microsoft MVP Virtual Machine


    • 已編輯 Bob Comer 2012年12月26日 下午 11:00
    • 已標示為解答 Goeran Bruns 2012年12月27日 下午 03:23
    2012年12月26日 下午 11:00
  • Fantastic.

    Worked excatly like you thought. I made a copy of the orginal Windows 8 entry for starting with hyper-v and set hypervisorlaunchtype to off for the orginal entry.
    It is not really comfortable but good enough for testing purposes and since Windows 8 run from ssd a reboot takes just a few seconds.

    Thanks again man !

    2012年12月27日 下午 03:23
  • You're welcome, glad I could help.
     
    And thanks for letting me know it worked!
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    2012年12月27日 下午 05:17
  • Well just for the record. After christmas holidays I started working today.
    One of my VBox-VMs didn't boot (vm hangs after loading of the kernel, no panic, no messages, vbox puts 100% load on one core). To be precise it is a centos6 guest.
    I had Hyper-V installed but disabled at boot time (VT-X was available for VBox).
    Funny thing other VMs with Linux guests did boot. So my guess is it has something to with centos kernel configuration.

    After deinstalling Hyper-V features the centos guest works flawless.

    If I have time I will try to investigate further ... so far I need VBox and the centos guests for my work and Hyper-V remains uninstalled :(.

    2013年1月3日 上午 08:27
  • >After deinstalling Hyper-V features the centos guest works flawless.
     
    I personally would suspect something in the networking that's stopping
    the boot rather than the core if Hyper-V is disabled...
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    2013年1月3日 下午 02:01
  • Hmm, there is no network up at the moment the centos guest hangs.

    It is exactly after the kernel is loaded an the root filesystem should be mounted. Seems like an io-issue but not inside the vm otherwise there would be an error message or a kernel panic (e.g. unable to mount root ...).

    2013年1月3日 下午 02:36
  • So after a few days of examination the problem becomes more and more mysterious.
    While Hyper-V is disabled or not installed it has no influence if the centos os guest is running or hanging.
    But the uptime of windows 8 does. If I start the guest right after windows 8 finished booting everything is ok, but do i try to start the vm only a few minutes later the guest hangs while booting.
    The VBox logs showing some commonly know error messages but none is critical and none seems related to the problem.
    I guess there is nothing wrong with hyper-v here.
    It might be related to a behaviour of Windows 8, but I guess I should ask arround in the VBox forum.

    My experiments with hyper-v (enabled via boot-option again) are very promising. One thing I don't unterstand. If I create a extern virtual switch which uses my one and only network adapter. The network adapater releases its IP-configuration but the virtual switch won't ask for a new IP-Configuration via dhcp.

    2013年1月11日 上午 06:33
  • Thanks a lot for the tip.
    2015年8月16日 上午 04:25
  • thank you thank you thank you thank you thank you

    windows 10... 

    trying to start VirtualBox


    Christian CXM

    2017年4月24日 上午 07:50
  • I have same issue. even after disabling Hyper-V, the download wasn't successful. 
    2018年4月21日 下午 12:51