none
Could not connect to System Event Notification Service RRS feed

  • 問題

  • I get the error: Windows could not connect to the System Event Notification Service service.

    Regular users are unable to log on to the machine but Administrators are. The Event Viewer does not have any useful information. I performed a system restore to a previously working day but the error came back eventually. I have ran the command netsh winsock reset many times to no avail. When I log in to the machine as Admin I can see that the service is started and it is set to Automatic yet the error persists. This has occurred on 2 Dell machines of different models. I had to completely reinstall the first one to get the user back working but this is not really a solution.

    Thanks

    2013年7月8日 下午 02:54

解答

  • I reinstalled Symantec Endpoint Protection from the computer and it now appears to be working. But I am skeptical and intend to keep a close eye. If anyone has any experience with this feel free to still chime in.
    • 已標示為解答 Ewido 2013年7月19日 下午 10:25
    2013年7月8日 下午 04:03

所有回覆

  • I reinstalled Symantec Endpoint Protection from the computer and it now appears to be working. But I am skeptical and intend to keep a close eye. If anyone has any experience with this feel free to still chime in.
    • 已標示為解答 Ewido 2013年7月19日 下午 10:25
    2013年7月8日 下午 04:03
  • Hi Ewido,

    Here are some suggestions to solve this issue:

    Method 1: Perform a clean boot. A clean boot helps to verify if any third party application service or startup item is causing this issue. For your information, please review this KB article to put the computer in clean boot:

    How to perform a clean boot to troubleshoot a problem in Windows 8, Windows 7, or Windows Vista

    Note: Make sure you put the computer back to Normal Startup once you have done with the troubleshooting.

    Method 2: In some cases, the issue is caused by faulty Font Cache files. Please review the following steps to solve this issue:

    1. Click Start, click All Programs, click Administrative Tools and then double-click Services.                                                                                OR: Click Start, type services.msc in the Search box, and then press Enter.
    2. In the right pane of the Services snap-in, locate the Windows Font Cache Service.
    3. Right-click the Windows Font Cache Service, and then select Stop in the context menu.
    4. Go to this location C:\Windows\ServiceProfiles\LocalService\AppData\Local                                                                                                    Note: please ensure your computer can display hidden files. For your information, please review this article show hidden files.
    5. Rename the file FontCache-System.dat to FontCache-System.old.
    6. Restart.

    Method 3: Please review this KB article The desktop does not load and only displays a black or blue background after you log on to a computer that is running Windows 7 or Windows Server 2008 R2 to get more help.

    For your information, please review the similar issues to get more help:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/windows-could-not-connect-to-the-system-event/e8de1ee3-159f-4dae-9e9e-9a648cd85478?page=10

    http://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/983e0736-57ef-4c6a-bb10-cfb2712dde24/limited-user-account-cannot-log-on-due-to-error-could-not-connect-to-the-system-event-notification

    Regards,

    Lany Zhang

    • 已標示為解答 Bennie ChenModerator 2013年7月18日 下午 02:22
    • 已取消標示為解答 Ewido 2013年7月19日 下午 10:24
    2013年7月9日 上午 09:52
    版主
  • Thank you for the response Lany.

    I have the computer back to a working level so I am currently unable to test these methods. However I will should it occur again.

    2013年7月11日 下午 03:07
  • Hi,

    I am Chetan Savade from Symantec Technical Support team.

    Why did you uninstall SEP? Do you see any conflict between SEP and Windows System Event Notification service. Do you see any error in the event viewer?

    Actually Symantec management client sevice depends on the System Event Notifcation service.

    Reference: http://www.symantec.com/docs/TECH146279

    Regards,

    Chetan Savade

    2013年7月15日 下午 03:38
  • I uninstalled it because I was testing everything I could to get it to work. Uninstalling it solved the problem. Reinstalling it did not recreate the problem so far.
    2013年7月19日 下午 10:25
  • I wanted to say thank-you, as these instructions solved my problem.

    2014年2月18日 上午 12:16
  • Thanks, i have followed these and the error was gone. But will this problem return again?

    2014年4月9日 下午 03:58
  • Lany's solutions worked for me for several desktop logons, but the trouble came back.
    2014年5月1日 下午 09:21
  • Thank You.  Deleting the font cache solved it for me.

    Tominator

    2014年6月6日 下午 02:08
  • I was having this issue in Win 8.1. The mention of the font cache made me realize that I had CCleaner running at startup and the tick box for cleaning the font cache was checked. I removed it and the problem has disappeared.
    2014年7月17日 下午 07:45
  • Thanks guys method 2 i tried now its working for me..........................god bless you buddy
    2015年4月8日 上午 04:28
  • So I'm having this issue right now. And I've followed the instructions to a T. But my laptop still says the same thing and hasn't gone back to normal at all. What do I do now?
    2015年6月12日 下午 06:31
  • Lany,

       Step 2 solved this problem on my pc. I noticed that the font changed somewhat when my laptop had this problem. The startup time has become normal. Thank you.

    William Tang

    2016年3月2日 下午 05:01
  • Click on Start Button

    Search "cmd.exe" open with Admin

    and Type in - "netsh winsock reset" press enter

    Then Restart your computer.

    Issue Solved
    2017年2月1日 下午 02:30
  • Click on Start Button

    Search "cmd.exe" open with Admin

    and Type in - "netsh winsock reset" press enter

    Then Restart your computer.

    Issue Solved
    My network connection suddenly stopped working on windows 7. I could see is connected and enabled however red cross on the connection. The network has been set up as DHCP. After running above command and restarting the PC it started working. Thank you
    2017年11月23日 上午 08:25
  • I know this is an old thread, but we have a user facing this same problem.

    Only an admin level account can sign in.  Limited user accounts can not.  To get this user on we need to sign on with admin account, run netsh winsock reset, log off and they can log on.  However that is only good for one logon.  EVERY SINGLE TIME the computer is rebooted, an admin account MUST be logged on first, the command run, and then limited user accounts can run.

    I'd almost want to set it as a logoff script in local computer policy, however it needs to run as an admin so when the limited user shuts down it wont run (nor would it run on improper shutdowns). We are not sure what to do, besides tell them to NEVER shut down (only do sleep or hibernate).  It is a laptop if that matters.

    2018年4月20日 下午 12:02
  • You are the best Lany, Renaming FontCache-System.dat to FontCache-System.old. fixed the issue. 

    Keep up the good work. 

    Thank you 

    Abusha

    2018年6月13日 下午 04:32