none
WS2012 Cluster network / DNS issues RRS feed

  • 問題

  • Hi,

    Does anyone know how to resolve the following cluster errors (these occur approximately every 15 minutes).

    EVENT ID 1228

    Cluster network name resource 'Cluster Name' encountered an error enabling the network name on this node. The reason for the failure was:
     'Unable to obtain a logon token'.
     The error code was '1326'.
     You may take the network name resource offline and online again to retry.

    EVENT ID 1196

    Cluster network name resource 'Cluster Name' failed registration of one or more associated DNS name(s) for the following reason:
    The handle is invalid.
    Ensure that the network adapters associated with dependent IP address resources are configured with at least one accessible DNS server.

    We have 3 networks defined

    Heartbeat - Cluster Use = Internal (No DNS configured)

    Live Migration - Cluster Use = Disabled (No DNS configured)

    Management -  Cluster Use = Enabled (DNS configured)

    We currently have a 6 node WS2008R2 Hyper-V cluster configured with the same network configuration with no issues.

    2012年10月8日 下午 11:03

解答

所有回覆

  • Hi,

    Thanks for your post.

    In order to troubleshoot, you may check the following points:

    • Check that on the DNS server, the record for the Network Name resource still exists. If the record was accidentally deleted, or was scavenged by the DNS server, create it again, or arrange to have a network administrator create it.
    • Ensure that a valid, accessible DNS server has been specified for the indicated network adapter or adapters in the cluster.
    • Check the system event log for Netlogon or DNS events that occurred near the time of the failover cluster event. Troubleshooting these events might solve the problem that prevented the clustered Network Name resource from registering the DNS name.

    For more detailed information about Network Name Resource registration and Event ID 1196, please refer to the following article. Hope it helps.

    DNS Registration with the Network Name Resource

    http://blogs.msdn.com/b/clustering/archive/2009/07/17/9836756.aspx

    Windows Server 2008 Troubleshooting: Event ID 1196 — Microsoft-Windows-FailoverClustering

    http://social.technet.microsoft.com/wiki/contents/articles/1417.windows-server-2008-troubleshooting-event-id-1196-microsoft-windows-failoverclustering.aspx

    Best Regards,

    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    2012年10月9日 上午 06:41
    版主
  • Hi,

    How are things going? I just want to check if the information provided was helpful. If there is any update or concern, please feel free to let us know.

    Best Regards,
    Aiden

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Aiden Cao

    TechNet Community Support

    2012年10月15日 上午 02:10
    版主
  • We were experiencing the same issue when setting up our 2012 cluster.  The DNS alias wouldn't auto create (permissions OK).  If I manually created the A record the nodes wouldn't update the record.  We destroyed the cluster and recreated and everything is now fine :/

    2012年10月29日 下午 04:19
  • we ended up rebuilding the clsuter with WS2008R2 due to time constraints, the WS2008R2 cluster setups works flawlessly.
    2012年10月29日 下午 07:22
  • The solution can be found here: http://blogs.technet.com/b/askcore/archive/2012/09/25/cno-blog-series-increasing-awareness-around-the-cluster-name-object-cno.aspx. We also experienced that Live Migration was not working.

    Cause:

    Beginning with Windows Server 2008, when a cluster is created, the computer objected associated with the CNO (Cluster Name Object), unless pre-staged in some other container, is placed, by default, in the Computers container. Windows Server 2012 Failover Clusters give cluster administrators more control over the computer object representing the CNO. The Product Group's blog mentioned earlier, details new functionality in Windows Server 2012, which includes:

    • Using      Distinguished Names when creating the cluster to manually control CNO      placement
    • New default behavior where a CNO is placed in      the same container as the computer objects for the nodes in the cluster
    • The Virtual Computer Objects (VCOs) created by      a CNO are placed in the same container as the CNO

    Having more control over cluster computer object(s) placement, while desirable, requires a bit more 'awareness' on the part of a cluster administrator. This 'awareness' involves knowing that, by default, the CNO when placed in the non-default location may not have the rights it needs for other cluster operations such as creating other cluster computer objects (VCOs).

    it appeared to be a case of the CNO account password being out of sync in the domain. Steps taken to resolve:

    1. Temporarily move the CNO account into the Computers container
    2. Log into one of the cluster nodes with a domain account that had the Reset Password right in the domain   
    3. Take the cluster Network Name offline. If this does not work to solve the problem, simulate failures for the cluster Network Name resource until it is in a permanent failed state
    4. Once the resource was in an offline state, right-click on the resource, choose More Actions and then click Repair
    5. The previous action caused the password for the CNO to be reset in the domain
    6. Restart the cluster service on all nodes

    The Failover Clustering Diagnostics logs will give you much more information about what is going wrong. You can find it in the Event Viewer: navigate to Applications and Services Logs -> Microsoft -> Windows -> FailoverClustering -> Diagnostic


    • 已提議為解答 Dennis_van_Doorn 2012年11月29日 下午 09:24
    • 已編輯 Mark D _NL_ 2012年12月20日 上午 08:44 Information on step 3 was not complete.
    2012年11月29日 下午 09:19
  • Mark, thanks for forcing me to re-read that TechNet blog - it solved my issue!  But your step 3 is off - the article says you must continually simulate a failure.  In my case, taking it offline didn't not solve the issue. 


    Mike Crowley | MVP
    My Blog -- Planet Technologies

    2012年12月20日 上午 04:08
  • Mike, thanks for following up. Good to hear that it solved your issue. In my case taking offline was enough to solve the issue. I will update the post above to reflect the proper approach.

    2012年12月20日 上午 08:41
  • Perfect... work great! 1 minute to recover... no system downtime!

    Thank you!


    Maia

    2013年1月8日 上午 10:04
  • I have the 1196 error on a new Windows Server 2012 cluster as well. How do you effectively simulate a permanent failed state of the cluster so you can perform the repair action that resets the password?

    Thank you.

    Greg

    2013年2月13日 下午 08:02
  • I have the 1196 error on a new Windows Server 2012 cluster as well. How do you effectively simulate a permanent failed state of the cluster so you can perform the repair action that resets the password?

    Thank you.

    Greg

    'simulate failure' is a right-click option.


    Mike Crowley | MVP
    My Blog -- Planet Technologies

    2013年2月13日 下午 09:21
  • That doesn't appear to be the case in the 2012 Failover Cluster Manager UI. I've right-clicked on every node in the tree. There is the Test-ClusterResourceFailure command but I don't think I can achieve the same thing with that.

    2013年2月13日 下午 10:00
  • You didn't click everywhere.  ;)



    Mike Crowley | MVP
    My Blog -- Planet Technologies

    2013年2月14日 上午 03:35
  • Ahh... but you have the 2008 interface, that option doesn't exist in the 2012 interface.

    2013年2月15日 上午 04:56
  • no, I'm using 2012.  you need to expand the center pane to get to cluster core resources.


    Mike Crowley | MVP
    My Blog -- Planet Technologies

    2013年2月15日 上午 05:05
  • Thanks Mike. The ultimate resolution to my problem was to go into DNS and add the cluster resource computer object to the cluster DNS record. Giving it full control got rid of the 1196 cluster errors and allowed me to successfully Live Migrate VMs between hosts. Previously any live migration attempts would fail while a quick migration would work.

    Thanks again!

    • 已提議為解答 Greg Kuchar 2013年2月18日 下午 03:04
    2013年2月16日 下午 03:11
  • Not sure whether This issue has been resolved or not..

    Just providing the workaround which worked at my end.If objects are properly registered in the DNS than below steps can be followed.

    1-shutdown the cluster (Right click on the cluster object ->more action->shutdown cluster)

    2-Start the cluster.

    3- repair the cluster object (select cluster object->right click->more actions->repair)

    check the cluster properties.Its should show the DNS status as ok.

    Thanks

    Ajay Bhardwaj 

    2013年9月30日 下午 04:17