none
Problème mode entreprise IE11 RRS feed

  • 問題

  • Bonjour,

    nous utilisons actuellement le mode entreprise IE11 appliqué sur les postes par GPO.

    Une liste de sites a été défini pour basculer en mode compatibilité IE8 sur IE11. J'ai voulu modifié cette liste mais les changements ne sont pas pris en compte sur les postes. Le fichier XML est stocké dans le dossier NETLOGON.

    J'ai effectué plusieurs tests :

    - creation d'un nouveau fichier xml avec la nouvelle liste des sites. Modification de la GPO pour pointer vers la nouvelle liste.

    Les postes prennent bien la modification au niveau de la clé registre (HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Main\EnterpriseMode) mais la liste n'est pas mise à jour.

    Si je supprime cette clé, elle est recréé lors de la prochaine actualisation des GPO et cela fonctionne.

    -modification du fichier XML existant en laisssant le même nom. Le souci reste le même...

    Comment puis-je forcer tous les postes de mon domaine a actualisé ce fichier ?

    Merci de votre retour.

    2017年10月2日 下午 12:50

所有回覆

  • Bonjour,

    Si vous utilisez Windows7, vérifier que cette KB a été appliquée : http://support.microsoft.com/kb/2929437

    2017年10月2日 下午 03:32
  • Plus d'explications, après recherche :

    • La modification doit être faite avec l'outil adéquate (Enterprise Mode Site Manager). Attention, il y a 2 version (la version 2 est prévue pour Windows 10).
    • Une fois le fichier XML mis à jour, vous devez le pousser à l'emplacement défini dans votre GPO (personnellement, je n'utilises pas le SYSVOL pour cela, le serveur WSUS à un moteur web sur lequel s'appuyer ce qui est plus sécurisé à mon sens).
    • Les clients seront notifiés 65 secondes après le lancement d'un nouveau processus IE11.

    La clé de registre HKEY_CURRENT_USER\Software\Microsoft\Internet Eplorer\Main\EnterpriseMode\CurrentVersion indique le numéro de version actuellement utilisé par le navigateur de l'utilisateur. vous pouvez la comparer avec celle du fichier :

    <rules version="7">
      <emie>
        <domain exclude="false">www.lapin.org</domain>
      </emie>
    </rules>

    Si la version ne se met pas à jour, c'est que :

    • soit le fichier est corrompu (mauvais format par exemple)
    • soit le contenu XML est incorrecte (balise, version 2 pour un poste en Windows 7...)
    • soit le chemin réseau n'est pas valable (sysvol pas à jour dans votre cas)

    Cela devrait vous aider je pense!


    2017年10月2日 下午 04:05
  • Bonjour, 

    Je fais remonter le sujet mais êtes-vous parvenu à régler ce problème car j'y suis également confronté…

    (peut être avec la solution proposée?)

    Merci pour votre retour

    2019年1月23日 下午 03:08
  • Non donc en définitive j'ai opté pour changer la version de mon fichier lors de chaque monter de version.

    Monfichier-v1.xml

    Monfichier-v2.xml

    ...

    etc

    PS : Désolé pour le retour tardif.

    2019年8月5日 下午 02:36