none
cannot start Services.msc RRS feed

  • 問題

  • I've disabled some services through Services.msc, as a result, Services.msc can't start itself now, nor can I install any program or run any configurative tools.

     

    C:\windows\system32\services.msc

     

    The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

     

    Now how can I enable a service when Services.msc could not start? I've tried "net start" command,

    but:

     

    System error 5 has occurred.

    Access is denied.

     

    Such irony, I'm the only user of this computer, but so many "access is denied" for me, and bad people can just control this computer anytime they want, I just knew they can.

     

    please help me

    2007年5月8日 上午 11:51

解答

  • I had the same problem, disabled AppInfo because the service is eating up all the memory, without knowing the consequence.

    It took me 2 hours. The final solution for me is pressing F8 when rebooting, and select Directory Services Restore Mode.

    In this mode, I could run Services.msc as normal, even it says the AppInfo is still disabled in the panel.

    Btw, if the Appinfo was only stopped in manual mode, it is much easier to restore, by restarting in task manager, which needs no administrator authorization and could operate most services which are not disabled in services.msc.

    2016年9月1日 上午 02:15

所有回覆

  • Hi,

     

    I had the same problem yesterday. I spent 4 hours trying to fix it.

     

    I can't be 100% sure, but I think it's the Application Information service which causing this problem. I disabled a few services including this one and I couldn't start the services.msc later.

     

    I tried to enable services in Safe Mode (press F8 during Vista boot and then choose Safe Mode), but I think I missed this service so it didn't work for me.

    At the end I had to do a System restore to a previous point. You should be able to do it in the Safe mode or you can do it via boot options - F8 during Vista boot up and then Windows Repair/Restore to a previous point. After the restore, I started disabling services one by one to see which one causes the problem - this is how I established that Application Information is the one to look at.

     

    I hope it helps.

     

    Cheers,

    Andrey

     

     

    2007年5月16日 上午 10:01
  •  


    [Error number: 0x8DDD0018]
    The site cannot continue because one or more of these Windows services is not running:

    • Automatic Updates (allows the site to find, download and install high-priority updates for your computer)
    • Background Intelligent Transfer Service (BITS) (helps updates download more quickly and without problems if the download process is interrupted)
    • Event Log (keeps a record of updating activities to help with troubleshooting, if needed)
    To make sure these services are running:
    1. Click Start, and then click Run.
    2. Type services.msc and then click OK.
    3. In the list of services, double-click on Automatic Updates and then click Properties.
    4. In the Startup type list, select Automatic and click Apply.
    5. Verify that the Service status is started, if the Service Status is Stopped click on the Start Button.
    6. In the list of services, double-click on Background Intelligent Transfer Service (BITS) and then click Properties.
    7. In the Startup type list, select Manual and click Apply.
    8. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.
    9. In the list of services, double-click on Event Log and then click Properties.
    10. In the Startup type list, select Automatic and click Apply.
    11. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.

    If this does not resolve the problem you may request help from one of the following resources.

    For self-help options:

    • 已提議為解答 zima01 2010年7月14日 上午 01:18
    2008年6月27日 上午 11:05
  •  


    [Error number: 0x8DDD0018]
    The site cannot continue because one or more of these Windows services is not running:

    • Automatic Updates (allows the site to find, download and install high-priority updates for your computer)
    • Background Intelligent Transfer Service (BITS) (helps updates download more quickly and without problems if the download process is interrupted)
    • Event Log (keeps a record of updating activities to help with troubleshooting, if needed)
    To make sure these services are running:
    1. Click Start, and then click Run.
    2. Type services.msc and then click OK.
    3. In the list of services, double-click on Automatic Updates and then click Properties.
    4. In the Startup type list, select Automatic and click Apply.
    5. Verify that the Service status is started, if the Service Status is Stopped click on the Start Button.
    6. In the list of services, double-click on Background Intelligent Transfer Service (BITS) and then click Properties.
    7. In the Startup type list, select Manual and click Apply.
    8. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.
    9. In the list of services, double-click on Event Log and then click Properties.
    10. In the Startup type list, select Automatic and click Apply.
    11. Verify that the Service status is started, If the Service Status is Stopped click on the Start Button.

    If this does not resolve the problem you may request help from one of the following resources.

    For self-help options:

    2008年6月27日 上午 11:05
  • If you're still having issues...You may have the vundo virus.  It's a very difficult virus to remove, because it disables most of the helpful features in MS for getting rid of viruses.  It also disables and or attempts to make it difficult to get win updates, antivirus updates and install new antivirus programs.
    RH9 x2, Vista b2 x2, WXPsp2 x5
    2009年7月16日 下午 05:40
  • Same issue here, you are right "Application Information" service was causing the problem
    • 已提議為解答 ErdeneLu 2012年5月14日 上午 03:16
    • 已取消提議為解答 ErdeneLu 2012年5月14日 上午 03:16
    • 已提議為解答 ErdeneLu 2012年5月14日 上午 03:19
    2009年9月11日 下午 01:02
  •  

    check C:\WINDOWS\system32\apphelp.dll 

    msc files will not work without this file

     

    2011年3月17日 下午 09:38
  • I had the same problem, disabled AppInfo because the service is eating up all the memory, without knowing the consequence.

    It took me 2 hours. The final solution for me is pressing F8 when rebooting, and select Directory Services Restore Mode.

    In this mode, I could run Services.msc as normal, even it says the AppInfo is still disabled in the panel.

    Btw, if the Appinfo was only stopped in manual mode, it is much easier to restore, by restarting in task manager, which needs no administrator authorization and could operate most services which are not disabled in services.msc.

    2016年9月1日 上午 02:15
  • But, On my vaio Laptop, How could i fix that issue......... I cannot

    find Any boot option


    pallabd21

    2016年10月9日 上午 05:55
  • Paul,

                 "The final solution for me is pressing F8 when rebooting, and select Directory Services Restore Mode.

    In this mode, I could run Services.msc as normal, even it says the AppInfo is still disabled in the panel.

    Btw, if the Appinfo was only stopped in manual mode, it is much easier to restore, by restarting in task manager, which needs no administrator authorization and could operate most services which are not disabled in services.msc."

    Worked like a charm !!!!

    Thanks a ton!

    KK

    2016年10月21日 上午 11:51
  • Paul I followed your instructions and solved the problem. Thank you!
    2019年5月20日 上午 11:12