none
Proper Virtual Network Configuration RRS feed

  • 問題

  • I have the below network configuration. It works fine for a day or so, then the Internet connection becomes unstable. My only solution is to reboot PC. W/O the bridge, my Wi-Fi connection remains stable.

    Guest vEthernet External Switch bridged to my Host Wi-Fi NIC.

    A) Is this proper configuration?

    B) Why might my Internet connection become unstable with this configuration?

    2019年9月18日 下午 02:23

解答

  •   If you are on a routed network, I would recommend that you set up your external virtual switch on the Ethernet NIC and using the WiFi NIC for the host. You should not need to use static IPs. The guest should get its config from DHCP, just as a physical machine would.

      If the WiFi NIC does not work correctly even with a default switch setup, I suspect that there is a compatibility problem with the TP-Link software. Everything works fine with my Dell 1705 WiFi NIC.   

        



    Both host and guest will get IP addresses from DHCP and behave as if they were two phyical machines on the same LAN. IN my case, their IPs are 192.168.1.2 and 192.168.1.26  .


     

    • 已編輯 Bill Grant 2019年9月20日 上午 03:09
    • 已標示為解答 msdnScott 2019年9月20日 下午 05:13
    2019年9月20日 上午 03:02

所有回覆

  • Why are you using a bridge?  
    2019年9月18日 下午 04:29
  • Why are you using a bridge?  

    What else can I do? W/O a bridge, no Internet for my VM's. I've tried ICS, but that did not work well either.

    2019年9月18日 下午 05:18
  • You don't need to use either with Hyper-V and that's probably what's causing all issues. It's an extra layer of complexity.

    There are a couple options:

    If you want basic network connectivity, assign the default switch (vEthernet) that Hyper-V created to your VM.  It's a non-configurable NAT setup, but will provide basic internet access.

    If you want your VM to appear on your local network, just like a physical computer.  Create an External Virtual Switch and assign your active NIC to it. Note that depending on your NIC and network config, you may temporarily lose your network connection and may need to manually configure the new External Virtual Switch.

    For details on creating an external virtual switch: https://docs.microsoft.com/en-us/windows-server/virtualization/hyper-v/get-started/create-a-virtual-switch-for-hyper-v-virtual-machines

    If you want a configurable NAT setup, you'll need to do some extra work.

    2019年9月18日 下午 05:27
  • Creating the External Virtual Switch automatically creates the bridge to my physical NIC (see screenshot below).

    With regards to NAT...that would be utilizing the Hyper-V Default Switch, however, it cannot work with a physical WIFI NIC.

    2019年9月18日 下午 06:09
  • Hyper-V doesn't use bridges, that's something that was manually created outside of Hyper-V.  Hyper-V uses a virtual switch which essentially adds a layer on top of your NIC, while you could consider it a "bridge" it won't show up anywhere labeled as such.  It should only appear in your network card list, in your case "vLAN External."  Assigning the "vLAN external" to your VM is all you should need to do. 

    Personally, I'd delete all your bridges and the existing virtual switch, and recreate a new external virtual switch.

    The default switch should and generally does work with a wireless NIC, I just verified on my laptop with success.  You could hit a driver issue though, since Hyper-V virtual switches have always been finicky with wireless NIC drivers.  Hit up tp-link's site for updated NIC drivers, just to be safe.

    2019年9月18日 下午 11:21
  • Default Switch: Without bridging, it will not work in any of my three VM's.

    Here's a video of me creating an External Virtual Switch. As you will see, it automatically creates a bridge. My initial settings may be incorrect, though.

    Video: External Virtual Switch



    • 已編輯 msdnScott 2019年9月19日 下午 04:17
    2019年9月19日 上午 12:44
  • I am not sure what you meant by "I've tried ICS". How did you try ICS? The default switch is basically just that. It uses ICS to provide a NAT-like connection the Internet, and you say that does not work for you.

      How is the host machine connected to the Internet? Is it on a LAN which has a router which does DHCP for the LAN?


    Bill

    2019年9月19日 上午 07:05
  • I am not sure what you meant by "I've tried ICS". How did you try ICS? The default switch is basically just that. It uses ICS to provide a NAT-like connection the Internet, and you say that does not work for you.

      How is the host machine connected to the Internet? Is it on a LAN which has a router which does DHCP for the LAN?


    Bill

    ICS: enabled ICS on my wifi connection, shared it to a V internal switch. I simply could not get the VM's to make a solid connection, and the IP structures changed, i.e. 192.168.137.246 instead of 192.168.1.246.

    Host, how else can I present it...Host > Wi-Fi NIC > Router/Gateway > Internet. I have a LAN identified, but there's nothing between my PC and the router. Router does DHCP; I have set static IP's to all connected devices.

    2019年9月19日 下午 01:06
  • Default Switch: Without bridging, it will not work in any of my three VM's.

    Here's a video of me creating an External Virtual Switch. As you will see, it automatically creates a bridge. My initial settings may be incorrect, though.

    Video: External Virtual Switch


    Link doesn't work.  
    2019年9月19日 下午 03:50
  • I updated the link to... https://vimeo.com/360941113

    2019年9月19日 下午 04:17
  • I completely reset all virtual switches; removed all from Device Manager and rebooted. Assigned the Default Switch to my VM and booted it (Win 10 VM). It will not connect. Below are a series of screenshots...

    Host Network Connections:

    Default Switch:

    Host Network:

    Hyper-V:

    VM Network:


    • 已編輯 msdnScott 2019年9月19日 下午 04:36
    2019年9月19日 下午 04:33
  •   If you are on a routed network, I would recommend that you set up your external virtual switch on the Ethernet NIC and using the WiFi NIC for the host. You should not need to use static IPs. The guest should get its config from DHCP, just as a physical machine would.

      If the WiFi NIC does not work correctly even with a default switch setup, I suspect that there is a compatibility problem with the TP-Link software. Everything works fine with my Dell 1705 WiFi NIC.   

        



    Both host and guest will get IP addresses from DHCP and behave as if they were two phyical machines on the same LAN. IN my case, their IPs are 192.168.1.2 and 192.168.1.26  .


     

    • 已編輯 Bill Grant 2019年9月20日 上午 03:09
    • 已標示為解答 msdnScott 2019年9月20日 下午 05:13
    2019年9月20日 上午 03:02
  • @Bill, your screenshot was what I needed. All the documentation and support I found noted that I had to connect the External V Switch with the physical NIC I was using for my Internet traffic. In your example, and ultimately the solution, I connected the External V Switch with my unused Ethernet connection. Thank you.

    Although this did not solve my other issue, of getting two NIC's to work in my PC, it is a moot point now.

    2019年9月20日 下午 05:13
  • The external virtual switch has to be connected to a NIC which has an Internet connection but it does not have to be the one which the host uses. In fact the system you are using is the preferred method - ie the host and guest each having its own connection to the physical LAN.

    Bill

    2019年9月20日 下午 11:09