Issues with TS certificate to TS farm DNS name


  • Hi,

    We have 2x 2008 R2 RDS Servers (ts1 and ts2) and 1 x connection broker for these.  I've created a DNS entry for ts that points to both so that users can connect to either.  However, I don't know how to digitally sign the ts name. 

    I have 2x thin clients onsite (HPs), and when I use the HP Connection Manager to connect, it gives a certificate error saying unknown publisher. I've tried clicking on don't ask me again, but it still comes back every time, even if I commit changes after clicking on don't ask again.

    Does anyone know what I should be doing?


    PS... here is my hpconnector.ini file which holds the rdp settings for the connection:

    [connectspec/Terminal Server]

        PrimaryConnections=Terminal Server
        AutoLaunchConnections=Terminal Server
        PersistentConnections=Terminal Server

    28. června 2012 2:58


Všechny reakce

  • This is a screenshot of the issue.  I can click the do not ask, but even if I do, it just keeps coming back.  The client os is Windows 7 embedded.


    28. června 2012 2:59
  • Closing this article. Sorted out issue.
    28. června 2012 4:17
  • Hello Luke,

    we are having exact the same problem in our environment. How can we get rid of this pesky waring message??

    We want to connect HP Thin Clients T510 via RDP to an Windows 2008 Terminalserver. The message appeared since we checked the "ports" option (we need the COM1 redirected to the TS).

    If you solved this problem your help would be very appreciated!

    Thanks from Germany!

    17. srpna 2012 10:00
  • Hi Jesse,

    I found out that the problem was due to having Redirect smart cards and comm ports enabled. I turned these off, saved the connection and then no more pesky message.  In your case, with you needing the com port, you may need to find a different solution... or hopefully turning off smart card redirection will fix it.



    17. srpna 2012 13:03