Windows 2012 - Failed to enumerate objects in the container. Access denied


  • Hi All,

    I have a Windows Server 2012 file and print server. I am having some issues gaining ownership of files/folders with my domain admin account. I cannot view the security information on the folders in questions so I attempt to take ownership, however when I apply this I get the following error:

    This happens on multiple folders, these are folders for document redirection.

    Any advice would be appreciated.



    14. ledna 2013 13:31


Všechny reakce

  • Hi Dave,

    Thanks for posting in Microsoft TechNet forums.

    We can check the thread below with similar issue.

    Domain Admins Denied Access To View Volume Even When Granted Full Control NTFS


    16. ledna 2013 5:42
  • This actually got fixed by a Microsoft update so turned out to be a bug in the end!


    • Označen jako odpověď Triumphtech 28. ledna 2013 11:00
    28. ledna 2013 11:00
  • I got this error also but in MachineKeys folder. I am trying to give permissions for IUSR or NetworkService but I got error like this above ;/
    5. února 2013 12:08
  • Anybody can help with this issue?
    6. února 2013 12:30
  • Could share the KB article of the update that fixed the problem?
    15. února 2013 21:17
  • Yes the KB or hotfix would be nice.  I ran into this today and I have all updates.  I did find this work around that was on Microsoft Answers for Windows 8...

    1. On the root folder, right click, select properties, select security tab.
    2. Click Advanced
    3. The window that pops up should show the current owner. Click "Change." The "Select User or Group" pop up box appears. 
    4. In the text box, type in your current user name (you should be an admin), and hit the "Check Names" button. Your name will be replaced with the "official" system name (i.e.,preceded by computer name and back slash).
    5. Click OK
    6. The box disappears, sending you back to the Advanced Security Settings window.
    7. A new tick box appears below owner, with the text "Replace owner on subcontainers and objects" Select this tick box.
    8. I also selected the tick box "Replace all child object permission entries with inheritable permission entries from this object", but I think I had to run this twice - once with this box ticked and once without.
    9. Make sure that "everyone" appears on the Permission entries window, if not, click add. The same box that appears in step 4 shows up again. Type everyone, click "Check Names" and then "OK"

    9. Hit apply

    I wish I had the link to it to give credit to the person who answered to it, these are just my notes.  It did work for me.

    It seems odd that with each new version of Windows Server its get harder and harder to setup a simple file share.  Windows 2003 was very simple and logical.  2008 R2 and UAC made it more difficult, 2012 even more.

    Thanks, -Lindy

    • Upravený cwlindy 23. srpna 2013 3:05
    23. srpna 2013 3:05
  • There is no such thing as a bug only bad programming.

    Larry (Netforce)

    14. ledna 2014 14:43
  • This actually got fixed by a Microsoft update so turned out to be a bug in the end!


    As of 02/27/2014 I am still having this issue on a fully patched 2012 R2 Standard server. I was able to work around it by using the local Administrator account to assign permissions, rather than using an account in "Domain Admins".

    This bug does not seem effect permissions when using the folders, as I am able to create/modify/etc.; it is only an issue when setting the permissions on the folder.

    27. února 2014 15:59
  • In my case, I had browsed to the folder using the UNC rather than going directly to the shared folder itself.  Even though I was browsing via File Explorer on the server, logged on as the Domain Administrator, I got this error ONLY when attempting to change permissions after browsing by UNC.

    -- Example --





    Painful but resolved.

    - Paul

    5. března 2014 21:08
  • Thanks for that Erik,

    I found that if I use the domain administrator account and take ownership and ticked the box underneath and also added that account to have full control I was then able to change the permissions of the files in the subfolders.

    30. března 2014 8:40
  • Thanks 
    22. června 2014 16:02
  • Oh, if we only had a choice.  I dread each new version of MS anything.  MS has ruined domain admin, Outlook (can't even see it), Office is a mess...  This fix worked for me, also.
    30. října 2014 15:31