none
Software Raid 5 braucht sehr lange zum Rebuilden RRS feed

  • Allgemeine Diskussion

  • Hallo, kann man die Rebuild Geschwindigkeit des Software Raid 5 unter Server 2008 R2, bzw. Windows Home Server 2011 irgendwie beschleunigen? Der Prozess hierfür scheint nur mit sehr niedriger Priorität zu laufen, und es dauert bei mir ca. 3 Tage bis ein Rebuild passiert ist obwohl der Server kaum belastet wird.
    Dienstag, 31. Mai 2011 18:12

Alle Antworten

  • Moin,

    ohne Deine Hardware-Plattform zu kennen, lässt sich wenig dazu sagen.

    Allerdings hängt die Rebuildgeschwindigkeit in jedem Fall von Größe, Anzahl und Füllstand der beteiligten Platten sowie der Performance des Controllers massgeblich ab.

    Nicht ohne Grund werden nach wie vor dedizerte RAID-Controller empfohlen.

    Von daher bin ich noch nicht mal der Auffassung, dass das unnormal ist.

    Viele Grüße

    Olaf

    Freitag, 3. Juni 2011 09:30
  • Danke für die Antwort.

    Ich habe für den Home Bereich leider keinen Raid Controller finden können der auch für Server 2008 R2 spezifiziert ist und entsprechend WHQL Treiber hat.

    Mit dem Software Raid unter Windows bin ich eigentlich sehr zufrieden da ich unabhängig von der Hardware bin. Wobei es eben auch Nachteile bietet (z.B. das man bei einem Rebuild nicht neu starten darf). Das Intel Onboard Raid erzeugt leider durchgehend Bluescreens also bleibt mir nur noch das Sofware Raid.

     

    Ich setze ein Mainboard mit Intel H67 Chipsatz, einen Core i3 2100 CPU mit 4GB RAM und für das Raid 5x 2TB Western Digital Green HDDs ein. Das Raid ist mit gerade mal 1TB belegt und die Rebuildgeschwindigkeit ist (nach einem Stromausfall kam es dazu) ist fast genau so lange wie beim ersten Aufbau, und das sind ca. 3.5 Tage.

    Da die Parität ja durch die CPU berechnet wird, hatte ich gehofft das ich dass Rebuild irgendwie beschleunigen kann. Denn die CPU Auslastung ist durchgehend auf unter 10% und auch der Festplatten I/O ist sehr niedrig. Derzeit wird auf den Server auch nicht zugegriffen. Das heisst, dass System hätte Ressourcen zur Verfügung aber sie werden nicht benutzt. Das ist eigentlich mein Problem.

    Freitag, 3. Juni 2011 10:52
  • Nimm den Adaptec 5805 SAS/SATA und ein Adaptec Batterie Modul.

    Hab die gleiche erfahrung gemacht, mein MSI H57M-ED65 und I Core 5 650 als CPU, 4GB Ram waren sehr langsam.

    Flaschenhals ist die Anbindung von den SATA Ports mit maximal 300MB zum Chipsatz.

    Wenn du umsteigen willst musst du vorher alle Daten sichern, weil der Controller sein eigenes Filesystem erstellt.

    Dann sind deine Daten aber sicher und er macht kein Rebuild mehr.

    Samstag, 11. Juni 2011 07:56