none
Cannot index into a null array.

    Frage

  • i have a powershell script that creates a Site Collection, SharePoint Permission Levels, SharePoint Groups and adds users to group
    sequentially, enables the essential features in the Site Collection, uploads the master page, and the site template 

    when i run the script it creates user groups with the names in a csv file attached and referred to also it gets the user names in each group from the same csv file i already added the users but when i run the script it returns the following error:

    AD User ADMAPAPP\cma.administrator does not exists

    Cannot index into a null array

    At C:\ADSSC\Deployment\Application\CMA_Script.ps1:979 char:35

    + $groupexists = $weburl.SiteGroups[ <<<<  $line.GroupName]

    +CategoryInfo                  :  InvalidOperation:  <CMA_Customer:String> [], RuntimeException

    +FullyQualifiedErrorId : NullArray

    Sonntag, 4. November 2012 11:57

Antworten

  • As you have not posted the script, it is impossible to say what's wrong.  But if the error is on line 979, please don't post the script:  It is too long for a forum like this.

    You need to narrow down the part that is not working, and post something that we can reproduce.


    Grant Ward, a.k.a. Bigteddy

    Sonntag, 4. November 2012 13:03