none
RDSH: Bei RDP-Reconnect falsches Tastatur-Layout RRS feed

  • Frage

  • Liebes Forum,

    Wir haben ein eigenartiges Problem. Wir haben Benutzer, die wir aufgrund von angeschlossenen Barcode-Scannern unbedingt auf Englisch als Tastatur-Layout betreiben müssen. Das funktioniert soweit via GPO einwandfrei. Wenn wir uns mit dem Benutzer anmelden und ein Notepad öffnen und testen, haben wir das gewünschte QWERTY Layout.

    Sobald wir uns aber "Disconnecten" und "Reconnecten", also ohne abmelden dazwischen, wechselt das Tastatur-Layout auf Deutsch, OBWOHL:

    - am Client sogar englische Tastatur eingestellt ist (getestet mit vielen verschiedenen Windows 10 Clients)
    - In der Eingabesprache in der RD-Session immer noch ENG angezeigt wird
    - Wir sogar den Registry Key ignoreRemoteKeyboardLayout auf dem Terminalserver auf 1 gestellt haben

    Das Problem ist jetzt, dass diese Scanner-Terminals via WLAN betrieben werden, und somit immer wieder mal rausfallen, und dann beim Reconnect die falsche Sprache haben. Der Reconnect passiert aber innerhalb von Sekunden, weswegen ich schlecht einen "Logoff at Disconnect Timeout" einstellen kann...

    Ich finde nirgendwo etwas dazu, habt Ihr eine Idee, oder einen Workaround?

    Mittwoch, 17. November 2021 19:39

Alle Antworten

  • Moin,

    was steht denn bei den betroffenen Usern in HKCU:\Keyboard Layout\Preload ?

    Wäre es eine Option, die Serversprache auf EN zu setzen?


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Mittwoch, 17. November 2021 20:07
  • Im folgenden Registrierungsschlüssel zum Beheben des Tastaturproblems während der RDP-Sitzung.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Tastaturlayout
    Erstellen Sie einen neuen DWORD-Wert IgnoreRemoteKeyboardLayout und geben Sie ihm den Wert 1.

    Das sollte reichen um dein Problem zu lösen.

    einfach nur die OPs lesen. Für die Anzahl Antworten gibt es keine Punkte...

    Evgenij Smirnov

    http://evgenij.smirnov.de

    Donnerstag, 16. Dezember 2021 17:43