none
RDP stopped listening on port 3389 RRS feed

  • Question

  • HI everyone,

    I've recently updated a HP Proliant server with the latest service pack from HP (SPPMDSLWIN2014020.2014_0129.3)

    Upon reboot, I noticed I could no longer RDP to the server.

    I can ping the server, but I note when I do a netstat -a -o port 339 is not listening.

    As has always been the case, the firewall service is started but is turned off for domain, home and public so need need to add 3389 as an allowed port.

    Changing the RDP-Tcp port number to 3390 and restarting RDP made no difference.

    SFC /scannow found no issues.

    How can I force RDP to again listen on 3389?

    Sunday, March 23, 2014 10:53 PM

Answers

  • So, I've found a solution.

    Found "Remote Desktop Security Filter Driver" was disabled (In Device Manager - Hidden Devices - Non Plug and Play )

    Removed that driver, restarted a server, and everything works again.

    However "Remote Desktop Security Filter Driver" did not got back in Device Manager.

    Saturday, March 29, 2014 12:47 PM

All replies

  • Hi,

    What server operating system are you running?

    If Server 2008/2008 R2 you can try deleting and recreating the RDP-Tcp listener using tsconfig.msc.  For Server 2012/2012 R2 you would need to use wmi.

    Any errors in the event logs?

    Are you able to remove the service pack?

    -TP

    Monday, March 24, 2014 6:22 AM
    Moderator
  • I'm running Windows Server 2008 R2 Sp1, no errors in event log, can't remove service pack as it's 2008 R2 with SP1. And you can't even re-install a service pack these days.

    Tried deleting / re-creating the RDP-TCP listening, still not working.

    RDP wouldn't work after I installed the latest HP Proliant Service Pack (SPPMDSLWIN2014020.2014_0129.3)

    Monday, March 24, 2014 9:30 PM
  • Hi,

    I was referring to the HP service pack.

    -TP

    Tuesday, March 25, 2014 5:58 AM
    Moderator
  • Hi,

    Thank you for posting in Windows Server Forum.

    Please check below mention thread for more troubleshooting guides.

    RDP suddenly stop working on Windows 7 SP1/ Port 3389 not Listening

    Try to modify the registry changes as per below mention.

    1.  Start Registry Editor.
    2.  Locate and then click the following registry subkey:
        HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

    3.  On the Edit menu, click Modify, and then click Decimal.
    4.  Type the new port number, and then click OK
    5.  Quit Registry Editor.
    6.  Restart the computer.

    More information:
    How to change the listening port for Remote Desktop
    http://support.microsoft.com/kb/306759

    Apart from this also check this thread.

    Hope it helps!

    Thanks,
    Dharmesh
    Tuesday, March 25, 2014 7:52 AM
    Moderator
  • The same situation on the DL380G7.

    Have you solved the problem?

    Thursday, March 27, 2014 7:58 PM
  • Hi,

    Do you need any other assistance?

    Thanks,
    Dharmesh
    Friday, March 28, 2014 8:43 AM
    Moderator
  • So, I've found a solution.

    Found "Remote Desktop Security Filter Driver" was disabled (In Device Manager - Hidden Devices - Non Plug and Play )

    Removed that driver, restarted a server, and everything works again.

    However "Remote Desktop Security Filter Driver" did not got back in Device Manager.

    Saturday, March 29, 2014 12:47 PM
  • So, I've found a solution.

    Found "Remote Desktop Security Filter Driver" was disabled (In Device Manager - Hidden Devices - Non Plug and Play )

    Removed that driver, restarted a server, and everything works again.

    However "Remote Desktop Security Filter Driver" did not got back in Device Manager.

    We had this same problem.  installed the most recent SPP on DL380 G5s and now RDP is not working.  3389 is not listening using netstat -a -o

    I uninstalled the Remote Desktop Security filter drive and rebooted but that did not resolved the issue.  Has anyone else found a fix?

    Wednesday, June 18, 2014 4:19 PM
  • So, I've found a solution.

    Found "Remote Desktop Security Filter Driver" was disabled (In Device Manager - Hidden Devices - Non Plug and Play )

    Removed that driver, restarted a server, and everything works again.

    However "Remote Desktop Security Filter Driver" did not got back in Device Manager.

    We had this same problem.  installed the most recent SPP on DL380 G5s and now RDP is not working.  3389 is not listening using netstat -a -o

    I uninstalled the Remote Desktop Security filter drive and rebooted but that did not resolved the issue.  Has anyone else found a fix?

    Just been struggling with this issue on a DL360G7 - and this HP page had the answer (use the CP023518.EXE NIC driver);

    http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/SPP-2014-02-DL385-G7-Win2008-R2-SP1-U1-bad-news/td-p/6475184#.U6K5UPmSzh4

    I just installed this driver after the SPP 2014.02(B) fiasco, and I can now RDP. The hidden devices are also now enabled, and running.

    I might give this SPP a miss on my PROD boxes for the time being...


    Thursday, June 19, 2014 10:45 AM