none
Clear type setting is not being saved across rdp sessions

    Question

      • Log in via RDP, turn clear type (cleartype) on, set up how it looks best to you.
      • Everything looks good.
      • Close the rdp session (you don't have to log out)
      • Open an rdp session and you'll see that cleartype is no longer on.

    I've read several things that I think are in error:

    • cleartype isn't supported in RDP: This is wrong as of win7 and (?) Win2008
    • the server is examining the cleartype settings on the client and if it's not set on the client, then it's not set on the server: this is in error also- it's definitely on on my win7 (64) client machine

    Unless someone can point me in the direction of more authoritative sources, this appears to be a bug- one I'd love to see fixed soon- cleartype is such a great thing that it's hard to go back.



    • Edited by dethswatch Tuesday, September 22, 2015 9:34 PM
    Monday, September 17, 2012 5:11 PM

Answers

  • Hi,

    Thanks for your post.

    Please note that ClearType functionality is known as font smoothing in RDC. Ensure that the Font smoothing was check in RDC -> Options -> Experience tab. Also, verify you log in with the same user which has configured the cleartype.

    In addition, of course it supported in Windows 2012 and Window 8 client. For more detailed information, you may refer to the following article.

    Configure Font Smoothing for Remote Sessions

    http://technet.microsoft.com/en-us/library/cc742823.aspx

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Wednesday, September 19, 2012 6:45 AM
    Moderator

All replies

  • Hi,

    Thanks for your post.

    Please note that ClearType functionality is known as font smoothing in RDC. Ensure that the Font smoothing was check in RDC -> Options -> Experience tab. Also, verify you log in with the same user which has configured the cleartype.

    In addition, of course it supported in Windows 2012 and Window 8 client. For more detailed information, you may refer to the following article.

    Configure Font Smoothing for Remote Sessions

    http://technet.microsoft.com/en-us/library/cc742823.aspx

    Best Regards,

    Aiden


    Aiden Cao

    TechNet Community Support

    Wednesday, September 19, 2012 6:45 AM
    Moderator
  • Hi,

    In the RDP client -> option Experience, if you use "Detect connection quality automatically" to connect to the remote server host, then you'll have your ClearType setting to OFF (no matter that ClearType was enabled on the remote server host), although on the RDP client's Experience tab it is shown that Font Smoothing is set when automatical quality detection has been selected ?!

    To have the ClearType set to ON when RDP connects to the remote server host (if on the server the ClearType was enabled), then just don't use the option "Detect connection quality automatically" - instead, use another option like "LAN (10Mbist or higer)" where the Font Smoothing checkbox is shown and checked, then connect to the remote server host and you'll find your ClearType setting as ON !

    Microsoft has to check how its RDP client's options are set when the "Detect connection quality automatically" option is used, because the grayed options shown as selected, including the Font Smoothing" is misleading and not correct.

    Best regards,

    Romain

    Thursday, October 6, 2016 3:28 PM