RDS in WS2012 Thin Clients not getting connected : Urgent Help Required

    General discussion

  • Hi Everyone,

    I have managed to install and configure WS2012 with Hyper V and a virtualized TS Server. In fact the inputs and problems/solutions available in this forum have helped me.

    I have following problem :

    I have created a virtual which is a RDS Server It has RDCB/RDSH/RDWEB /RDGateway roles installed on it. The Remote DEsktop Licensing shows no errors or issues. If I login through IE, I am able to login and see the published the applications on this server. Both my ADDS server and TS Server as well as Thin Clients are in the same subnet on local LAN within the premises.

    I have a few Thin Clients in my local LAN network with WIN7 embedded. These are not able to log in through RD Gateway.

    1. If I give IP address of the RDS server & tick automatically detect RD Gateway settings, the RDP Client connects as a Remote Console Admin. Initially it says the server is an untrusted server, but if I say connect anyway, it connects.

    2. If I provide IP address in General Tab ( remote computer ) and  RDGateway server IP Address in Advanced Settings ' use following Gateway Server' it returns an error stating ' the subject in the certificate and server name does not match ' and does not connect.

    3. INstead of IP Address, if I provide FQDN for TS Server ( TS-Server.mydomain.local ) ,as well at 'use this RDGateway server , it says the RD gateway server is temporarily unavailable, please try later.

    This is holding up my go-live date for the server,. Any help will be highly appreciated.

    Added On 14-06-2013

     I have tried to do a Remote DEsktop connection from TS Server to itself, even there it says ' The RD gateway server is temporarily unavailable, please try later. '

    I have checked logs but there in nothing in them.

    From :


    Thursday, June 13, 2013 9:31 AM

All replies

  • You can only use the same gateway name as specified in imported certificate in rd gateway configuration. I think it should be fqdn, but it's not resolving your issue that server is unavailable. Try to restart rd gateway service, check event logs if still not works, check event logs for rd services at app. and services logs\microsoft\windows.

    --- Jacek Kochan MCSE,MCSA,MCITP

    Thursday, June 13, 2013 10:53 AM
  • I have tried reboot of complete server but it has not helped.  The logs do not show anything except 'service started'.

    Is it possible to trace any particlular RDS cnnection and find out where it runs into problems during connection-logon process?

    From :


    Friday, June 14, 2013 5:01 AM
  • event log atTerminalServices-Gateway\Operational

    --- Jacek Kochan MCSE,MCSA,MCITP

    Friday, June 14, 2013 8:44 AM
  • Thanks for reply. But could yu be more specific? I have checked Event logs for system and application but there is nothing unusual about RD Gateway.


    Friday, June 14, 2013 2:01 PM
  • Check log at applications and services\microsoft\windows

    --- Jacek Kochan MCSE,MCSA,MCITP

    • Edited by Jacolex Wednesday, June 19, 2013 11:56 AM \\\\
    Wednesday, June 19, 2013 11:56 AM
  • The above isue was resolved after I obtained paid support from Microsoft support.

    The problem was a erroneous entry on the DNS server. After it was updated the problem was resolved. I am thankful to MS SUpport for prompt and courteous support.

    Thursday, June 27, 2013 4:33 AM