none
Web passwords not saved in Credential Manager RRS feed

  • Question

  • Hello,<o:p></o:p>

    since we build a new 2012R2 RDS farm we have problems
    with the remember password for an IE website. The option to remember passwords
    in IE is enabled but in the credential manager the password is not cached.<o:p></o:p>

    I checked with vaultcmd /list to see where the vault
    directory is stored. It is stored in
    c:\users\%username%\appdata\local\Microsoft\Vault.<o:p></o:p>

    That directory do not exist. (most of the time)<o:p></o:p>

    Now the strangest thing is that sometimes it does work
    and the directory suddenly exists. Its not server related, it is random. I did a search for
    the Vault directory in all logged in users directory and some have the vault
    directory and some not.<o:p></o:p>

    Also new users have the same problem.<o:p></o:p>

    I hope someone has an answer or solution? Thanx,<o:p></o:p>


    Tuesday, October 7, 2014 2:42 PM

Answers

  • Hi,

    I checked the Registry setting and it was not configured. I solved the problem now by creating a Vault directory in the users profile in a loginscript:
    IF NOT EXIST ("%USERPROFILE%\Appdata\Local\Microsoft\Vault")
       MD ("%USERPROFILE%\Appdata\Local\Microsoft\Vault\4BF4C442-9B8A-41A0-B380-DD4A704DDB28")
       MD ("%USERPROFILE%\Appdata\Local\Microsoft\Vault\UserProfileRoaming")
    ENDIF

    Oke so now if i save a web password i can see it in the Credential Manager. So that is working.

    But now there is a second problem. We are using a RDSFarm and when logging off and logging in it can be that you are redirected to another server. Now the Web credentials will not Roam. I enabled Credential Roaming but still it will not roam.

    When i store a web password in Credential Manager and look at the extra info it shows: Roaming: No

    Wednesday, October 15, 2014 5:13 AM

All replies

  • When using processmon and using internet explorer to save a password the following error is shown:

    Thread: 1208
    Class: File system
    Operation: CreateFile
    Result: PATH NOT FOUND
    Path: c:\users\username\appdata\local\microsoft\vault\4bf4c442-9b8a.......

    it shows Path not found to store the password in the c:\users\%username%\appdata\local\microsoft\vault

    Tuesday, October 7, 2014 7:22 PM
  • Hi,

    Thank you for posting in Windows Server Forum.

    Please try to use registry  fix and check the result. 

    Open registry editor and go through following path.
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

    Look for the FormSuggest PW named string (REG_SZ), If can’t find then create one and fill the value as Yes.

    Please check below article for information.
    Fix: Credential Manager not working properly in Windows 8 | 7

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    TechNet Community Support

    Monday, October 13, 2014 1:31 AM
    Moderator
  • Thanx Dharmesh Solanki,

    unfortunately the redistry Edit dit not work.

    I discovered that when i manually restart the Credential Manager service on the RDS server and login as a user on the server that when i save a password in IE the vault directory is created successfully. But when i logoff and login againt the problem occurs again. When i try to save a web password it is not stored in the Credential Manager and the Vault directory is not there/created.

    Monday, October 13, 2014 11:23 AM
  • Hi,

    Thanks for your comment.

    Kindly check the Security policy setting “Network access: Do not allow storage of passwords and credentials for network authentication” to control credential Manager. If you enable this setting, Credential Manager does not store passwords or credentials for domain authentication on the computer. You can find related setting under following path.
    GPO_name \Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options

    More information.
    Network access: Do not allow storage of passwords and credentials for network authentication
    http://technet.microsoft.com/en-us/library/jj852185(v=ws.10).aspx

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    TechNet Community Support

    Tuesday, October 14, 2014 1:28 AM
    Moderator
  • Hi,

    I checked the Registry setting and it was not configured. I solved the problem now by creating a Vault directory in the users profile in a loginscript:
    IF NOT EXIST ("%USERPROFILE%\Appdata\Local\Microsoft\Vault")
       MD ("%USERPROFILE%\Appdata\Local\Microsoft\Vault\4BF4C442-9B8A-41A0-B380-DD4A704DDB28")
       MD ("%USERPROFILE%\Appdata\Local\Microsoft\Vault\UserProfileRoaming")
    ENDIF

    Oke so now if i save a web password i can see it in the Credential Manager. So that is working.

    But now there is a second problem. We are using a RDSFarm and when logging off and logging in it can be that you are redirected to another server. Now the Web credentials will not Roam. I enabled Credential Roaming but still it will not roam.

    When i store a web password in Credential Manager and look at the extra info it shows: Roaming: No

    Wednesday, October 15, 2014 5:13 AM
  • Finally found a workarround:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/2ead13cc-2863-4637-b0fe-7f3b26a3aaf2/save-website-passwords-not-working-properly-with-credential-manager-in-windows-2012r2-rds?forum=winserverTS

    Friday, July 31, 2015 10:00 AM