none
Access Denied when you try to Remote Control User Session from Terminal Server Manager.

    Question

  • Q: What is the issue?
    A: Windows Server 2008 DataCenter Edition with Terminal Services role installed cannot use Remote Control feature through Terminal Services Manager.  RDP Connection in TS Configuration has been set to allow Interactive Remote Control without user permission.  RDP Connection permissions verified at Full Control for both users I've tried this under.  All user sessions, other than one I'm logged on under,

    Q: What error messages do you receive?
    A: Access is Denied when you right click the Session under Terminal server manager.

    Q: What specific applications are you experiencing the issue with?
    A: Terminal Services Manager

    Q: What recent changes were  made on the system?
    A: None.  Recently installed OS and components

    Tuesday, March 30, 2010 11:54 AM

Answers

  • v2sanket,

     

    You need to RDP to the server, and then use remote control.  Are you doing this, or are you on the console trying to remote control?


    Hope this helps,

    Kristin L. Griffin

    Co-Author of the Windows Server 2008 Terminal Services Resource Kit (and a SUPER BIG fan of the Microsoft RDV Team!!!) 

    I finally started my blog: blog.kristinlgriffin.com
    Wednesday, March 31, 2010 12:56 AM
    Moderator
  •  

    This is a known issue in 2008 server.  The solution is to install SP2 or to upgrade to 2008R2 Server.  I've had this same issue and opened a case with Tech Support - their response was the previous sentence.

    I have not tried 2008 SP2 because we had some linux-based HP thin clients which would actually not connect to it - I had to downgrade my server back to SP1.  It had something to do with support to RDP 6 on their linux image.

    I have just started to play with 2008R2 terminal servers, however, and everything is working well.  My linux clients connect to it AND I can shadow users' session.  It's also got some nice multimedia handling.

    Pam

    • Proposed as answer by pmcleod Thursday, July 22, 2010 8:14 PM
    • Unproposed as answer by v2sanket Friday, July 23, 2010 8:24 PM
    • Marked as answer by v2sanket Friday, July 23, 2010 8:24 PM
    Thursday, July 22, 2010 8:09 PM
  • Hi ShallowTech,

    Please download and install the following hotfix on your Server 2008 SP2 servers and test to see if your issue is resolved.

    A shadowed Windows Server 2008 Terminal Services session is disconnected from a computer that is running Windows Server 2008 R2 SP1 or Windows 7 SP1

    http://support.microsoft.com/kb/2523307

    Please reply back here and let us know if the hotfix helps.

    Thanks.

    -TP

    Friday, February 10, 2012 4:37 PM
    Moderator

All replies

  • Are you having multiple monitors by any chance? Remote Control (aka Shadow) does not support multi-monitor mode and will give access denied error (meaning inaccessible feature in current mode)

    Thanks

    Rong


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, March 30, 2010 7:22 PM
    Moderator
  • v2sanket,

     

    You need to RDP to the server, and then use remote control.  Are you doing this, or are you on the console trying to remote control?


    Hope this helps,

    Kristin L. Griffin

    Co-Author of the Windows Server 2008 Terminal Services Resource Kit (and a SUPER BIG fan of the Microsoft RDV Team!!!) 

    I finally started my blog: blog.kristinlgriffin.com
    Wednesday, March 31, 2010 12:56 AM
    Moderator
  • We are definately remoting the TS server and than controlling the sessions.

    One thing i found that was once the session is locked and when i try to remote control i get access denied and when i unlock the session i can remote control.

    But dont know if that is the problem, if the session is locked i am unable to remote control it

    Wednesday, April 07, 2010 4:37 PM
  • Hi,

    This is normal behavior.  You cannot remote control a session that is locked.

    -TP

    Wednesday, April 07, 2010 5:44 PM
    Moderator
  • Windows server 2008 x64 Standard SP2, configured for TS access, 2 Quad processors, 8 GB memory, GB Nic, 554 GB HD, Raid 10.

    Windows XP SP3, RDP client 7, 3 monitors, 4GB memory GB Nic

     

    RDP to server not a problem, open TS Manager, right click to shadow another client, I see their desktop, but have no control over the shadowed desktop. disconnect shadow session and I get

    "Terminal Services Manager"

    Access is denied

                                   OK

     

    Anyone else having this problem?

     

    Franz

     

    Friday, May 14, 2010 6:59 PM
  • Windows server 2008 x64 Standard SP2, configured for TS access, 2 Quad processors, 8 GB memory, GB Nic, 554 GB HD, Raid 10.

    Windows XP SP3, RDP client 7, 3 monitors, 4GB memory GB Nic

     

    RDP to server not a problem, open TS Manager, right click to shadow another client, I see their desktop, but have no control over the shadowed desktop. disconnect shadow session and I get

    "Terminal Services Manager"

    Access is denied

                                   OK

     

    Anyone else having this problem?

     

    Franz

     

    I have also physically removed 2 monitors and am having the same issue
    Friday, May 14, 2010 7:01 PM
  • We've also the same issues. Recently we've installed Windows 2008 64bit terminal server with service pack to see if Microsoft has resolved the multiple monitor remote control issue. But it still doesn't work. Still the error Access Denied and also when you use the shadow.exe command no remote control.
    Tuesday, July 20, 2010 8:08 AM
  •  

    This is a known issue in 2008 server.  The solution is to install SP2 or to upgrade to 2008R2 Server.  I've had this same issue and opened a case with Tech Support - their response was the previous sentence.

    I have not tried 2008 SP2 because we had some linux-based HP thin clients which would actually not connect to it - I had to downgrade my server back to SP1.  It had something to do with support to RDP 6 on their linux image.

    I have just started to play with 2008R2 terminal servers, however, and everything is working well.  My linux clients connect to it AND I can shadow users' session.  It's also got some nice multimedia handling.

    Pam

    • Proposed as answer by pmcleod Thursday, July 22, 2010 8:14 PM
    • Unproposed as answer by v2sanket Friday, July 23, 2010 8:24 PM
    • Marked as answer by v2sanket Friday, July 23, 2010 8:24 PM
    Thursday, July 22, 2010 8:09 PM
  • Do have the case detail in any plz
    Friday, July 23, 2010 8:24 PM
  • The shadowing issue still occurs with 2k8 R2 when using multimons...

    This article describes that multimonitors are not supported for remote control/shadowing:

    Article 2484290: You cannot shadow a session with multiple monitors enabled in Windows Server 2008 R2

     

    Wednesday, September 14, 2011 1:28 AM
  • Is someone able to point me to a KB Article that describes this "known issue" with shadowing RDP sessions?

    Additionally, it would be nice to know what is causing this issue and how Microsoft is addressing it. The company I work for is currently running three terminal severs. Each of these terminal servers are running Windows Server Enterprise (2008) SP2. At this time I am unable to shadow any session on any of these servers from a windows 7 workstation. Regardless of if I am using command line or RDP gui the connection drops, disconnects the user and give the admin (me) an access denied message. 

    This issue started months ago, but I am unsure which SP or update caused it. I was contemplating opening a ticket with Microsoft, but I do not feel that we should have to pay a fee for something that was broke from an update. Furthermore, we do not see that removing a whole service pack of critical updates is an option. I would like some clarity on this issue.

    Thank you,

    Friday, February 10, 2012 4:25 PM
  • Hi ShallowTech,

    Please download and install the following hotfix on your Server 2008 SP2 servers and test to see if your issue is resolved.

    A shadowed Windows Server 2008 Terminal Services session is disconnected from a computer that is running Windows Server 2008 R2 SP1 or Windows 7 SP1

    http://support.microsoft.com/kb/2523307

    Please reply back here and let us know if the hotfix helps.

    Thanks.

    -TP

    Friday, February 10, 2012 4:37 PM
    Moderator
  • Thank you very much! : ) After testing on our DR site, to verify the issue was there, I installed the hotfix and it resolved the issue. Thank you for the quick response.

    Friday, February 10, 2012 9:19 PM
  • This did not resolve the issue for us.  The hotfix will not install and says "The update is not applicable to your computer."  Tried on the Terminal Server and the Workstation I'm working from.

    Anyone else having ongoing issues with this.  Terminal Server is Server 2008 SP2, and client I'm connecting from is Win 7 SP1.

    Tuesday, June 26, 2012 2:58 AM
  • Hi Ben,

    Which hotfix did you download to your server?

    If your server is 64-bit you need to select Windows Vista x64, if your server is 32-bit you need to select Windows Vista x86 on the hotfix request page.  Please click Show hotfixes for all platforms and languages to see all three hotfix versions.

    Thanks.

    -TP

    Tuesday, June 26, 2012 3:10 AM
    Moderator