none
Gibberish in csv file - Office365 Excel RRS feed

  • Question

  • Hello Microsoft Community,

    I'm trying to open CSV file in hebrew language in Office365 Excel version 1907 (build: 11901, 20176) on WIN10 Pro 1809(All computers are updated to the latest 1809 updates) and it shows the text in gibberish..

    I have couple of PC workstations that have no problem opening this document and 2 PC's with this issue

    I tried to open the file from DATA>From text/CSV and the documents opens fine after pressing LOAD(File Origin: Hebrew(Windows):1255, Delimiter: Comma, Data type detection: Based of first 200 rows)

    I tried to change to UTF-8 unicode: 65001, and i get question marks in black squars unreadable

    I tried to open the document with notepad and still gibberish

    I tried changing the default language to Hebrew and it didnt help

    I tried to change the default font to Calibri (Opens on other PC's with this font) , still not working..

    Please advise..

    EDIT: SOLVED the issue: https://pureinfotech.com/change-region-settings-windows-10/

    I had to copy the regional settings from the PC's which opening the .CSV file without gibberish.


    • Edited by QmarkIT Tuesday, August 6, 2019 7:15 AM
    Wednesday, July 31, 2019 7:54 AM

Answers

  • Hi,

    >>… I tried to open the file from DATA>From text/CSV and the documents opens fine after pressing LOAD(File Origin: Hebrew(Windows):1255, Delimiter: Comma, Data type detection: Based of first 200 rows). I tried to change to UTF-8 unicode: 65001, and i get question marks in black squars unreadable

    I have created a .csv file and it worked fine on my machine. Do you mean operate like this? Have you checked the preview when changing File Origin to UTF-8? Such as in the red box.

    Maybe you can refer to those links to see if it helps:

    https://stackoverflow.com/questions/4221176/excel-to-csv-with-utf8-encoding

    https://stackoverflow.com/questions/6002256/is-it-possible-to-force-excel-recognize-utf-8-csv-files-automatically

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Bella Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Office 2019. 

    None of the links are helping me.. the only way it works for me is by importing from text\csv option under Data

    Another solution is to install libreoffice or openoffice but I prefer not to

    I have 3 different users that are able to open the file normaly.. but I couldnt find any configuration to copy..

    EDIT: SOLVED the issue: https://pureinfotech.com/change-region-settings-windows-10/

    I had to copy the regional settings from the PC's which opening the .CSV file without gibberish.


    • Edited by QmarkIT Tuesday, August 6, 2019 7:14 AM
    • Marked as answer by QmarkIT Sunday, August 11, 2019 5:13 AM
    Monday, August 5, 2019 11:28 AM

All replies

  • Hi,

    >>… I tried to open the file from DATA>From text/CSV and the documents opens fine after pressing LOAD(File Origin: Hebrew(Windows):1255, Delimiter: Comma, Data type detection: Based of first 200 rows). I tried to change to UTF-8 unicode: 65001, and i get question marks in black squars unreadable

    I have created a .csv file and it worked fine on my machine. Do you mean operate like this? Have you checked the preview when changing File Origin to UTF-8? Such as in the red box.

    Maybe you can refer to those links to see if it helps:

    https://stackoverflow.com/questions/4221176/excel-to-csv-with-utf8-encoding

    https://stackoverflow.com/questions/6002256/is-it-possible-to-force-excel-recognize-utf-8-csv-files-automatically

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Bella Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Office 2019. 

    Thursday, August 1, 2019 7:30 AM
    Moderator
  • Hi,

    Is there any updates of you?

    Regards,

    Bella Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Office 2019. 

    Monday, August 5, 2019 9:45 AM
    Moderator
  • Hi,

    >>… I tried to open the file from DATA>From text/CSV and the documents opens fine after pressing LOAD(File Origin: Hebrew(Windows):1255, Delimiter: Comma, Data type detection: Based of first 200 rows). I tried to change to UTF-8 unicode: 65001, and i get question marks in black squars unreadable

    I have created a .csv file and it worked fine on my machine. Do you mean operate like this? Have you checked the preview when changing File Origin to UTF-8? Such as in the red box.

    Maybe you can refer to those links to see if it helps:

    https://stackoverflow.com/questions/4221176/excel-to-csv-with-utf8-encoding

    https://stackoverflow.com/questions/6002256/is-it-possible-to-force-excel-recognize-utf-8-csv-files-automatically

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Bella Wu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Office 2019. 

    None of the links are helping me.. the only way it works for me is by importing from text\csv option under Data

    Another solution is to install libreoffice or openoffice but I prefer not to

    I have 3 different users that are able to open the file normaly.. but I couldnt find any configuration to copy..

    EDIT: SOLVED the issue: https://pureinfotech.com/change-region-settings-windows-10/

    I had to copy the regional settings from the PC's which opening the .CSV file without gibberish.


    • Edited by QmarkIT Tuesday, August 6, 2019 7:14 AM
    • Marked as answer by QmarkIT Sunday, August 11, 2019 5:13 AM
    Monday, August 5, 2019 11:28 AM
  • Hi,

    Thanks for your sharing here. Since you have found the workaround yourself, could you mind mark your reply as answer? Your kind move will help others who have similar issue quick find the answer and help close this thread.

    Regards,

    Bella

    Friday, August 9, 2019 9:17 AM
    Moderator