Server 2008 R2 - Extend Partition .. space not showing available


  • Good morning all -- have a question about extending a volume on Server 2008 R2.


    The volume is an iSCSI target using the Microsoft iSCSI initiator -- the iSCSI device is a Dell MD3000i.

    The volume was originally 500GB.  On the MD3000i, I expanded the space from 500GB to 1TB -- this went fine without any issues.  Once the space was expanded on the MD3000, I hopped on the server and saw the available unallocated space on that drive..  So, I followed the normal MS guide to extend a partition using the unallocated space -- I used the command prompt, diskpart, method instead of Disk Management GUI.

    After extending the disk (which went fine without any issues), I can now see Disk Management reports the drive as 1100GB instead of the original 500GB.  However, when I go to My Computer, it still only shows the disk as being 500GB.  When I right clicked on the volume to check the properties, it still showed 500GB but it didn't look right -- I recall some a couple of the areas just showed 0 bytes even though the disk was working and was usable. 

    After rebooting the computer, the problem still persists -- I did run a 'chkdsk /R G:' so it could find/repair any errors -- this fixed the 0 byte errors I saw on the drive properties.

    It should also be noted that from the MD3000, it is showing the volume as a 1100GB target instead of the original 500GB (so that looks fine).


    Any reason why this additional space is not available for use?

    Friday, June 17, 2011 2:50 PM

All replies

  • I also have screen captures of everything if anyone would like to see them..
    Friday, June 17, 2011 2:51 PM
  • Hi Chris,

    It sounds like you may have missed a step, based on your information above.

    In addition to resizing the iSCSI target lun, (Which you've already done), you would also need to resize the Volume located on this Disk in disk management, so that the filesystem can actually utilize this additional space.

    In Diskmgmt.msc, right-click the Volume in question (lower right-hand pane of Diskmgmt), and choose Extend Volume this will allow resizing the volume located on this disk to take advantage of the larger disk size.




    Sunday, June 19, 2011 2:48 PM
  • Bruce 


    Thanks for the reply but as my original post states, I expanded the lun, and also extended the partition from within Server 2008 using the command prompt method, instead of extending through Disk Management -- I tend to prefer the console over GUI for most things.

    I also reported on findings in Disk Management after performing the extend tasks..


    Sunday, June 19, 2011 4:44 PM
  • This is not the first time I see such an issue that the size is not changed in Properties while enlarge the size in ISCSI target.

    Have a test to disconnect in initiator, remove the virtual disk in ISCSI target (not delete the disk), then re-add it, connect in initiator to see if it will back to correct.  

    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact

    Tuesday, June 21, 2011 9:25 AM
  • How are things going? Please let us know if there is anything we can help.
    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact
    Friday, June 24, 2011 6:36 AM
  • I believe there is an issue with the way Windows calculates available disk size.  Occassionally, I have noticed that after increasing the size of a disk (by editing the virtual disk in vSphere client, or when space is allocated by someone on our storage team) that I am unable to just click through the wizard to extend the partition.  First I have to decrease the size I am attempting to extend because Windows is rounding to a slightly larger size than what's actually there (in vSphere you add GB to a drive, in the extend wizard it's MB).  I have seen similar behavior on physical servers with HBAs after a disk is enlaged on the storage side.  We use NetApp and EMC for physical servers with HBAs and virtuals, so I'm not sure if it's related to any particular storage vendor or Windows itself, but I'm leaning toward the MB/GB translation on the Windows side being the issue.

    Last week I added space to a virtual disk and had to adjust the available space to extend in the wizard.  Aftetwards disk manager showed the drive space as available but explorer (My Computer, Computer, what-have-you) only showed the original space.  I was able to resolve the issue by shrinking the disk and then extending again but setting the extended value to a meg or two smaller than what the wizard offered.

    • Proposed as answer by Desousae Wednesday, June 20, 2012 2:11 PM
    Monday, November 14, 2011 6:57 PM
  • Why does this problem occur in the first place, what makes the space visible one out of two places?
    I had this problem recently myself. I added 10 GB initially to a server, and had to add 1 GB extra in vmware to the disk, and after extending it twice in Disk Management, 11 GB of free space were visible in Windows Explorer. My solution to the problem was to add 1 GB extra.

    Does anyone know why it happens?

    By the way, I also saw the problem mentioned above "Windows is rounding to a slightly larger size than what's actually there "

    Friday, December 23, 2011 11:54 AM
  • Can you try following

    diskpart> sel par <par>



    Do let me know if it resolves the issue,




    Thursday, January 12, 2012 11:37 AM
  • Satish, I'm not sure about the original poster, but I was in a crunch on an Exchange server that had a full database (0% free space), and your fix solved my issue.  Much thanks!!
    • Proposed as answer by murphyslaw1978 Thursday, June 14, 2012 8:41 PM
    Thursday, June 14, 2012 8:41 PM
  • The other day my manager and I realized we needed to add more space to a particular drive.  He used the GUI to extend the drive after I allocated more space from vShpere, however it did not take.  He then mentioned that he ran into this issue some time ago and opened a console to use the DiskPart command.  This corrupted our drive and we had to run a check disk to repair the issue.  After the check disk ran, I tried to extend the drive, with the same results, only this time I did not try to extend again in the console.  After reading your comment I shrunk the drive and then added all but 5GB to the drive.  THIS WORKED.  It amazes me that MS has not fixed this calculation issue if it has been known for this long.


    Wednesday, June 20, 2012 2:10 PM
  • This solved the issue for me, thank you so much!!
    Thursday, February 21, 2013 3:41 AM
  • "DISKPART > extend filesystem" gave me the error "DiskPart has encountered an error. The device does not recognize the command.. See the system event log for more information. DiskPart successfully extended the filesystem on the volume." Except that there was no more information in the event log and DiskPart did not extend the filesystem.

    Using the Disk Management GUI to shrink the volume returned the error, "The parameter is incorrect."

    This fixed it for me:

    1. Defragment the drive.
    2. DISKPART > extend filesystem

    • Proposed as answer by reprac Thursday, March 14, 2013 5:25 PM
    Wednesday, February 27, 2013 2:55 PM
  • The 'extend filesystem' command also worked for me. No reboot required.
    Monday, July 15, 2013 2:51 PM
  • Hi,

    I had the same issue, I added 150GB to one of the drives but after extending the drive through disk management I didn't see the extra space I added, so following Desousae tip I just added another 10GB (probably could have done it with less)to the drive on the V-sphere and than extended through windows disk management but only added 9.5GB (in MB), finished the Wizard and than the extra 150 I added before appeared on the drive.

    Thursday, August 07, 2014 2:44 PM
  • I had this issue today with a Server 2008 SP2 server. I ran through the steps above and it didn't work for me. I did a defrag on the drive and I kept getting the "DiskPart has encountered an error. The device does not recognize the command." error. I got some advice to try the defrag again and this time it worked. Just thought I would share this as a resolution in case someone got here and had tried these steps. Defrag again and then try the extend filesystem in diskpart and it may work for you too. 
    Tuesday, August 12, 2014 3:07 AM
  • Though this thread is dated now but in my case what I had to do was a refresh of Disk Management console. Before the refresh, I closed and reopened the console but the extra space did not show up.
    Friday, January 09, 2015 4:22 PM
  • You must click the disk in he left panel with mouse's right button, then you just select rescan disks and the added space will appear. After this you can expand the disk and if you want to be 100% correct at first time, do not extend 100% but lower the amount a little bit (like 100 MB). Sometimes selecting all available new space for extend creates a situation described earlier in this thread.
    Friday, January 16, 2015 7:48 AM
  • I have been beating my head against the wall on this for a while.  This was perfect and worked like a charm.

    "If at first you don't succeed, get a bigger hammer."

    Wednesday, October 21, 2015 9:26 PM
  • Thanks Satish.... above command worked for me... :-)


    Manjunath B S

    Sunday, June 19, 2016 6:07 AM
  • Same here, Diskpart-->Select Volume and extend filesystem worked; but WTF, we are going backwards. It is not since 2003 server that I had to mess with diskpart to expand a disk.
    Tuesday, July 26, 2016 4:08 PM
  • Thanks Satish! This worked for me as well!


    Thursday, August 04, 2016 7:06 PM