locked
PXE-Boot with Hyper-V based on W2K12 R2 with Gen2-VMs RRS feed

  • Question

  • Dear Community,

    as you probably know the new R2-Version was advertised with the ability of PxE-booting with the synthetic instead of the legacy-nic which works with poor 100 mbit/s.

    Here´s the problem:

    When I create a new virtual machine with Gen2 without the option "Secure Boot" and PxE-boot it, I get the following error:

    Boot failed. EFI Network.
    Boot failed. EFI SCSI Device.
    No Operating System was Loaded. Press a key to retry the boot sequence

    When I create another new virtual machine with Gen2 but with the option "Secure Boot" and PxE-boot it, I get this error:

    Station IP address is x.x.x.x
    Server IP address is x.x.x.x
    NBP filename is pxelinux.0
    NBP filesize is 15888 Bytes
    Downloading NBP file...
    Successfully downloaded NBP file.
    Boot Failed. EFI Network. Failed Secure Boot Verification.
    Boot Failed. EFI SCSI Device
    No Operating System was Loaded. Press a key to retry the boot sequence

    When taking a look at the log of the TFTP-Server (TFTPD32) I get the same information regardless which way I do it. The only interesting thing it says is:

    "Peer returns ERROR <User aborted the transfer> ->aborting transfer"

    I have also tried to use another tool called Serva as TFTP/PXE-Server -> The error still occurs.

    Before anybody wants me to try to do it as Gen1 -> I know that this works, but I want to get it running under Gen2 since the synthetic one works (should work) much faster than the legacy-one.

    Really looking forward to get some useful information here.

    Thanks in advance !


    • Edited by GoProo Thursday, October 24, 2013 12:14 PM
    Thursday, October 24, 2013 12:13 PM

Answers

  • I am really wondering what technology you are using.

    Is your bootstrap image UEFI capable?  If it isn't you will get a very quick failure.

    just like with and installed disk, a UEFI disk won't boot non-UEFI and vice versa - PXE streaming des not change that


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    • Marked as answer by Elton_Ji Monday, November 11, 2013 4:41 AM
    Friday, October 25, 2013 12:59 PM

All replies

  • I ran into exactly the same issue yesterday and have not found the solution as of yet.

    This was to install Windows 8. As you stated, Gen1 works with no problems here as well.

    • Proposed as answer by _NoirFry_ Tuesday, October 24, 2017 1:31 PM
    Thursday, October 24, 2013 2:53 PM
  • I was about to ask what your client OS was.

    Have you tried R2 / 8.1 as the client?

    And, what is your streaming solution?  Simply straight TFTP?  Do you have DNS options 66 and 67 set?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, October 24, 2013 3:12 PM
  • Personally, I haven't upgraded my Server 2012 Hyper-V hosts to R2 yet.

    My test was performed on Win 8.1. The ISO image to install over PXE is Win 8 only.

    Streaming is TFTP with 66 and 67 enabled.

    Thursday, October 24, 2013 3:19 PM
  • It usually comes down to the bootstrap, and if that has the correct devices embedded in it.

    Most of my experience has been with WDS (little) or Provisioning Server (lots) when it comes to PXE.  And I have not tried this with the generation 2 VMs yet.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, October 24, 2013 4:09 PM
  • The thought just occurred to me.

    How did you create your VHD image that you are streaming?

    Tell us more about how you are set up and your assumptions.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Thursday, October 24, 2013 4:50 PM
  • I was about to ask what your client OS was.

    Have you tried R2 / 8.1 as the client?

    And, what is your streaming solution?  Simply straight TFTP?  Do you have DNS options 66 and 67 set?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Dear Brian,

    well, as this problem appears before you got any chance to choose which OS you want to boot, it doesn´t matter, which my client would be? Yes, I am using simple TFTP and do you mean the DHCP-Options 66 and 67? Yes, those are set.

    It works in general, since I can PxE-boot the machines when I use Gen1.

    Friday, October 25, 2013 9:22 AM
  • I am really wondering what technology you are using.

    Is your bootstrap image UEFI capable?  If it isn't you will get a very quick failure.

    just like with and installed disk, a UEFI disk won't boot non-UEFI and vice versa - PXE streaming des not change that


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    • Marked as answer by Elton_Ji Monday, November 11, 2013 4:41 AM
    Friday, October 25, 2013 12:59 PM
  • Dear Brian,

    first of all, thanks for your assistance :)

    Actually this sounds right to me, nevertheless I can´t really answer you the question. I´m not into UEFI at all, never had to handle that before.

    Maybe it helps if I describe you what our PxE is doing.

    You start a machine booting over it´s NIC -> it starts the pxelinux.0-file (is that one UEFI-capable?) -> afterwards we get a menu to start two different installations (the last two steps are not working since we get the error before that)

    So if the pxelinux.0-file ain´t UEFI-capable (i think that is the case), do you know any alternatives that could work?

    Best regards !


    • Edited by GoProo Monday, October 28, 2013 10:52 AM
    Monday, October 28, 2013 7:32 AM
  • Hi GoProo,

    May be you need to get some help about UEFI Boot  from linux forum .

    And hope the following link is helpful:

    https://wiki.ubuntu.com/UEFI/PXE-netboot-install

    RGDS

    Wednesday, October 30, 2013 2:52 AM
  • Same problem here. But when I reinstall wds role in standalone mode - the issue is gone. It doesn't work in integrated mode only.

    Vadim

    Wednesday, October 30, 2013 7:51 AM
  • I had exactly the same problem here.

    My solution was to set up the correct entry in DHCP Option 67 on my DHCP Server.

    The DCHP Option 67 is the Boot File Name. You have to enter the EFI boot file name.

    In my case it was Boot\x64\wdsmgfw.efi . I entered this and restart the DHCP Server. Now my Gen2 VMs could succesfully boot by PXE.

    • Proposed as answer by kzizo Sunday, March 2, 2014 7:22 PM
    Sunday, December 8, 2013 7:59 PM
  • In Hyper-V Manager

    Select VM and go to settings. Click Firmware and then un-check the "Enable Secure Boot" option.  Apply are start the VM and it should at least remove the "Failded Secure Boot Verification error.

    • Proposed as answer by Aspenglade Friday, May 22, 2015 3:23 PM
    Sunday, December 22, 2013 3:52 PM
  • First of all, sorry for my English. I used the same solution, but it's like a temporary one. If I have not only EFI machines in the network, it doesn't work. To resolve this problem, I've added policy (for EFI machines, filtered by MAC) to DHCP. It works fine, but very inconvenient. I hope MS give us some more clear solution.

    Vadim

    Tuesday, December 24, 2013 2:13 AM
  • This question was completely answered by Andy here: http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/4098e57f-c6da-493a-a772-87d60ee1d0a1/#b2808adb-a79e-49e6-8a00-2c324c3e41d1

    He wrote:

    "Apparently, there is an issue in WDS that causes it to use legacy NetBIOS name resolution instead of DNS to find a domain controller, and it impedes domain controller connectivity. The solution is simple - go to TCP advanced properties on WDS server, and on WINS tab disable NetBIOS over TCP/IP. This forces WDS to use the right name resolution, and everything works perfectly."


    I can confirm it. Works perfectly! Thanks to Andy!


    Vadim



    • Edited by treckamerica Thursday, March 6, 2014 6:51 PM
    • Proposed as answer by G. Kjono Wednesday, September 3, 2014 1:21 PM
    Thursday, March 6, 2014 6:46 PM
  • Sorry for the late reply.

    Thank you guys for the assistance.

    Best regards

    Tuesday, October 7, 2014 11:38 AM
  • In Hyper-V Manager

    Select VM and go to settings. Click Firmware and then un-check the "Enable Secure Boot" option.  Apply are start the VM and it should at least remove the "Failded Secure Boot Verification error.

    Fixed it for me! Thanks!
    Friday, May 22, 2015 3:23 PM
  • It's working for me now.

    Boot\x64\wdsmgfw.efi

    Tuesday, March 1, 2016 11:45 PM
  • This question was completely answered by Andy here: http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/4098e57f-c6da-493a-a772-87d60ee1d0a1/#b2808adb-a79e-49e6-8a00-2c324c3e41d1

    He wrote:

    "Apparently, there is an issue in WDS that causes it to use legacy NetBIOS name resolution instead of DNS to find a domain controller, and it impedes domain controller connectivity. The solution is simple - go to TCP advanced properties on WDS server, and on WINS tab disable NetBIOS over TCP/IP. This forces WDS to use the right name resolution, and everything works perfectly."


    I can confirm it. Works perfectly! Thanks to Andy!


    Vadim



    I can confirm, this solved my problem as well. Thank you Andy :)
    Thursday, April 27, 2017 3:42 PM
  • I don't understand where to do this at?  You say to do this on your DHCP server.  We have DHCP running on our domain controller.  I'm not seeing where to enter this at... please advise.
    Tuesday, June 6, 2017 12:31 AM
  • I don't understand where to do this at?  You say to do this on your DHCP server.  We have DHCP running on our domain controller.  I'm not seeing where to enter this at... please advise.

    If you are referring to the NetBIOS setting, it's in the WDS server's TCP settings in the NIC.

    If you are referring to the DHCP option to add SMSBoot\x64\wdsmgfw.efi, that's on your DHCP server.


    What worked for me is making the Boot File SMSBoot\x64\wdsmgfw.efi.  Notice the SMSBoot instead of just boot.  I'm running SCCM 1606.  Hope that helps someone.


    Wednesday, June 14, 2017 7:22 PM
  • I had the same issue with WDS Hyper-V and Gen2 server 2016 VMs.

    My DHCP and WDS servers run on different boxes so had set both options 66 to WDS FQDN and 67 to Boot\x64\wdsnbp.com

    Changing the DHCP option 67 to Boot\x64\wdsmgfw.efi solved my problem


    • Edited by bebbho Saturday, February 9, 2019 2:34 PM
    • Proposed as answer by RichardParry Tuesday, November 26, 2019 9:33 PM
    Saturday, February 9, 2019 2:34 PM