Ethernet Controller not Recognized


  • I've tried unsuccessfully for the last 24 hours to get a clean installation of WSE.  The installation process fails because it cannot establish a network connection.

    This is a new DIY system with the following components:

    ASUS Maximus V Extreme Motherboard, BIOS 1402 (or most current)
    32GB RAM
    750GB Primary HD (SATA)
    3 x 3TB Secondary HDs (SATA)
    1 DVD-RW
    1200W Power Supply

    I've downloaded the current drivers (chipset, BIOS, LAN) from ASUS.

    I've also scanned the ASUS and Republic of Gamer (ROG) support sites. It seems like there may be some issues with this motherboard, but not certain.
    Also not clear of any solutions are available.

    Oddly enough, the light on the Ethernet port is illuminated.  However, device manager doesn't recognize it.

    Any new suggestions short of RMA the motherboard?

    Monday, December 03, 2012 4:07 PM


All replies

  • Get PCI vendor ID and Device ID from Device Manager (should be "unrecognized device" node in any case) and Google for who's actually made the controller ASIC. You'll definitely find a drivers on OEM site.

    StarWind iSCSI SAN & NAS

    Tuesday, December 04, 2012 10:00 PM
  • Ah, the joys of DIY computers!  This is one reason why Microsoft has a logo-certification program - to ensure that all the components work for server installations.  You may have created a system that can't run Windows Server without some modifications.

    I don't quite understand why you are getting an installation failure because of no network connection.  I have installed 2012 many times without having a network connection.  Once the system is installed, I install a network driver.  So you may be running into a problem with the motherboard itself.  And without the proper BIOS to support Windows Server 2012, there is not much you can do.  Looking at I do see that ASUS does have one system that they have certified for Windows Server 2012, but it has a Z9PR motherboard with totally different BIOS version than what you are showing.

    Wednesday, December 05, 2012 4:00 PM
  • On Wed, 5 Dec 2012 16:00:22 +0000, TimCerl wrote:

    I don't quite understand why you are getting an installation failure because of no network connection.

    I believe that the OP is trying to install Windows Server Essentials, hence the WSE in the original post. Like Windows Home Server 2011 before it, Essentials requires a valid functioning network connection to complete the install process.

    Paul Adare
    MVP - Forefront Identity Manager
    My computer NEVER cras...DOH!

    Wednesday, December 05, 2012 6:00 PM
  • Hi,

    Thank you for the post.

    I agree with Paul, before you install windows server 2012 Essentials, you should ensure your computer meets the minimum hardware requirements and prepare your network as per this link:


    Nick Gu - MSFT

    Thursday, December 06, 2012 2:41 AM
  • Windows Server 2012 (maybe starting in Windows Server 2008) requires specific motherboards with onboard NIC to be certified.  If the board is not designated as a server board, the NIC won't work.  The workaround solution is to purchase a NIC and place in an available slot.

    This solved my problem.

    Friday, December 28, 2012 7:16 PM