WDS PXE-E32: TFTP open timeout


  • server 2008 sp2, running dhcp/wds, also a domain controller.

    server was working yesterday... today ran windows update, rebooted, and later in the day received report that it was not working: WDS PXE-E32: TFTP open timeout

    whats the deal?
    Friday, November 13, 2009 8:33 PM


All replies

  • removed, then reinstalled the WDS server role. Its working again.
    Friday, November 13, 2009 10:40 PM
  • Do you have DNS also installed?
    Saturday, November 14, 2009 2:02 AM
  • yes, AD integrated forward lookup zone for the AD domain that the WDS machine is a domain controller for.... the AD domain is only for deployments, nothing else. In fact ADDS is only installed because, sadly, it is a requirement for WDS. I really wish it wasn't.
    Monday, November 16, 2009 5:54 PM
  • In Server08R2, you can use the PXE provider in the transport server role to remove the dependacy on AD. See for more details.

    With DNS and WDS running on the same machine, you can randomly have issues when the DNS port range and the WDS port range overlap.  This is due to a security fix in DNS that causes the DNS process to bind to 2500 ports at once. Some of the known issues with this DNS fix are tracked here:

    Take a look at this KB:
    Monday, November 16, 2009 8:13 PM
  • thanks for that info, greatly appreciated.
    Friday, November 20, 2009 1:16 PM
  • Incresing UDP ports worked like charm. service is running perfect now.

    Thanks for info. appreciate.

    Friday, June 03, 2011 12:58 AM
  • Hi All - 

    I'm late to the party on this one.  But I recently built a WDS Server using images I created from deployment workbench.  I'm trying to get the PXE Boot option to work, but the farthest I get is that the client receives the IP, and then the TFTP Timeout error occurs.  I'm a rookie at using WDS.  What should I be checking as to the causes of the TFTP Timeout error I'm getting.  

    I'm not sure if I'm using the right Boot file.  I have option 66 enabled and 67 using the bootfile I think I should be using.  Anyway, any suggestions would help.  I've tried many of the steps here.  Also, if a moderator could point me to the right thread if this thread is closed. 

    Monday, February 04, 2013 9:10 PM
  • I have the same issue and am not sure what to do at this point.
    Friday, June 14, 2013 6:26 PM
  • restart DNS service after restart WDS service instead of remove WDS role, and f***kup all of the settings...

    It worked for me.

    Monday, May 08, 2017 12:48 PM