GPP - Power Settings (for XP)."Always show icon on taskbar" is unavailable


  • Scenario:

    -Server 2003 domain, with ADMX files in place and functioning.

    -Using Vista SP1 with /Remote Tools installed to manage GPO's/GPP's

    -XP SP2 client, with xmlLite/CSE patch installed, and functioning


    I've set up a GPO with the new Group Policy Preferences power settings.


    Two items I cannot get to work:


    1. Create a new power scheme and set as active power scheme.

     - Using "Create"  and making up a name for my scheme, my XP box will not even show the new power scheme, let alone set it as default. 

     - Using "Update" and "Laptop/Portable" I can get it to work.... the GPP settings will be set properly (however, I would like to create my own name for support purposes, so I can quickly tell from a remote end user if the policy has applied properly).


    2) This issue is seemingly a catch 22.

    - Create a new "Power Options (Windows XP)" setting... can enable all settings EXCEPT "Always Show icon in the taskbar"... which is grayed out.  Tried F5 (pushed really hard on it!!! LOL).... nothing to get it to activate.  So.....Vista SP1 is a requirement in order to even see the GPP's.... yet in Vista, this setting is no longer tied to the power settings but to the taskbar itself.  Is that why it is grayed out?




    anyone else experiencing this?

    Wednesday, May 07, 2008 9:18 PM


  • In both cases you need to be using User Policy instead of Computer Policy. The "Always show icon in the taskbar" is only enabled for Power Options when under User Policy because the setting only exists in the user hive of the registry. The custom theme you had created probably did apply, but to the machine area of the registry, which would only effect new users or the default user. The Power Scheme extension under User Policy controls the current user or existing users. Try creating a custom power theme there and put it in Update mode (this will create the theme if it does not exist).

    Wednesday, May 21, 2008 7:18 PM