none
Forum FAQ: VSS System Writer is missing.

    General discussion

  • Symptom

    System state backup failed with the following error message:

    "System writer is not found"

     

    In addition, when you run the “Vssadmin list writers” command to display VSS writers on the system, the System Writer is missing.

     

    Cause

    The system writer fails due to the fact that the trusted installer & system accounts are missing permissions to files in the directory %windir%\winsxs\filemaps\.

     

    Resolution

     

    To resolve this issue, please run the following commands from an administrative elevated Command Window:

     

    CD c:\windows\system32

    Takeown /f %windir%\winsxs\filemaps\* /a

    icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"

    icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)"

    icacls %windir%\winsxs\filemaps\*.* /grant "BUILTIN\Users:(RX)"

     

    Applies to

     

    Windows Server 2003, Windows Server 2008

    Monday, February 22, 2010 8:06 AM

All replies

  • Hi,

     

    I have an issue where I am missing the system writer on on my Win2k3 box.  I ran the above commands and I get, "System cannot find the file path specified."  i.e there is no filemaps folder. 

     

    Please help. 

    Thanks

    Wednesday, September 29, 2010 10:55 PM
  • Hi,

    Please try to run the following cmd's for windows 2003 server

    net stop cryptsvc

    net start cryptsvc

    Please let us know if you face any issue. this will list System writer for a 2003 server

    Thanks

    Sunday, March 13, 2011 4:46 PM
  • Thanks! I had the same issue on a Win2k box and I fixed it using your suggestion. 

    One thing, after restarting the Cryptographic Services service I had to restart the Windows Management Instrumentation also as the WMI Writer was now missing :)

     

    Thanks again!!

    Wednesday, August 10, 2011 1:37 PM
  • Hi!

    What can I do, if the folder %windir%\winsxs\filemaps is missing on my 2003 Server?

    I have the exact problem described above, but browsing through the folder WinSxS, I cannot find the filemaps folder...


    Freddy

    Thursday, July 19, 2012 2:25 PM
  • I have the same issue, no filemaps folder. Does anyone have a solution for this?

    -NerdyCrook

    Tuesday, July 24, 2012 8:51 PM
  • Quite a long time later, but this applied to my Windows 2012 RDS Server, when backing up through Backup Exec 2012 SP2. System and WMI writers were missing and the above fixes and a reboot was required to get this working.
    Monday, September 30, 2013 8:26 AM
  • Yes the Above does work for Windows Server 2008

    And i have some steps to share which i have used to fix vss issue fix on windows server 2003 without rebooting the Server...

    Have a look on the Link http://aikitsupport.com/fix-vss-errors-windows-server-2003/ and share your views thanks

    Regards

    Joy Banerjee

    Thursday, January 02, 2014 3:07 PM