none
Password complexity RRS feed

  • Question

  • How do I configure password complexity on a standalone server 2008 R2 core? I notice the net accounts command doesn't seem to have a complexity parameter. many thanks.
    Tuesday, February 9, 2010 1:50 PM

Answers

  • The Password complexity is a Local Policy setting named "Passwords must meet complexity requirements" under Computer Configuration/Windows Settings/Security Settings/Account Policies/Password Policy.

    In a Server Core installation there is no graphical user interface to set this policy.
    Instead use secedit to import and export the security settings from a Full Installation of Windows Server 2008.
    1. First export your security configuration using the following command:

      secedit /export /cfg C:\securityconfig.cfg
        
    2. Then open notepad.exe and edit the C:\securityconfig.cfg file.
      Under [System Access] you should find PAssword complexity = 1
      Change the value to 0 and save the file.
       
    3. Then fire up the next command to import the configuration:

      secedit /configure /db C:\Windows\security\new.sdb /cfg C:\securityconfig.cfg /areas SECURITYPOLICY

     

    Tuesday, February 9, 2010 5:26 PM

All replies

  • The Password complexity is a Local Policy setting named "Passwords must meet complexity requirements" under Computer Configuration/Windows Settings/Security Settings/Account Policies/Password Policy.

    In a Server Core installation there is no graphical user interface to set this policy.
    Instead use secedit to import and export the security settings from a Full Installation of Windows Server 2008.
    1. First export your security configuration using the following command:

      secedit /export /cfg C:\securityconfig.cfg
        
    2. Then open notepad.exe and edit the C:\securityconfig.cfg file.
      Under [System Access] you should find PAssword complexity = 1
      Change the value to 0 and save the file.
       
    3. Then fire up the next command to import the configuration:

      secedit /configure /db C:\Windows\security\new.sdb /cfg C:\securityconfig.cfg /areas SECURITYPOLICY

     

    Tuesday, February 9, 2010 5:26 PM
  • Perfect, much appreciated.

    John
    Wednesday, February 10, 2010 11:12 AM
  • Perfect it's really working, much appreciate.

    Sandeep Oak


    Sandeep Oak
    Thursday, June 3, 2010 11:58 AM