none
RDP Port 3389 not listening RRS feed

  • Question

  • We have windows server 2012 R2 standard. We are facing issue with the server is not responding to RDP. While checking on the server could see that its not listening on port 3389. However if i try to telnet another server in the network on the port 3389 its working fine. Would need help on this issue. 
    Thursday, November 30, 2017 3:52 PM

All replies

  • While checking on the server could see that its not listening on port 3389

    I'd check that the Remote Desktop Services (TermService) service is started.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Thursday, November 30, 2017 4:00 PM
  • Hi,

    Have you checked that whether RDS services are running?

    If yes, I suggest you check for RDP listening port under registry

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\PortNumber

    If the port is changed, the new port needs to be specified (connecting as servername:portnumber) upon RDP connection.

    Please let us know if the issue persists.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, December 4, 2017 1:32 AM
    Moderator
  • Hi,

    Are there any updates at the moment?

    Best Regards,
    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 6, 2017 7:08 AM
    Moderator
  • I had the same problem after a migrating a Windows Server 2008R2 (p2v), my resolution may work for you:

    The problem occurs because the RDP service tries to use the old network adapter. 

    After some hours of google, I found this option in registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    Change the "LanAdapter" value from "1" to "0", to allow RDP in all network adapters.

    Reboot the system and test.

    I hope it helps.


    • Edited by Canove Sunday, May 20, 2018 4:33 PM
    • Proposed as answer by AT3 Friday, August 30, 2019 5:16 PM
    Sunday, May 20, 2018 4:32 PM