none
Time zone not recognized on Windows Server 2008 R2 RRS feed

  • Question

  • OS: Windows 2008 R2 (Ent.) terminal server (No upgrade from an earlier version and all the latest patches and updates are installed)

    Problem:
    Time zone keeps changing after installing (in our case) the Dutch language pack. The time zone switches to "(UTC -12:00) Dateline Standard Time" and an error "Your current time zone is not recognized. Please select a valid time zone...."

    Changing the time zone under an administrator account doesn't work (as suggested in link). Tried both manually and with the tzutil -command. It works for a while, but after a few minutes it changes back.

    When I change the language back to default (English). The problem does not excist.

    Can someone please help us...

    Monday, October 29, 2012 9:54 AM

Answers

  • Hi,

    Have you tried to restore Windows Time service on local computer to default settings to see if the issue still persists?  Please refer to the following steps to restore Windows time service.

    To restore Windows Time service on local computer to default settings

    1. Open a Command Prompt.
    2. Type the following command and then press ENTER:

                net stop w32time

    1. Type the following command and then press ENTER:

                w32tm /unregister

    1. Type the following command and then press ENTER:

                w32tm /register

    1. Type the following command and then press ENTER:

                net start w32time

    Here is the article about time configuration in a Windows domain as reference, hope this helps.

    Time configuration in a Windows Domain

    http://msmvps.com/blogs/mweber/archive/2010/06/27/time-configuration-in-a-windows-domain.aspx

    Best Regards,

    Andy Qi

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Tuesday, October 30, 2012 9:08 AM
    Moderator