locked
Cannot install SQL Server 2005 Service Pack 2: Unable to install windows installer msi file RRS feed

  • Question

  • Here is the error message from the summary.txt file:

    Product Installation Status
    Product                   : Setup Support Files
    Product Version (Previous): 2047
    Product Version (Final)   : 
    Status                    : Failure
    Log File                  : C:\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\Hotfix\Redist9_Hotfix_KB921896_SqlSupport.msi.log
    Error Number              : 1260
    Error Description         : MSP Error: 1260  Windows cannot open this program because it has been prevented by a software restriction policy. For more information, open Event Viewer or contact your system administrator.
    

    I have already installed service pack 1 without issue and am not aware of any software restriction policies that have been put in place. I installed SQL Server 2005 recently with service pack 2 (on the same server) and did not come across this problem before so I am a bit confused.

    Friday, August 22, 2014 12:43 PM

Answers

  • The GPO message turned out to be a complete red herring. Here's how I resolved it:

    Go to the Add or Remove Programs section of Control Panel and remove the SQL Server Setup Support Files.

    Browse to C:\Program Files\Microsoft SQL Server\90\Setup Bootsrap\Cache\SQLSupport\x86\1033 and run SqlSupport.msi

    Run the Service Pack 2 installer again, the Setup Support Files should show status 'Upgraded' on the feature selection page. The rest of the installation should complete successfully.

    I hope this helps!


    Tuesday, September 2, 2014 11:38 AM

All replies

  • Hi

    Sounds like you have a GPO preventing you from installing this. 

    http://technet.microsoft.com/en-us/library/cc737011(v=ws.10).aspx


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Frank Shen5 Tuesday, September 2, 2014 3:43 AM
    • Unmarked as answer by Alex Shallcross Tuesday, September 2, 2014 11:59 AM
    Friday, August 22, 2014 2:54 PM
  • The GPO message turned out to be a complete red herring. Here's how I resolved it:

    Go to the Add or Remove Programs section of Control Panel and remove the SQL Server Setup Support Files.

    Browse to C:\Program Files\Microsoft SQL Server\90\Setup Bootsrap\Cache\SQLSupport\x86\1033 and run SqlSupport.msi

    Run the Service Pack 2 installer again, the Setup Support Files should show status 'Upgraded' on the feature selection page. The rest of the installation should complete successfully.

    I hope this helps!


    Tuesday, September 2, 2014 11:38 AM
  • Hi Alex,

    Thanks for coming back to us and sharing the solution with us.

    Best regards,

    Frank Shen

    Wednesday, September 10, 2014 8:24 AM
  • This worked but the .MSI file was not even there to upgrade. I had to get it from a different box, then followed these steps. Thanks.
    Friday, November 21, 2014 6:57 PM
  • the solution not work for me .
    1. I can't find C:\Program Files\Microsoft SQL Server\90\Setup Bootsrap\Cache\SQLSupport\x86\1033\SqlSupport.msi

    2. without support tools, SP3 installation failed. TOO

    Monday, December 15, 2014 8:22 AM
  • I didn't have it as well but you can find it by extracting the contents of SP file, so execute

    PathandNameOfSPfile /extract

    Under that path you will have the folder 'hotfixsqlsupport\files' and the sqlsupport.msi is there. Execute it after removing the Support Files from the Add/Remove programs.

    After that, execute again the SP and you should apply it successfully.


    • Edited by Apposai Wednesday, July 8, 2015 8:26 AM
    Wednesday, July 8, 2015 8:25 AM
  • Hello Alex,

    Wanted to say thanks for your solution, it brought me to the resolution for the following errors during the MSSQL Server 2005 Service Pack installation. I decided to describe the procedure in some  more detail since it cost quite a bit of time to resolve this darn problem, and this might help others...

    PROBLEMS / ERROR MESSAGES

    (During SP2 installation attempt): A recently applied update, KB921896, failed to install

    (During SP4  installation attempt): A recently applied update, KB2463332, failed to install

    The general idea here is related to the SqlSupport.msi file and the fact that it needs to be upgraded to the SP4 version.

    I successfully resolved the issue as follows:


    1.

    Uninstall the ‘Microsoft SQL Server Setup Support Files (English)’ through Add/Remove programs.  (NOTE: This is the SP0 version that we need to replace by the SP4 version)

    2.Download SP4 from MS and locate the SP4 setup file locally

    E.g. For SP4, the file name is 'SQLServer2005SP4-KB2463332-x86-ENU.exe'

    3.Extract the files in SP4:

    -          Open the command prompt (cmd.exe)

    -          Navigate to the folder in which the SP4 file is located

    Cd D:\INSTALL\Microsoft SQL Server 2005 - SP4

    -          Run the following command to extract the files in the SP4-file:

    SQLServer2005SP4-KB2463332-x86-ENU.exe /x

    -          Extract to a temporary folder, e.g. the following folder:

    D:\INSTALL\Microsoft SQL Server 2005 - SP4\temp

    4.  Locate the SqlSupport.MSI installer    (SP4 version)

    E.g. D:\INSTALL\Microsoft SQL Server 2005 - SP4\temp\hotfixsqlsupport\files

    5.Install SqlSupport.MSI (SP4 version) from this folder.

    6.Restart the original installation by using the SP4 installation setup file.

    NOTE: The ‘Setup Support Files’ now shows status ‘Upgraded’, since it has been upgraded already to the SP4 version. Therefore, the installer will skip installation of the SqlSupport.MSI file.

    7.That's it !  The installation of SP4 now completes successfully !




    • Edited by mroset Sunday, July 19, 2015 11:41 PM more text changes
    • Proposed as answer by HangTeChen Monday, August 10, 2015 5:02 AM
    Sunday, July 19, 2015 11:30 PM
  • Thanks a lot, Your workaround saved me a lots of time
    Friday, October 9, 2015 8:29 PM
  • Work fine in my case.

    Congratulations for the solution.

    Reguards,

    Dalmo Junior

    Friday, October 6, 2017 12:44 PM
  • The GPO message turned out to be a complete red herring. Here's how I resolved it:

    Go to the Add or Remove Programs section of Control Panel and remove the SQL Server Setup Support Files.

    Browse to C:\Program Files\Microsoft SQL Server\90\Setup Bootsrap\Cache\SQLSupport\x86\1033 and run SqlSupport.msi

    Run the Service Pack 2 installer again, the Setup Support Files should show status 'Upgraded' on the feature selection page. The rest of the installation should complete successfully.

    I hope this helps!


    I did not find SqlSupport.msi in the path you referenced.  So I did a search and found it in a temp location  whose path looked like this: 

    D:\639466405392a35d0d2c4412\hotfixsqlsupport\files\sqlsupport.msi

    After removing and reinstalling sqlsupport.msi, SQL-2005 SP4 installed OK.

    I know this is an old thread, but maybe some poor govbernment worker who is supporint very old servers and systems may need this.  It help me get through my day!  Thanks.

    Tuesday, February 6, 2018 12:31 AM
  • @mroset Thanks a lot! You saved my day! :)

    There is no knowledge that is not power.


    • Edited by JohnyL Saturday, March 31, 2018 12:45 PM
    Saturday, March 31, 2018 12:45 PM
  • Problem

    Installation or upgrade of Application Control and Change Control fails with the following error; however, no software restriction policy is configured on the system:


    • Click Start, Run, type regedit, and then click OK.
    • Navigate to and then click the following subkey in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer.
    • From the Edit menu, select New, DWORD Value.
    • Type SecureRepairPolicy for the name of the DWORD, and then press ENTER.
    • Right-click SecureRepairPolicy, and then click Modify.
    • In the Value data box, type 2, and then click OK.
    • Navigate to and then click the following subkey in the registry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer.
    • From the Edit menu, select New, Key.
    • Type SecureRepairWhitelist for the name of the key, and then press ENTER.

    Open the Event Viewer and find the Application event where the install failed and open the Even Properties (The source will most likely be MsiInstaller)

    Copy the Data text under Bytes out to notepad:

    e.g:

    0000: 7b 31 38 43 35 41 36 35   {18C5A65

    0008: 42 2d 30 41 33 39 2d 34   B-0A39-4

    0010: 30 42 35 2d 42 39 35 38   0B5-B958

    0018: 2d 36 33 30 35 35 41 46   -63055AF

    0020: 41 42 36 35 43 7d         AB65C}

    The highlighted values in green are the string value you require. Remove all the other text and put the values together.

    In this case:  {18C5A65B-0A39-40B5-B958-63055AFAB65C}

    • In the registry Double-click the SecureRepairWhitelist key to open it.
    • From the Edit menu, select New, String Value. Type {432DB9E4-6388-432F-9ADB-61E8782F4593} as the string value. Exit the Registry Editor.

    THis should work for this install and can be applied to any other installs you have a problem with that are prevented by the software restriction policy bug.

    • Proposed as answer by Findlay90210 Friday, July 6, 2018 9:07 AM
    Friday, July 6, 2018 9:07 AM
  • I had tried everything else from this thread and others, but this is what solved it for me. Thanks!
    Tuesday, July 31, 2018 6:08 PM