none
Intel 1000/Pro - VLAN not working. Any idea? RRS feed

  • Question

  • Hello,

    after all the trouble we had with getting our Realtek drivers not to crash our "servers" (call that: our lab), we now got an Intel Pro 1000/GT for it. I try to move the VM's over now...

    * I renamed the old Virtual Network. It will be taken out of service, the Realtek card being used only for managing the server.
    * I put the Intel card in physically. It went and installed MS drivers. I updated (using Device Manager) to a downloaded driver, version 8.3.9
    * I created a new virtual network.
    * I removed all bindings on the created virtual network entry - no IPv4, no IPv6 etc., as this is only to be used for the virtual machines.

    No settings were changed for the driver.

    I am slowly moving virtual machines over. Those who are using the "default VLAN" find their network - I do not even have to turn them off - I can rehook them to the new virtual network, and after a short doiwntime (1-2 pings lost) the thing sorts out - as it should.

    Those which ARE using VLAN's are not working. As in: NOT working. If I move them back to the old network, I get connectivity. If I move them to the Intel based network -  I have none.

    Any other settings I need to change on the driver?
    Monday, June 16, 2008 11:43 AM

Answers

All replies

  • Ok, it looks like the **** inten network card driver is not working properly with VLAN's. Seems oyu have to create virtual NIC's (which is nice - sucks - seriously - I want this handled in Hyper-V, not have to think about which virtual network card I want on which server), as the driver strips out the VLAN tag and filters that.

    There seems to ahve been a KB article by MS how to fix the driver. KB951006 sadly is nowhere to be found anymore.

    What google still knows about it seems to indicate exactly my problem. Sadly, it WAS pulled.

    Anyone knows how to fix that? I COULD go the virtual network way, but I seriously do not want it if possible. This means another 2 network connections for every vlan, and it means having to manage a dozen or so VLAN's on a level where it is just inconvenient.
    Monday, June 16, 2008 12:46 PM
  • I think the article stated that you should set the VLAN ID to something other than 0 (like 1) on physical nic (the one with the VM Switch protocol only enabled).
    Monday, June 16, 2008 5:12 PM
  • Hm. How do I do that with only the drivers installed (i.e. via update in device manager, not having the toolkit installed - I would prefer to keep it that way (but will install it if I have to).
    Monday, June 16, 2008 6:56 PM
  • Open the properties of the physical network card.
    Click the Configure Button
    Select the Advanced Tab
    You may see the VLAN or VLAN ID field here.  If so, enter 1.

    Monday, June 16, 2008 7:40 PM
  • Ah, that is how you do it.

    Sadly - not on Intel 8.3.9 drivers. No such entry exists. The ONLY VLAN entry I have is "Priority & VLAN" which has entries for "Enabled, VLAN only, Priority Only, Disabled.

    No way to enter a value anywhere.
    Monday, June 16, 2008 7:55 PM
  • Why are you using the 8.x series of drivers for the Pro/1000GT? Version 13.0 is available from http://www.intel.com/
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, June 17, 2008 4:10 PM
  • ____. Seriously, I looked for download drivers and that is what I found. I look now and there are v13 drivers for 2008 x64. Now THAT explains. I will upgrade my drivers tomorrow morning.

    Thanks ;)
    Tuesday, June 17, 2008 5:15 PM
  • How am I supposed to install that driver?

    I downloaded the 13 pack, uninstalled it. Then I let Windows look for a driver (update from device manager), it finds some. Update (have disc) - the same driver stays in.

    I updated tons of drivers like that - now it seems I am stuck with a 8.3.9 one?
    Tuesday, June 17, 2008 8:52 PM
  •  Determine the driver file used from the driver properties.  Delete the nic device(s) in device manager that use this driver and then delete this file and the copy of it located in the drivers cache folder .  Rescan devices and provide the new driver for the nics.

    -or-

    Update the driver, select the option to specify the location, select the option to show all compatible drivers and/or browse to the new driver and updates each nic this way.

    If you have an Intel network package installed, it may help to uninstall this first.
    • Edited by millertime78 Wednesday, June 18, 2008 4:34 AM clarity
    Wednesday, June 18, 2008 4:33 AM
  • Done.

    Changed nothing.

    EIther the 1 pack contains that driver, or 8.3 is so stuck in the system I do not know what to do.

    * Went into safe mode, uninstalled the device, maunally deleted the drivers -> same come back when I manually upgrade from device manager.

    I even went in and installed the whole intel pack - now I can at least set up virtual network cards for vlan's.

    But no, still the 8.3 driver.
    Wednesday, June 18, 2008 7:59 AM
  • Is a clean install out of the question?  Sorry, it sounds like AOL must have developed that installer  : )
    Wednesday, June 18, 2008 7:46 PM
  • This thread may have some of the VLan Answers you need
     http://forums.technet.microsoft.com/it-IT/winserverhyperv/thread/cb771a3a-870d-4771-8658-97f0dcc47672/

    Specifically by MikeLascha
    The Intel's were a tougher nut to crack as the settting is not exposed through the NIC's Advanced Properties, but only through the registry .  Changing the HKLM\SYSTEM\CurrentControlSet\Control\Class\{GUID}\XXXX\VlanFiltering registry key (where {GUID} is the GUID containing the network adapter configuration and XXXX is the NIC to be confgured) from 1 to 0 and rebooting corrects the issue.  The easiest way to find the proper key in your system is to use the find command in regedit with enough of the network adapter name (i.e. for the Intel's, find "1000 PT").
    Identifying a registry key to enable this support actually turned out to be a plus since I was able to use it to get VLAN support working in server core.  So now I can use the Broadcom’s as originally planned (for host and cluster NIC’s), and the Intel’s for VM public and/or iSCSI connectivity.

    JM
    • Proposed as answer by oyvindskj Monday, December 30, 2013 9:36 AM
    Thursday, June 19, 2008 7:57 PM
  • A clean install is out untill all other options have been checked, I am sorry ;)

    If I am going to stay with intel, I need this cleard - I can not reinstall a server every time I plan to upgrad the nic driver.

    Anyone has a list of ALL locations the driver dll's are stored? So I can actually UNINSTALL Them "the hard way", complete ;)
    Friday, June 20, 2008 7:55 AM
  • Got it working.

    Uninstalled the Intel drivers, went back to the ones from Microsoft.

    The FilterVLAN key appeared and - well - after changing it it now works flawless, as it seems (i.e. no server crash or freeze).

    If that sticks on for another week, we will buy Intel cards for the other test servers, too.

    Thanks for the help.
    Tuesday, June 24, 2008 9:30 AM