Unable to Connect to Guest Console (Virtual Machine Connection) via Hyper-V Console


All replies

  • I have never heard of this before - but what you are describing is basically that WMI is working just fine - but we cannot connect over RDP to the virtual machine.  Cn you have a look in the event logs under "Application and Services Logs" --> "Microsoft" --> "Windows" --> "Hyper-V VMMS" --> "Admin" and see if there are any entries that talk about the RDP listener?
    Benjamin Armstrong
    Windows Virtualization
    Senior Lead Program Manager

    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.
    Friday, January 23, 2009 5:34 AM
  • i can connect to the guest VM using RDP, but i am unable to connect using the Hyper-V console.  It just sits there for a couple of minutes before it returns the errors listed above. 

    I can see the guest status in the console via the preview at the bottom.  Nothing in the Event logs you mentioned.  Is there a way to turn on some debugging for the console?



    Monday, January 26, 2009 1:33 PM
  • Just to check - are you logging into your computer with a smart card or biometric device?
    Benjamin Armstrong
    Windows Virtualization
    Senior Lead Program Manager

    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.
    Tuesday, January 27, 2009 5:59 AM
  • No smart card or biometric device.  I have noticed that after repeated retries (3-5 min) in between each retry it does finally connect in the Hyper-V Console Virtual Machine Connection.  It took me almost 20 min just to finally get the Hyper-V console Virtual Machine connection to connect to the Guest.

    Does the Hyper-V Virtual Machine Connection use RDP?



    Tuesday, January 27, 2009 2:49 PM


    You can connect to the guest VM using RDP, so the VM is working properly.

    I guess the problem occured between Hyper-V manager and the HA cluster. Please check the HA Hyper-V cluster and try to restart your Hyper-V.
    Sometimes after you restart the computer, the issue goes away.


    Wednesday, January 28, 2009 8:01 AM
  • Still no luck after reboot.



    Thursday, January 29, 2009 12:14 PM
  • Hi,


    Are you using SCVMM2008 to manage the VMs?


    Looks like the clustering condition is actually loss of communication between VMM server and hosts.


    Please perform the following updates to test whether this issue continues:


    Certain applications become very slow on a Windows Server 2008-based or Windows Vista SP1-based computer when a certificate with the SIA extension is installed


    Incorrect status codes that are returned in failover clusters may cause operations to fail on a Windows Server 2008-based computer


    Increased functionality and virtual machine control in the Windows Server 2008 Failover Cluster Management console for the Hyper-V role;EN-US;951308



    In addition, please check whether there are any errors in Event Viewer. If so, please tell me the details of the error, then we can isolate the issue.



    Best regards,

    Vincent Hu

    • Marked as answer by Vincent HuModerator Monday, February 02, 2009 1:58 AM
    • Unmarked as answer by Jason4520 Tuesday, February 03, 2009 2:30 PM
    Friday, January 30, 2009 7:25 AM
  • We are not using SCVMM2008 at this time.  The patches are loaded with the same result.  There are no errors in the eventlog or the Hyper-V eventlogs at the time of trying to connect to the Guest from the hyper-V console.  Still just sits there saying "Connecting to "SERVER"....."  It will finally fail with an error listed in the first post.  After numerous reties (sometime 20 min) it will finally connect.


    Tuesday, February 03, 2009 2:37 PM
  •  Hi Jason4520,

    If this issue continues, I think you need to analyze the dump file to narrow down the root cause of the issue. Unfortunately, it is not effective for us to debug the crash dump file here in the forum. Therefore, I would like to suggest that you contact Microsoft Customer Service and Support (CSS) via telephone so that a dedicated Support Professional can assist with your request, and you can get the most qualified pool of respondents.

    To obtain the phone numbers for specific technology request please take a look at the web site listed below:;EN-US;OfferProPhone#faq607

    Hope the issue will be resolved soon.

    Best regards,
    Vincent Hu


    Wednesday, February 04, 2009 8:32 AM
  • Hotfix 955805 corrected all the issues we experienced.

    • Marked as answer by Jason4520 Friday, March 13, 2009 9:50 PM
    Friday, March 13, 2009 9:50 PM
  • I am having the exact same issue as described. I am running Hyper-V on Windows Server 2008 R2 not 2008 so that Hotfix above does not apply because it's for 2008 only. Any resolution would be appreciated.


    Tuesday, January 18, 2011 10:31 PM
  • I had this issue.


    My issue was related to DNS & Hosts file.


    The host machine you are on must be able to resolve its host name to its own ip address.  

    In my case, I had an old hosts file entry that was hardwired the host name to an old IP address on our test network.  Changing the ip address to the production network ip address solved the problem.


    I hope that gives you some direction to head.


    • Proposed as answer by Phil C_ Tuesday, December 27, 2011 10:33 PM
    Tuesday, January 25, 2011 9:06 PM
  • You're a genius Jamie!  The Host file also cleared up my issue.  Well done!
    Thursday, December 15, 2011 9:13 PM
  • I had the same connection error after changing the Server IP address.

    Turned out there was a host file hardwiring the name of the server to it's old IP address. Once corrected, connectivity to the VM was restored :-)


    Thanks for the pointer Jamie.


    Sunday, January 15, 2012 1:10 PM
  • I had the same Problem. I solved it the dirty way by adding       [hostname]

    to the c:\windows\system32\drivers\etc\hosts file of the host System.

    Thursday, May 02, 2013 9:27 PM
  • my server is win2008 sp2 and when trying to install the hotfix it says the hotfix is not for my system.
    Friday, April 01, 2016 6:21 AM