none
Backup failed with "The version does not support this version of the file format" 0xc03a0005

    Question

  • So I have a batch that I am trying to run but doing so gives me an error.


    Batch
    @echo off
    
    
    
    
    
    
    
    rem script using WBADMIN.EXE on a Windows Server 2008 R2 Server
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    rem backup share UNC
    
    
    
    
    
    
    
    set backupshare=\\servername\vol
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    rem files and folders to include
    
    
    
    
    
    
    
    set include=E:\FolderIAmBackingUp
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    rem define date time variables for building the folder name
    
    
    
    
    
    
    
    set m=%date:~4,2%
    
    
    
    
    
    
    
    set d=%date:~7,2%
    
    
    
    
    
    
    
    set y=%date:~10,4%
    
    
    
    
    
    
    
    set h=%time:~0,2%
    
    
    
    
    
    
    
    set min=%time:~3,2%
    
    
    
    
    
    
    
    set sec=%time:~6,2%
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    set newfolder=%backupshare%\%computername%\%m%%d%%y%_%h%%min%%sec%
    
    
    
    
    
    
    
    echo Creating %newfolder%
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    mkdir %newfolder%
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    rem run the backup
    
    
    
    
    
    
    
    echo Backing up %include% to %newfolder%
    
    
    
    
    
    
    
    wbadmin start backup -backuptarget:%newfolder% -include:%include% -quiet
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    rem Clear variables
    
    
    
    
    
    
    
    set backupshare=
    
    
    
    
    
    
    
    set include=
    
    
    
    
    
    
    
    set m=
    
    
    
    
    
    
    
    set d=
    
    
    
    
    
    
    
    set y=
    
    
    
    
    
    
    
    set h=
    
    
    
    
    
    
    
    set min=
    
    
    
    
    
    
    
    set sec=
    
    
    
    
    
    
    
    
    set newfolder=





    Now when I run the batch it starts to work, then outputs the following:




    Retrieving volume information...
    
    
    
    
    
    
    
    This will back up volume AIC_JBOD_VOL_0(E:) (Selected Files) to \\backupserver\volume\ServerToBeBackedUp\01142010_115022.
    
    
    
    
    
    
    
    The backup operation to \\Backupservername\volume\ServerToBeBackedUp\01142010_115022 is starting.
    
    
    
    
    
    
    
    Creating a shadow copy of the volumes specified for backup...
    
    
    
    
    
    
    
    Creating a shadow copy of the volumes specified for backup...
    
    
    
    
    
    
    
    Please wait while files to backup for volume AIC_JBOD_VOL_0(E:) are identified.
    
    
    
    
    
    
    
    This might take several minutes.
    
    
    
    
    
    
    
    Found (0) files.
    
    
    
    
    
    
    
    File identification is complete.
    
    
    
    
    
    
    
    The backup of volume AIC_JBOD_VOL_0(E:) to \\Backupservername\volume\ServerToBeBackedUp\01142010_115022 is starting...
    
    
    
    
    
    
    
    The backup of volume AIC_JBOD_VOL_0(E:) could not be completed. Error: The version does not support this version of the file format.
    
    
    
    
    
    
    
    The backup operation stopped before completing.
    
    
    
    
    
    
    
    Summary of the backup operation:
    
    
    
    
    
    
    
    ------------------
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    The backup operation stopped before completing.
    
    
    
    
    
    
    
    Log of files successfully backed up:
    
    
    
    
    
    
    
    C:\Windows\Logs\WindowsServerBackup\Backup-14-01-2010_11-50-33.log
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    Log of files for which backup failed:
    
    
    
    
    
    
    
    C:\Windows\Logs\WindowsServerBackup\Backup_Error-14-01-2010_11-50-33.log
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    None of the source volumes were backed up.

    The remote path is a SMB share, ver. 3.0.33.
    • Edited by Bikash Agrawala Tuesday, March 09, 2010 6:34 AM adding error code.
    Thursday, January 14, 2010 5:18 PM

Answers

  • Thanks Daniel for confirming that the solution provided by me above worked for you. This will be useful for some other users on the forum as well.
    I will change the title that will be more useful information for others.

    Here is the conclusion:

      Failure: The file level backup to the NAS device running samba failed with "The version does not support this version of the file 
                    format"
      When:    The failure happens while the .VHD file created by Windows Backup is mounted during backup.
      Reason: The .VHD file is created as a sparse file and this is not supported by the native VHD driver and hence mounting of the .vhd failed.
      Solution:Adding "strict allocate = yes" to the smb.conf and restarting the samba.

      For all those who are not sure if the file created is a "Sparse File" or not and the above solution does not solve the problem then
      please run the netmon tool and send me the SBM traffic between the two nodes when the failure happened. The tool is available
      at the following link
     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en



    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    • Marked as answer by Bikash Agrawala Tuesday, February 16, 2010 9:36 AM
    • Edited by Bikash Agrawala Tuesday, February 16, 2010 9:52 AM Added some more information
    Tuesday, February 16, 2010 9:36 AM

All replies

  • Hello,
       We have seen this error once earlier where the backup to a network share was failing. And the reason was that the files that were created
       on the share was getting created as a "sparse" file. So can you please confirm once by running the following command and see if that is indeed
       a sparse file. VHD driver does not support mounting of a sparse VHD file and hence the backup was failing.

       This is a device specific behaviour where all the files that get created are sparse files. There should be an option to change this behaviour. So
       try changing this behaviour and retry the backup. 

        fsutil sparse queryflag D:\sharedFolder\WindowsImageBackup\Backup<Time>\<Guid>.vhd

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, January 18, 2010 11:15 AM
  • Not sure that may be the issue at hand.  If I do just the volume itself then it works no problem.  However in my test case I am not able to use just the volume since it is well over the 2TB limit, so I was using the include option to include folders instead of the entire volume.
    Monday, January 18, 2010 3:42 PM
  • Hello,
       Volume backup uses Block Level technology where the vhd file(Backup file) is not mounted. When the backup is done at File Level(Selected Files) then
       the backup file (.vhd) is mounted and the failure in your case would come while mounting a vhd which is sparse.

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Tuesday, January 19, 2010 5:11 AM
  • Hello,
      can you please send the output of the command requested above to confirm if the sparse file is indeed the cause of the problem in your case.

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, January 25, 2010 11:31 AM
  • I will try first thing tomorrow and let you know.  Thanks!
    Monday, January 25, 2010 10:16 PM
  • When running the FSUTIL I thought it had to be a local NTFS drive, so how would I run that command on a UNC path?

    Tuesday, January 26, 2010 11:39 AM
  • You need to run on local system where the share is hosted.
    Wednesday, January 27, 2010 5:36 AM
  • Hi - I've been watching this thread as I have exactly this issue too.

    I can't run the FSUtil command on the local system, because the local system is a Netgear ReadyNAS device that runs linux.

    It's weird, because the backups worked fine for a couple of weeks, then this issue started to happen.  And even weirder, I have two other R2 servers that are backing up fine to the same ReadyNAS-hosted share.

    Look fwd to hearing more from you Bikash.
    Wednesday, January 27, 2010 9:48 AM
  • Hello,
       Since we have seen this issue earlier with the root cause being the file on the share getting created as a Sparse File, we think that this should be the
       same issue. We however need to validate that and with your help and support we should be able to nail down the issue.

       Background:
       Just for the background the windows backup will have problems with sparse file only in case of "File Level" backup. For "Block Level" backup the sparse
       file is not a problem and the backup/recovery would succeed. This is because for Block Level Backup the .vhd file is never mounted whereas for File
       Level Backup the .vhd is mounted which does not support mounting of sparse file.

       Are you running Block Level(Full Volume) Or File Level (Selected file/folders in a volume) backups on the servers? If you are not sure then 
       we can find it out using the logs. Can you please zip the folder %windir%\logs\WindowsBackup and send it to bikasha-nospam@microsoft.com (Use the
       highlighted part only) for analyzing the problem. Please keep the subject of the email same as this thread for easy tracking.


      Validate Sparse File:
       In order to validate that the .vhd file is a sparse file we can try a couple of things:
       1. Try to mount the .vhd file using the diskmgmt.msc. Open the Diskmgmt.msc and click "Action" and the "Attach VHD" and then specify the path of
            the .vhd.   Then see if the .vhd is getting mounted. If not what is the error. If the error is the same as you get for the backup " ... Version does not
            support ... " then it is because of the sparse file.

       2. Try running the command "ls -ls" for the .vhd file. See if the file size and the space occupied by the file on the disk are different. My knowledge of
           Linux is poor. I just searhed on the net. May be you know a better way of checking this.

       3. Copy the .vhd file from the linux to Windows system and then run the FSUTIL command as mentioned above. If it shows Sparse then it is a sparse file.
           If it says not a sparse file then it may or may not be a sparse file as I am not sure of the behaviour of SMB from Linux to Windows. I will try to find it.

     The "strict allocate = yes" option of Samba will force it to not have UNIX style behaviour of creating sparse file. I found this option on the following link http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html . Can you try this and see the outcome.


       

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    • Edited by Bikash Agrawala Thursday, January 28, 2010 12:01 PM Added more info.
    • Proposed as answer by Bikash Agrawala Tuesday, February 16, 2010 5:27 AM
    Thursday, January 28, 2010 10:43 AM
  • Hello,
      Can you please share the outcome of the above operations.

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, February 01, 2010 8:07 AM
  • Hello,
      Can you please share the outcome of the above operations.

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Thursday, February 04, 2010 12:14 PM
  • Will do as soon as I get a chance to test it all out.
    Thursday, February 04, 2010 9:52 PM
  • I have checked the things you wanted.

    I am doing a backup that has the following options selected:

    Backup Items: Bare Metal Recovery, System State, System Reserved, C:, Selected files F:....
    File Excluded: From volumes F: and E:
    Advanced Option: VSS Copy Backup
    Destination: \\server\share\D3 (Remote Shared Folder)
    Backup Time: Everyday at 5:00 a.m

    I have sent the zipped log file to your email address.

    When I try to mount the biggest VHD in the backup destination folder I get the same error as the when the backup job runs - "The version does not support this version of the file format".  The same goes for the smaller more recent VHDs.

    FSUtil says the files are not set as sparse.


    • Proposed as answer by UANET AB Wednesday, April 22, 2015 12:29 PM
    • Unproposed as answer by UANET AB Wednesday, April 22, 2015 12:29 PM
    Saturday, February 06, 2010 1:36 AM
  • Hello,
       So far we have come across this problem only in case of backup to network share where the .vhd file is getting marked as sparse by the
       system hosting the share and hence the bakup would fail while mounting the .vhd as sparse file is not supported by the native vhd driver.
       This problem is only in File Level Backup.

       Since in your case .vhd is not reported as a sparse file, it is a different problem. I need to involve other teams within Microsoft to find out the cause
       of the problem as this is not a backup related problem. I will keep my findings updated here.

    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, February 08, 2010 6:12 AM
  • Hi all,

    I had the same issue while running windows serverbackup on a server 2008 r2 machine. The solution provided by Bikash worked for me. First, i checked on my qnap nas if the file was indeed a sparse file. One way to detect sparse files is when their displayed size (ls -l) is larger than the number of blocks used by them (ls -s) x 512, at least when the filesystem doesn't perform data compression. As you can guess, the vhd created by windows serverbackup was a sparse file.

    Next, i added "strict allocate = yes" to the [global] section of smb.conf. Restarted samba and restarted the backup. Now the backup works fine :). Thanks for this solution.


    Monday, February 15, 2010 4:17 PM
  • Thanks Daniel for confirming that the solution provided by me above worked for you. This will be useful for some other users on the forum as well.
    I will change the title that will be more useful information for others.

    Here is the conclusion:

      Failure: The file level backup to the NAS device running samba failed with "The version does not support this version of the file 
                    format"
      When:    The failure happens while the .VHD file created by Windows Backup is mounted during backup.
      Reason: The .VHD file is created as a sparse file and this is not supported by the native VHD driver and hence mounting of the .vhd failed.
      Solution:Adding "strict allocate = yes" to the smb.conf and restarting the samba.

      For all those who are not sure if the file created is a "Sparse File" or not and the above solution does not solve the problem then
      please run the netmon tool and send me the SBM traffic between the two nodes when the failure happened. The tool is available
      at the following link
     

    http://www.microsoft.com/downloads/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en



    Thanks,

    Bikash Agrawala [MSFT]

    --------------------------------------------------------------------------------- This posting is provided "AS IS" with no warranties, and confers no rights

    • Marked as answer by Bikash Agrawala Tuesday, February 16, 2010 9:36 AM
    • Edited by Bikash Agrawala Tuesday, February 16, 2010 9:52 AM Added some more information
    Tuesday, February 16, 2010 9:36 AM
  • The "strict allocate = yes" worked somewhat for my ReadyNAS NV, however, it has the side effect of causing file copies (to the unit) of 1.9GB or greater to fail.

    It would be better if Microsoft would simply fix the Windows Server Backup so it would just work.

     

     

    Saturday, May 01, 2010 10:30 PM
  • Hi Bikash,

     

      I've followed the steps above and am in a similar situation.  I'm running WS2008R2 and am trying to back up to a SAMBA drive.  strict_allocate = yes has been enabled in the smb server's smb.conf, and SAMBA was restarted.  Still no luck.

     

      I ran the MS network capture utility mentioned and will email you the results.  If you could please take a look, it would really help.  

     

    Thanks!

     

    Felix

    Friday, February 04, 2011 8:04 PM
  • Bikash,

     

      Where can I find your email address?

     

    -f

    Friday, February 04, 2011 8:12 PM
  • It would be better if Microsoft would simply fix the Windows Server Backup so it would just work.
    That would defeat Microsoft's goal.  The plan is to break your spirit to the point that you feel grateful for  every crumb that Microsoft tosses your way and spend all your money on upgrades.
    Tuesday, March 01, 2011 6:49 PM
  • So I see in this blog a lot of talk about ways to make the backups work in the future.

    I am I just missing how to access a VHD file that I already created? One that I now need since my hardrive crashed and I need the data contained within it?

    I wish that there was a warning message that popped up to tell me that if I write spool the recovery backup to a NAS then it will become unusable.

    MarkM


    FamilyMan
    Thursday, April 14, 2011 10:12 PM
  • Okay so I moved the VHD file to an NTFS partition and it is working now.
    FamilyMan
    Friday, April 15, 2011 6:09 PM
  • G'day All,

     

    If you read "Best Practices for AD DS Backup and Recovery" (http://technet.microsoft.com/en-us/library/cc753294%28WS.10%29.aspx), you will find that it states the following:

     

    Create a backup volume on a dedicated internal or external hard drive. You cannot use a network shared folder as a backup target for a system state backup. To store a system state backup on a network shared folder, you must use a local volume as the backup target and then copy the backup to the network shared folder. 

     

    I had the issue where when my backup contained System State backup, it would fail with "The operation was stopped. Detailed error: The requested operation could not be completed due to a file system limitation".  I ended up creating a new iSCSI LUN for System State backups.  Resolved my issue at least.

     

    I tried modifying my "smb.conf", however adding the "strict allocate = yes" didn't fix it.

     

     

    Hope this information helps.

     

    Regards

     

    Radon86


    • Edited by Radon86 Sunday, December 18, 2011 2:41 AM
    • Proposed as answer by Radon86 Sunday, December 18, 2011 8:41 PM
    Sunday, December 18, 2011 2:39 AM
  • I tried this but no luck getting this to work on my readynas NV+. I both added the "strict allocate = yes" string to the /etc/frontview/samba/smb.conf.* and the /etc/samba/smb.conf [global] files without any effect. I still get the "the version does not support this version of the file format" error whenever I try to back up my windows home server 2011 (WHS 2011) to my ReadyNAS NV. Was anyone able to get this to work? Can anyone post detailed instructions on how to get this to work or how to troubleshoot this?

    Thanks,

    H
    Tuesday, January 03, 2012 8:57 PM
  • Hi

    I've had the same problem with a ReadyNAS Duo and after reading various forums I've got a solution that works for me..

    1. Edit the [global] section of /etc/samba/smb.conf and add the line 'strict allocate = yes' as suggested.

    2. Edit /etc/fstab and change the filesystem of your data partition from ext3 to ext2. My NAS had this:

    /dev/c/c    /c     ext3      defaults,acl,user_xattr,usrquota,grpquota,noatime    0    2

    and I just changed ext3 to ext2.

    (You'll need reboot or remount/restart the services here)

    3. Finally, make sure you're not backing up to a location that already has a sparse VHD file in it.. I just renamed the existing failed WindowsImageBackup\MACHINE folder so it would create a new backup image.

    Since doing these things my file-level backups from Server 2008 R2 to ReadyNAS Duo seem to be spot on.. Backup and restores are both working successfully.

    Hope that helps

    Mark


    • Edited by Starstream Wednesday, January 25, 2012 1:28 PM
    Wednesday, January 25, 2012 1:24 PM
  • One quick thought,

    If you don't need to exclude files from your backup, use the "-allcritical" option in your command line. AS IN:

    wbadmin start backup -backupTarget:\\backup1\backupdrive1\ -include:c: -user:administrator -password:xxxx -systemState -vssFull -allcritical -quiet

    This changes it to Block backup and gets rid of the error. Of course, if you need to exclude folders, you need to enter the smb.conf and add the line 'strict allocate = yes'.

    Robert

    • Proposed as answer by thewrz Thursday, October 11, 2012 3:16 PM
    Sunday, July 22, 2012 9:43 PM
  • @Robert: I tried this (on Server 2012) and got the same "..file format.." message. My destination share is a CIFS share on an open-e Linux NAS..

    I can backup to a windows share on another machine, and then move the backup to the NAS. Inelegant and slow, but it works.


    Pete Wason

    Thursday, August 29, 2013 6:29 PM
  • hi how do you edit the samba conf?

    strict allocate = yes

    i m managing my qnap from the web interface

    thanks

    Friday, May 09, 2014 3:51 PM