Backup and Restore image fails 3TB Advanced Format Drive Windows 7-32 SP1


  • Windows native backp fails to create an System Image, or a Complete PC Backup.

    This occurs in Windows 7, 64 bit Professional, Windows 7, 32bit Ultimate, Windows Vista Business, 32 bit. It occurs in 6 different computers I've tried. All the backup drives are 3TB. I have tried Seagte USB and Hitachi USB drives. 4 of them. The Windows 7 Ultimate, 32bit machine has SP1. All operating systems are using the current Service Packs, and all of the MS Updates including all of the recommended harware drivers. All of the systems are using the latest BIOS, firmware and OEM drivers as well.

    It looks like the issue may be causes by a deficiency in Windows related to the Advanced Format drive spec. All of the computers that qualified had the AF hotfix applied; Advanced Format Drives 512e 4k, Vista and 2008 - KB2470478, Windows 7, and 2008 R2 KB982018

    Error messages follow:

    The Backup Failed.

    Error message: One of the backup files could not be created. (0x8078002A)

    The request could not be perfomed because of an I/O error. (0x8007045D)

    This deficiency seems to apply across the board to different hardware manufacturers of external hard drives.

    From what I have heard, Western Digital may have a format utility that addresses this issue, but only for WD drives.


    Wednesday, April 13, 2011 12:29 AM

All replies

  • Yes...I am having the same problem exactly, on multiple Windows 7/64 Home installations, with a Seagate 3GB external.
    Saturday, May 14, 2011 7:46 PM
  • I am having the same issue as well with my 3TB Seagate (Seagate has stated to get with TS of Microsoft) and I have no issues doing the same backup on my 500G WD HD. I know this has to do with the fact that my Seagate HD is using Advance Formatted Disk and by following the steps described in KB: the issue still continues. This is very frustrating and now I have a useless 3TB drive that is unable to do backups b/c of the OS. I hate to spend more on 3rd party software when the OS is suppose to provide the same functionality.

    I've tried everything the KB has stated and also steps from moderates on other posts on this issue.(I have yet to find a post on here having a resolution for anyone)

    1. Ensured Im running SP1

    2. Ran check disk for error on both drives. (even though my hp pavilion is 4 days out of the box and the HD is also new)

    3. install update according to KB 982018


    After the hotfix was installed I'm still getting the same output


    C:\Windows\system32>Fsutil fsinfo ntfsinfo F:
    NTFS Volume Serial Number :       0x7420b59d20b566b0
    Version :                         3.1
    Number Sectors :                  0x000000002baa0a1f
    Total Clusters :                  0x000000002baa0a1f
    Free Clusters  :                  0x000000002b78d793
    Total Reserved :                  0x00000000000df800
    Bytes Per Sector  :               4096
    Bytes Per Physical Sector :       <Not Supported> <-------
    Bytes Per Cluster :               4096
    Bytes Per FileRecord Segment    : 4096
    Clusters Per FileRecord Segment : 1
    Mft Valid Data Length :           0x0000000000d00000
    Mft Start Lcn  :                  0x00000000000c0000
    Mft2 Start Lcn :                  0x0000000015d5050f
    Mft Zone Start :                  0x00000000000c0100
    Mft Zone End   :                  0x00000000000cc900
    RM Identifier:        230A744D-C625-11E0-9ECD-101F740C3A98



    Any assistance is appreciated





    Sunday, August 14, 2011 4:50 AM
  • Hi David,

    Did you have found any error message?

    Check if all the files have been created on the hard drive.

    Check the Volume shadow copy service in services window. To check follow these steps:

    i.                    Click Start and type services.msc in the search box

    ii.                  Search for the Volume shadow copy service

    Make sure the start- up type is automatic.  Steps to set the services to automatic

    i.                    Search for the service

    ii.                  Right click on the service

    iii.                If the service is stopped then Start the service

    iv.                 Select Properties

    v.                   And in the Start-up type select Automatic


     This is the most definitive answer I can find so am taking this as the answer.





    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    Monday, August 15, 2011 6:20 AM
  • I want to report exactly the same error with the Seagate 3TB (Freeagent Goflex Desk) on Win 7 64 (fully patched as of today).  Never had problems with 1 & 2TB drives.

    I need to (system) image a volume that is slightly under 2 TB - and by that I mean a real (binary) 2TB, not the <1.8TB (decimal) equivalent that the disk manufacturers use.  Does anyone know of a sufficiently large USB external drive that actually works with windows backup?  I suspect I might be returning this Seagate drive on Monday...

    Edit: I just tried deleting the 3TB volume and making a new 2TB 'simple' volume (just large enough for my needs) but I'm still having same error.

    • Edited by Paul_42 Friday, September 02, 2011 3:12 PM
    Friday, September 02, 2011 11:30 AM
  • I commented earlier, but I finally solved my own issue.

    Windows backup will not work with the Seagate >2tb partition and formatting the drive ships with - this issue is reported on multiple forums.  I believe it is because Seagate does something tricky with the MBR partition tables (which are normally limited to 2GB total).

    The solution is to switch to the new GPT (GUID Partition Table) format.  The down side it that this ONLY works with recent 64 bit operating systems (Server 2008, Vista SP1 or Windows 7).  If you have a 32 bit operating system, or an older 64 bit one (e.g. Vista without the service pack, or server 2003), you will NOT be able to use GPT.

    Also, GPT can only be used as a boot disk if your BIOS supports it, although this does not affect data/backup disks.

    To make the switch:

    1. Download Seagate's DiskWizard software, and use it to delete any existing partitions and re partition the disk into a single GPT partition (I found DiskWizard will throw errors if a bitlocker drive is present but hasn't been unlocked, but these errors are benign).  You must use DiskWizard, because the build in Windows partitioning tool won't let you exceed 2GB, but you only need DiskWizard to make the partition.

    2. Go to Control Panel -> Administrative Tools -> Computer Management -> Disk Management and format the partition as usual with NTFS.  I did a (2 day) slow format because I had been messing around with my disk a lot trying to get it to work, but I assume a quick format would have worked as well.

    3. Assign the disk a drive letter (for some reason the drive letter I assigned when I started the format didn't 'stick', so I had to do it manually at the end).

    Now windows backup is working perfectly on the 3GB (actually 2.7GB) partition.  Of course, the disk can now only be used on supported 64bit OS's, but that's fine for a backup disk.

    Thursday, July 19, 2012 7:12 AM
  • Help I have same problem on a win7 64 I've tried this item and is still failing.
    Saturday, July 28, 2012 12:19 AM
  • Hi jess1831,

    Check the link below for the update on compatibility with AF 4K native sectors. AF native 4k sectors will be supported in windows 8 and Windows Server 2012, I'm afraid with windows 7 you are out of luck unless your drive supports native 512 or 512 emulation sectors.

    From command promt, (run as administrator) use the command:

    fsutil fsinfo ntfsinfo x:  (where x is the drive letter for the drive you want to check)

    It will show  the sector size in you 3TB drive or any other drive.

    Saturday, July 28, 2012 9:35 PM
  • It is now December 2014.  I walked next door to Staples and purchased a Western Digital MyBook Desktop USB 3.0 drive, 3TB in size.  

    I can confirm that running the WD Quick Formatter tool with the default compatibility setting (Windows Vista and Later) enables the 512e feature as shown in fsutil fsinfo ntfsinfo.

    This is the first time I have ever been able to successfully create a disk image backup of my Windows 7 x64 workstation to an Advanced Format Drive over 2TB in size.  Please know that--over two years later--you are still doing the lord's work!

    This is huge because it does not feel great to go to a client and say "Sorry, you're going to need to drop $600+ on server backup software because Microsoft doesn't want to patch a known issue from 2011--they consider Windows 7 and Server 2008 R2 obsolete and want you to upgrade again!"  Inexcusable, in my opinion.

    Note that Seagate does not have a tool like the Western Digital one--at least that I have been able to find.  Our go-to drive is normally the 4TB Seagate USB 3.0 desktop drive, but our clients need to be able to take full disk image backups of their machines.

    I'll be buying these WD drives for on-site/off-site cycling Server 2008 R2 backup routines.

    Wednesday, December 10, 2014 2:34 AM